openSUSE Security Update: Security update for sphinx
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2022:0046-1
Rating:             moderate
References:         #1195227 
Cross-References:   CVE-2020-29050
CVSS scores:
                    CVE-2020-29050 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Affected Products:
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:


   sphinx was updated to fix the following issues:

   - CVE-2020-29050: SphinxSearch in Sphinx Technologies Sphinx through 3.1.1
     allows directory traversal (in conjunction with CVE-2019-14511) because
     the mysql client can be used for CALL SNIPPETS and load_file operations
     on a full pathname (e.g., a file in the /etc directory). (boo#1195227)


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-2022-46=1



Package List:

   - openSUSE Leap 15.4 (aarch64 i586 ppc64le s390x x86_64):

      libsphinxclient-0_0_1-2.2.11-lp154.3.3.1
      libsphinxclient-devel-2.2.11-lp154.3.3.1
      sphinx-2.2.11-lp154.3.3.1
      sphinx-debuginfo-2.2.11-lp154.3.3.1
      sphinx-debugsource-2.2.11-lp154.3.3.1


References:

   https://www.suse.com/security/cve/CVE-2020-29050.html
   https://bugzilla.suse.com/1195227