openSUSE Security Update: Security update for wireshark
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2022:0375-1
Rating:             moderate
References:         #1194166 #1194167 #1194168 #1194169 #1194170 
                    #1194171 #1194780 SLE-18727 
Cross-References:   CVE-2021-4181 CVE-2021-4182 CVE-2021-4183
                    CVE-2021-4184 CVE-2021-4185 CVE-2021-4190
                   
CVSS scores:
                    CVE-2021-4181 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2021-4181 (SUSE): 4.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
                    CVE-2021-4182 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2021-4182 (SUSE): 4.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
                    CVE-2021-4183 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
                    CVE-2021-4183 (SUSE): 3.3 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
                    CVE-2021-4184 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2021-4184 (SUSE): 4.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
                    CVE-2021-4185 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2021-4185 (SUSE): 4.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
                    CVE-2021-4190 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2021-4190 (SUSE): 4.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L

Affected Products:
                    openSUSE Leap 15.3
______________________________________________________________________________

   An update that solves 6 vulnerabilities, contains one
   feature and has one errata is now available.

Description:

   This update for wireshark fixes the following issues:

   Update to version 3.6.1:

   - CVE-2021-4185: RTMPT dissector infinite loop (bsc#1194166)
   - CVE-2021-4184: BitTorrent DHT dissector infinite loop (bsc#1194167)
   - CVE-2021-4183: pcapng file parser crash (bsc#1194168)
   - CVE-2021-4182: RFC 7468 file parser infinite loop (bsc#1194169)
   - CVE-2021-4181: Sysdig Event dissector crash (bsc#1194170)
   - CVE-2021-4190: Kafka dissector infinite loop (bsc#1194171)
   - Support for Shared Memory Communications (SMC) (jsc#SLE-18727)


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2022-375=1



Package List:

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      libvirt-7.1.0-150300.6.23.1
      libvirt-admin-7.1.0-150300.6.23.1
      libvirt-admin-debuginfo-7.1.0-150300.6.23.1
      libvirt-client-7.1.0-150300.6.23.1
      libvirt-client-debuginfo-7.1.0-150300.6.23.1
      libvirt-daemon-7.1.0-150300.6.23.1
      libvirt-daemon-config-network-7.1.0-150300.6.23.1
      libvirt-daemon-config-nwfilter-7.1.0-150300.6.23.1
      libvirt-daemon-debuginfo-7.1.0-150300.6.23.1
      libvirt-daemon-driver-interface-7.1.0-150300.6.23.1
      libvirt-daemon-driver-interface-debuginfo-7.1.0-150300.6.23.1
      libvirt-daemon-driver-lxc-7.1.0-150300.6.23.1
      libvirt-daemon-driver-lxc-debuginfo-7.1.0-150300.6.23.1
      libvirt-daemon-driver-network-7.1.0-150300.6.23.1
      libvirt-daemon-driver-network-debuginfo-7.1.0-150300.6.23.1
      libvirt-daemon-driver-nodedev-7.1.0-150300.6.23.1
      libvirt-daemon-driver-nodedev-debuginfo-7.1.0-150300.6.23.1
      libvirt-daemon-driver-nwfilter-7.1.0-150300.6.23.1
      libvirt-daemon-driver-nwfilter-debuginfo-7.1.0-150300.6.23.1
      libvirt-daemon-driver-qemu-7.1.0-150300.6.23.1
      libvirt-daemon-driver-qemu-debuginfo-7.1.0-150300.6.23.1
      libvirt-daemon-driver-secret-7.1.0-150300.6.23.1
      libvirt-daemon-driver-secret-debuginfo-7.1.0-150300.6.23.1
      libvirt-daemon-driver-storage-7.1.0-150300.6.23.1
      libvirt-daemon-driver-storage-core-7.1.0-150300.6.23.1
      libvirt-daemon-driver-storage-core-debuginfo-7.1.0-150300.6.23.1
      libvirt-daemon-driver-storage-disk-7.1.0-150300.6.23.1
      libvirt-daemon-driver-storage-disk-debuginfo-7.1.0-150300.6.23.1
      libvirt-daemon-driver-storage-gluster-7.1.0-150300.6.23.1
      libvirt-daemon-driver-storage-gluster-debuginfo-7.1.0-150300.6.23.1
      libvirt-daemon-driver-storage-iscsi-7.1.0-150300.6.23.1
      libvirt-daemon-driver-storage-iscsi-debuginfo-7.1.0-150300.6.23.1
      libvirt-daemon-driver-storage-iscsi-direct-7.1.0-150300.6.23.1
      libvirt-daemon-driver-storage-iscsi-direct-debuginfo-7.1.0-150300.6.23.1
      libvirt-daemon-driver-storage-logical-7.1.0-150300.6.23.1
      libvirt-daemon-driver-storage-logical-debuginfo-7.1.0-150300.6.23.1
      libvirt-daemon-driver-storage-mpath-7.1.0-150300.6.23.1
      libvirt-daemon-driver-storage-mpath-debuginfo-7.1.0-150300.6.23.1
      libvirt-daemon-driver-storage-scsi-7.1.0-150300.6.23.1
      libvirt-daemon-driver-storage-scsi-debuginfo-7.1.0-150300.6.23.1
      libvirt-daemon-hooks-7.1.0-150300.6.23.1
      libvirt-daemon-lxc-7.1.0-150300.6.23.1
      libvirt-daemon-qemu-7.1.0-150300.6.23.1
      libvirt-debugsource-7.1.0-150300.6.23.1
      libvirt-devel-7.1.0-150300.6.23.1
      libvirt-libs-7.1.0-150300.6.23.1
      libvirt-libs-debuginfo-7.1.0-150300.6.23.1
      libvirt-lock-sanlock-7.1.0-150300.6.23.1
      libvirt-lock-sanlock-debuginfo-7.1.0-150300.6.23.1
      libvirt-nss-7.1.0-150300.6.23.1
      libvirt-nss-debuginfo-7.1.0-150300.6.23.1
      libwireshark15-3.6.1-3.68.1
      libwireshark15-debuginfo-3.6.1-3.68.1
      libwiretap12-3.6.1-3.68.1
      libwiretap12-debuginfo-3.6.1-3.68.1
      libwsutil13-3.6.1-3.68.1
      libwsutil13-debuginfo-3.6.1-3.68.1
      wireshark-3.6.1-3.68.1
      wireshark-debuginfo-3.6.1-3.68.1
      wireshark-debugsource-3.6.1-3.68.1
      wireshark-devel-3.6.1-3.68.1
      wireshark-plugin-libvirt-7.1.0-150300.6.23.1
      wireshark-plugin-libvirt-debuginfo-7.1.0-150300.6.23.1
      wireshark-ui-qt-3.6.1-3.68.1
      wireshark-ui-qt-debuginfo-3.6.1-3.68.1

   - openSUSE Leap 15.3 (aarch64 x86_64):

      libvirt-daemon-driver-storage-rbd-7.1.0-150300.6.23.1
      libvirt-daemon-driver-storage-rbd-debuginfo-7.1.0-150300.6.23.1

   - openSUSE Leap 15.3 (x86_64):

      libvirt-client-32bit-debuginfo-7.1.0-150300.6.23.1
      libvirt-daemon-driver-libxl-7.1.0-150300.6.23.1
      libvirt-daemon-driver-libxl-debuginfo-7.1.0-150300.6.23.1
      libvirt-daemon-xen-7.1.0-150300.6.23.1
      libvirt-devel-32bit-7.1.0-150300.6.23.1

   - openSUSE Leap 15.3 (noarch):

      libvirt-bash-completion-7.1.0-150300.6.23.1
      libvirt-doc-7.1.0-150300.6.23.1


References:

   https://www.suse.com/security/cve/CVE-2021-4181.html
   https://www.suse.com/security/cve/CVE-2021-4182.html
   https://www.suse.com/security/cve/CVE-2021-4183.html
   https://www.suse.com/security/cve/CVE-2021-4184.html
   https://www.suse.com/security/cve/CVE-2021-4185.html
   https://www.suse.com/security/cve/CVE-2021-4190.html
   https://bugzilla.suse.com/1194166
   https://bugzilla.suse.com/1194167
   https://bugzilla.suse.com/1194168
   https://bugzilla.suse.com/1194169
   https://bugzilla.suse.com/1194170
   https://bugzilla.suse.com/1194171
   https://bugzilla.suse.com/1194780