openSUSE: 2022:0498-1 important: expat | LinuxSecurity.com

   openSUSE Security Update: Security update for expat
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2022:0498-1
Rating:             important
References:         #1195054 #1195217 
Cross-References:   CVE-2022-23852 CVE-2022-23990
CVSS scores:
                    CVE-2022-23852 (NVD) : 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-23852 (SUSE): 8.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-23990 (NVD) : 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-23990 (SUSE): 8.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Affected Products:
                    openSUSE Leap 15.3
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for expat fixes the following issues:

   - CVE-2022-23852: Fixed signed integer overflow in XML_GetBuffer
     (bsc#1195054).
   - CVE-2022-23990: Fixed integer overflow in the doProlog function
     (bsc#1195217).


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2022-498=1



Package List:

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      expat-2.2.5-3.12.1
      expat-debuginfo-2.2.5-3.12.1
      expat-debugsource-2.2.5-3.12.1
      libexpat-devel-2.2.5-3.12.1
      libexpat1-2.2.5-3.12.1
      libexpat1-debuginfo-2.2.5-3.12.1

   - openSUSE Leap 15.3 (x86_64):

      expat-32bit-debuginfo-2.2.5-3.12.1
      libexpat-devel-32bit-2.2.5-3.12.1
      libexpat1-32bit-2.2.5-3.12.1
      libexpat1-32bit-debuginfo-2.2.5-3.12.1


References:

   https://www.suse.com/security/cve/CVE-2022-23852.html
   https://www.suse.com/security/cve/CVE-2022-23990.html
   https://bugzilla.suse.com/1195054
   https://bugzilla.suse.com/1195217

openSUSE: 2022:0498-1 important: expat

February 18, 2022
An update that fixes two vulnerabilities is now available

Description

This update for expat fixes the following issues: - CVE-2022-23852: Fixed signed integer overflow in XML_GetBuffer (bsc#1195054). - CVE-2022-23990: Fixed integer overflow in the doProlog function (bsc#1195217).

 

Patch

Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2022-498=1


Package List

- openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64): expat-2.2.5-3.12.1 expat-debuginfo-2.2.5-3.12.1 expat-debugsource-2.2.5-3.12.1 libexpat-devel-2.2.5-3.12.1 libexpat1-2.2.5-3.12.1 libexpat1-debuginfo-2.2.5-3.12.1 - openSUSE Leap 15.3 (x86_64): expat-32bit-debuginfo-2.2.5-3.12.1 libexpat-devel-32bit-2.2.5-3.12.1 libexpat1-32bit-2.2.5-3.12.1 libexpat1-32bit-debuginfo-2.2.5-3.12.1


References

https://www.suse.com/security/cve/CVE-2022-23852.html https://www.suse.com/security/cve/CVE-2022-23990.html https://bugzilla.suse.com/1195054 https://bugzilla.suse.com/1195217


Severity
Announcement ID: openSUSE-SU-2022:0498-1
Rating: important
Affected Products: openSUSE Leap 15.3 . Affected Products: openSUSE Leap 15.3 .

Related News

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.