openSUSE Security Update: Security update for python-Twisted
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2022:0499-1
Rating:             important
References:         #1195667 
Cross-References:   CVE-2022-21712
CVSS scores:
                    CVE-2022-21712 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
                    CVE-2022-21712 (SUSE): 7.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N

Affected Products:
                    openSUSE Leap 15.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for python-Twisted fixes the following issues:

   - CVE-2022-21712: Fixed secret exposure in cross-origin redirects by
     properly removing sensitive headers when redirecting to a different
     origin (bsc#1195667).


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-499=1

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2022-499=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      python-Twisted-debuginfo-19.10.0-3.6.1
      python-Twisted-debugsource-19.10.0-3.6.1
      python2-Twisted-19.10.0-3.6.1
      python2-Twisted-debuginfo-19.10.0-3.6.1
      python3-Twisted-debuginfo-19.10.0-3.6.1

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      python-Twisted-debuginfo-19.10.0-3.6.1
      python-Twisted-debugsource-19.10.0-3.6.1
      python-Twisted-doc-19.10.0-3.6.1
      python2-Twisted-19.10.0-3.6.1
      python2-Twisted-debuginfo-19.10.0-3.6.1
      python3-Twisted-19.10.0-3.6.1
      python3-Twisted-debuginfo-19.10.0-3.6.1


References:

   https://www.suse.com/security/cve/CVE-2022-21712.html
   https://bugzilla.suse.com/1195667