openSUSE Security Update: Security update for containerd
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2022:0720-1
Rating:             moderate
References:         #1196441 
Cross-References:   CVE-2022-23648
CVSS scores:
                    CVE-2022-23648 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Affected Products:
                    openSUSE Leap 15.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for containerd fixes the following issues:

   - CVE-2022-23648: A specially-crafted image configuration could gain
     access to read-only copies of arbitrary files and directories on the
     host (bsc#1196441).


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-720=1

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2022-720=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      containerd-1.4.12-63.1
      containerd-ctr-1.4.12-63.1

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      containerd-1.4.12-63.1
      containerd-ctr-1.4.12-63.1


References:

   https://www.suse.com/security/cve/CVE-2022-23648.html
   https://bugzilla.suse.com/1196441