openSUSE Security Update: Security update for flac
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2022:0815-1
Rating:             moderate
References:         #1196660 
Cross-References:   CVE-2021-0561
CVSS scores:
                    CVE-2021-0561 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
                    CVE-2021-0561 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Affected Products:
                    openSUSE Leap 15.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for flac fixes the following issues:

   - CVE-2021-0561: Fixed out of bound write in
     append_to_verify_fifo_interleaved_ (bsc#1196660).


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-815=1

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2022-815=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      flac-1.3.2-3.9.1
      flac-debuginfo-1.3.2-3.9.1
      flac-debugsource-1.3.2-3.9.1
      flac-devel-1.3.2-3.9.1
      libFLAC++6-1.3.2-3.9.1
      libFLAC++6-debuginfo-1.3.2-3.9.1
      libFLAC8-1.3.2-3.9.1
      libFLAC8-debuginfo-1.3.2-3.9.1

   - openSUSE Leap 15.4 (x86_64):

      flac-devel-32bit-1.3.2-3.9.1
      libFLAC++6-32bit-1.3.2-3.9.1
      libFLAC++6-32bit-debuginfo-1.3.2-3.9.1
      libFLAC8-32bit-1.3.2-3.9.1
      libFLAC8-32bit-debuginfo-1.3.2-3.9.1

   - openSUSE Leap 15.4 (noarch):

      flac-doc-1.3.2-3.9.1

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      flac-1.3.2-3.9.1
      flac-debuginfo-1.3.2-3.9.1
      flac-debugsource-1.3.2-3.9.1
      flac-devel-1.3.2-3.9.1
      libFLAC++6-1.3.2-3.9.1
      libFLAC++6-debuginfo-1.3.2-3.9.1
      libFLAC8-1.3.2-3.9.1
      libFLAC8-debuginfo-1.3.2-3.9.1

   - openSUSE Leap 15.3 (x86_64):

      flac-devel-32bit-1.3.2-3.9.1
      libFLAC++6-32bit-1.3.2-3.9.1
      libFLAC++6-32bit-debuginfo-1.3.2-3.9.1
      libFLAC8-32bit-1.3.2-3.9.1
      libFLAC8-32bit-debuginfo-1.3.2-3.9.1

   - openSUSE Leap 15.3 (noarch):

      flac-doc-1.3.2-3.9.1


References:

   https://www.suse.com/security/cve/CVE-2021-0561.html
   https://bugzilla.suse.com/1196660