openSUSE Security Update: Security update for openssl-1_0_0
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2022:0856-1
Rating:             important
References:         #1196877 
Cross-References:   CVE-2022-0778
CVSS scores:
                    CVE-2022-0778 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Affected Products:
                    openSUSE Leap 15.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for openssl-1_0_0 fixes the following issues:

   - CVE-2022-0778: Infinite loop in BN_mod_sqrt() reachable when parsing
     certificates (bsc#1196877).


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-856=1

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2022-856=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      libopenssl-1_0_0-devel-1.0.2p-3.49.1
      libopenssl10-1.0.2p-3.49.1
      libopenssl10-debuginfo-1.0.2p-3.49.1
      libopenssl1_0_0-1.0.2p-3.49.1
      libopenssl1_0_0-debuginfo-1.0.2p-3.49.1
      libopenssl1_0_0-hmac-1.0.2p-3.49.1
      libopenssl1_0_0-steam-1.0.2p-3.49.1
      libopenssl1_0_0-steam-debuginfo-1.0.2p-3.49.1
      openssl-1_0_0-1.0.2p-3.49.1
      openssl-1_0_0-cavs-1.0.2p-3.49.1
      openssl-1_0_0-cavs-debuginfo-1.0.2p-3.49.1
      openssl-1_0_0-debuginfo-1.0.2p-3.49.1
      openssl-1_0_0-debugsource-1.0.2p-3.49.1

   - openSUSE Leap 15.4 (noarch):

      openssl-1_0_0-doc-1.0.2p-3.49.1

   - openSUSE Leap 15.4 (x86_64):

      libopenssl-1_0_0-devel-32bit-1.0.2p-3.49.1
      libopenssl1_0_0-32bit-1.0.2p-3.49.1
      libopenssl1_0_0-32bit-debuginfo-1.0.2p-3.49.1
      libopenssl1_0_0-hmac-32bit-1.0.2p-3.49.1
      libopenssl1_0_0-steam-32bit-1.0.2p-3.49.1
      libopenssl1_0_0-steam-32bit-debuginfo-1.0.2p-3.49.1

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      libopenssl-1_0_0-devel-1.0.2p-3.49.1
      libopenssl10-1.0.2p-3.49.1
      libopenssl10-debuginfo-1.0.2p-3.49.1
      libopenssl1_0_0-1.0.2p-3.49.1
      libopenssl1_0_0-debuginfo-1.0.2p-3.49.1
      libopenssl1_0_0-hmac-1.0.2p-3.49.1
      libopenssl1_0_0-steam-1.0.2p-3.49.1
      libopenssl1_0_0-steam-debuginfo-1.0.2p-3.49.1
      openssl-1_0_0-1.0.2p-3.49.1
      openssl-1_0_0-cavs-1.0.2p-3.49.1
      openssl-1_0_0-cavs-debuginfo-1.0.2p-3.49.1
      openssl-1_0_0-debuginfo-1.0.2p-3.49.1
      openssl-1_0_0-debugsource-1.0.2p-3.49.1

   - openSUSE Leap 15.3 (noarch):

      openssl-1_0_0-doc-1.0.2p-3.49.1

   - openSUSE Leap 15.3 (x86_64):

      libopenssl-1_0_0-devel-32bit-1.0.2p-3.49.1
      libopenssl1_0_0-32bit-1.0.2p-3.49.1
      libopenssl1_0_0-32bit-debuginfo-1.0.2p-3.49.1
      libopenssl1_0_0-hmac-32bit-1.0.2p-3.49.1
      libopenssl1_0_0-steam-32bit-1.0.2p-3.49.1
      libopenssl1_0_0-steam-32bit-debuginfo-1.0.2p-3.49.1


References:

   https://www.suse.com/security/cve/CVE-2022-0778.html
   https://bugzilla.suse.com/1196877