openSUSE Security Update: Security update for MozillaThunderbird
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2022:0906-1
Rating:             important
References:         #1196900 
Cross-References:   CVE-2022-26381 CVE-2022-26383 CVE-2022-26384
                    CVE-2022-26386 CVE-2022-26387
Affected Products:
                    openSUSE Leap 15.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that fixes 5 vulnerabilities is now available.

Description:

   This update for MozillaThunderbird fixes the following issues:

   Updated to version 91.7 (bsc#1196900):
     - CVE-2022-26381: Fixed an invalid memory access due to text reflow when
       SVG
       objects were present.
     - CVE-2022-26383: Fixed an issue where, when resizing a popup after
       requesting fullscreen access, the popup would not display the
       fullscreen notification.
     - CVE-2022-26384: Fixed an iframe XSS sandbox bypass when allow-popups
       was used
       on the iframe.
     - CVE-2022-26386: Fixed an issue where downloadable temporary files were
       accessible to other local users.
     - CVE-2022-26387: Fixed a potential add-on signature verification bypass
       due to a race condition.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-906=1

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2022-906=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      MozillaThunderbird-91.7.0-150200.8.62.7
      MozillaThunderbird-debuginfo-91.7.0-150200.8.62.7
      MozillaThunderbird-debugsource-91.7.0-150200.8.62.7
      MozillaThunderbird-translations-common-91.7.0-150200.8.62.7
      MozillaThunderbird-translations-other-91.7.0-150200.8.62.7

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      MozillaThunderbird-91.7.0-150200.8.62.7
      MozillaThunderbird-debuginfo-91.7.0-150200.8.62.7
      MozillaThunderbird-debugsource-91.7.0-150200.8.62.7
      MozillaThunderbird-translations-common-91.7.0-150200.8.62.7
      MozillaThunderbird-translations-other-91.7.0-150200.8.62.7


References:

   https://www.suse.com/security/cve/CVE-2022-26381.html
   https://www.suse.com/security/cve/CVE-2022-26383.html
   https://www.suse.com/security/cve/CVE-2022-26384.html
   https://www.suse.com/security/cve/CVE-2022-26386.html
   https://www.suse.com/security/cve/CVE-2022-26387.html
   https://bugzilla.suse.com/1196900