openSUSE: 2022:0915-1 moderate: lapack | LinuxSecurity.com

   openSUSE Security Update: Security update for lapack
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2022:0915-1
Rating:             moderate
References:         #1193562 
Cross-References:   CVE-2021-4048
CVSS scores:
                    CVE-2021-4048 (NVD) : 9.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
                    CVE-2021-4048 (SUSE): 4.7 CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:H

Affected Products:
                    openSUSE Leap 15.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for lapack fixes the following issues:

   - CVE-2021-4048: Fixed an out of bounds read when user input was not
     validated properly (bsc#1193562).


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-915=1

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2022-915=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      blas-devel-3.5.0-4.6.1
      blas-devel-static-3.5.0-4.6.1
      lapack-debugsource-3.5.0-4.6.1
      lapack-devel-3.5.0-4.6.1
      lapack-devel-static-3.5.0-4.6.1
      lapacke-devel-3.5.0-4.6.1
      lapacke-devel-static-3.5.0-4.6.1
      libblas3-3.5.0-4.6.1
      libblas3-debuginfo-3.5.0-4.6.1
      liblapack3-3.5.0-4.6.1
      liblapack3-debuginfo-3.5.0-4.6.1
      liblapacke3-3.5.0-4.6.1
      liblapacke3-debuginfo-3.5.0-4.6.1

   - openSUSE Leap 15.4 (x86_64):

      blas-devel-32bit-3.5.0-4.6.1
      lapack-devel-32bit-3.5.0-4.6.1
      lapacke-devel-32bit-3.5.0-4.6.1
      libblas3-32bit-3.5.0-4.6.1
      libblas3-32bit-debuginfo-3.5.0-4.6.1
      liblapack3-32bit-3.5.0-4.6.1
      liblapack3-32bit-debuginfo-3.5.0-4.6.1
      liblapacke3-32bit-3.5.0-4.6.1
      liblapacke3-32bit-debuginfo-3.5.0-4.6.1

   - openSUSE Leap 15.4 (noarch):

      blas-man-3.5.0-4.6.1
      lapack-man-3.5.0-4.6.1

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      blas-devel-3.5.0-4.6.1
      blas-devel-static-3.5.0-4.6.1
      lapack-debugsource-3.5.0-4.6.1
      lapack-devel-3.5.0-4.6.1
      lapack-devel-static-3.5.0-4.6.1
      lapacke-devel-3.5.0-4.6.1
      lapacke-devel-static-3.5.0-4.6.1
      libblas3-3.5.0-4.6.1
      libblas3-debuginfo-3.5.0-4.6.1
      liblapack3-3.5.0-4.6.1
      liblapack3-debuginfo-3.5.0-4.6.1
      liblapacke3-3.5.0-4.6.1
      liblapacke3-debuginfo-3.5.0-4.6.1

   - openSUSE Leap 15.3 (noarch):

      blas-man-3.5.0-4.6.1
      lapack-man-3.5.0-4.6.1

   - openSUSE Leap 15.3 (x86_64):

      blas-devel-32bit-3.5.0-4.6.1
      lapack-devel-32bit-3.5.0-4.6.1
      lapacke-devel-32bit-3.5.0-4.6.1
      libblas3-32bit-3.5.0-4.6.1
      libblas3-32bit-debuginfo-3.5.0-4.6.1
      liblapack3-32bit-3.5.0-4.6.1
      liblapack3-32bit-debuginfo-3.5.0-4.6.1
      liblapacke3-32bit-3.5.0-4.6.1
      liblapacke3-32bit-debuginfo-3.5.0-4.6.1


References:

   https://www.suse.com/security/cve/CVE-2021-4048.html
   https://bugzilla.suse.com/1193562

openSUSE: 2022:0915-1 moderate: lapack

March 21, 2022
An update that fixes one vulnerability is now available

Description

This update for lapack fixes the following issues: - CVE-2021-4048: Fixed an out of bounds read when user input was not validated properly (bsc#1193562).

 

Patch

Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2022-915=1 - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2022-915=1


Package List

- openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64): blas-devel-3.5.0-4.6.1 blas-devel-static-3.5.0-4.6.1 lapack-debugsource-3.5.0-4.6.1 lapack-devel-3.5.0-4.6.1 lapack-devel-static-3.5.0-4.6.1 lapacke-devel-3.5.0-4.6.1 lapacke-devel-static-3.5.0-4.6.1 libblas3-3.5.0-4.6.1 libblas3-debuginfo-3.5.0-4.6.1 liblapack3-3.5.0-4.6.1 liblapack3-debuginfo-3.5.0-4.6.1 liblapacke3-3.5.0-4.6.1 liblapacke3-debuginfo-3.5.0-4.6.1 - openSUSE Leap 15.4 (x86_64): blas-devel-32bit-3.5.0-4.6.1 lapack-devel-32bit-3.5.0-4.6.1 lapacke-devel-32bit-3.5.0-4.6.1 libblas3-32bit-3.5.0-4.6.1 libblas3-32bit-debuginfo-3.5.0-4.6.1 liblapack3-32bit-3.5.0-4.6.1 liblapack3-32bit-debuginfo-3.5.0-4.6.1 liblapacke3-32bit-3.5.0-4.6.1 liblapacke3-32bit-debuginfo-3.5.0-4.6.1 - openSUSE Leap 15.4 (noarch): blas-man-3.5.0-4.6.1 lapack-man-3.5.0-4.6.1 - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64): blas-devel-3.5.0-4.6.1 blas-devel-static-3.5.0-4.6.1 lapack-debugsource-3.5.0-4.6.1 lapack-devel-3.5.0-4.6.1 lapack-devel-static-3.5.0-4.6.1 lapacke-devel-3.5.0-4.6.1 lapacke-devel-static-3.5.0-4.6.1 libblas3-3.5.0-4.6.1 libblas3-debuginfo-3.5.0-4.6.1 liblapack3-3.5.0-4.6.1 liblapack3-debuginfo-3.5.0-4.6.1 liblapacke3-3.5.0-4.6.1 liblapacke3-debuginfo-3.5.0-4.6.1 - openSUSE Leap 15.3 (noarch): blas-man-3.5.0-4.6.1 lapack-man-3.5.0-4.6.1 - openSUSE Leap 15.3 (x86_64): blas-devel-32bit-3.5.0-4.6.1 lapack-devel-32bit-3.5.0-4.6.1 lapacke-devel-32bit-3.5.0-4.6.1 libblas3-32bit-3.5.0-4.6.1 libblas3-32bit-debuginfo-3.5.0-4.6.1 liblapack3-32bit-3.5.0-4.6.1 liblapack3-32bit-debuginfo-3.5.0-4.6.1 liblapacke3-32bit-3.5.0-4.6.1 liblapacke3-32bit-debuginfo-3.5.0-4.6.1


References

https://www.suse.com/security/cve/CVE-2021-4048.html https://bugzilla.suse.com/1193562


Severity
Announcement ID: openSUSE-SU-2022:0915-1
Rating: moderate
Affected Products: openSUSE Leap 15.3 openSUSE Leap 15.4 . Affected Products: openSUSE Leap 15.3 openSUSE Leap 15.4 .

Related News

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.