openSUSE: 2022:10196-1 important: libmodbus | LinuxSecurity.com

   openSUSE Security Update: Security update for libmodbus
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2022:10196-1
Rating:             important
References:         #1195124 
Cross-References:   CVE-2022-0367
CVSS scores:
                    CVE-2022-0367 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Affected Products:
                    openSUSE Backports SLE-15-SP4
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for libmodbus fixes the following issues:

   - CVE-2022-0367: Fixed heap-based Buffer Overflow in modbus_reply
     (boo#1195124).


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Backports SLE-15-SP4:

      zypper in -t patch openSUSE-2022-10196=1



Package List:

   - openSUSE Backports SLE-15-SP4 (aarch64 i586 ppc64le s390x x86_64):

      libmodbus-devel-3.1.6-bp154.2.3.1
      libmodbus5-3.1.6-bp154.2.3.1


References:

   https://www.suse.com/security/cve/CVE-2022-0367.html
   https://bugzilla.suse.com/1195124

openSUSE: 2022:10196-1 important: libmodbus

November 11, 2022
An update that fixes one vulnerability is now available

Description

This update for libmodbus fixes the following issues: - CVE-2022-0367: Fixed heap-based Buffer Overflow in modbus_reply (boo#1195124).

 

Patch

Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Backports SLE-15-SP4: zypper in -t patch openSUSE-2022-10196=1


Package List

- openSUSE Backports SLE-15-SP4 (aarch64 i586 ppc64le s390x x86_64): libmodbus-devel-3.1.6-bp154.2.3.1 libmodbus5-3.1.6-bp154.2.3.1


References

https://www.suse.com/security/cve/CVE-2022-0367.html https://bugzilla.suse.com/1195124


Severity
Announcement ID: openSUSE-SU-2022:10196-1
Rating: important
Affected Products: openSUSE Backports SLE-15-SP4 . Affected Products: openSUSE Backports SLE-15-SP4 .

Related News

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.