openSUSE Security Update: Security update for openvpn
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2022:1029-1
Rating:             important
References:         #1197341 
Cross-References:   CVE-2022-0547
CVSS scores:
                    CVE-2022-0547 (SUSE): 7.4 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Affected Products:
                    openSUSE Leap 15.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for openvpn fixes the following issues:

   - CVE-2022-0547: Fixed possible authentication bypass in external
     authentication plug-in (bsc#1197341).


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-1029=1

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2022-1029=1



Package List:

   - openSUSE Leap 15.4 (aarch64):

      openvpn-2.4.3-150000.5.10.1
      openvpn-auth-pam-plugin-2.4.3-150000.5.10.1
      openvpn-auth-pam-plugin-debuginfo-2.4.3-150000.5.10.1
      openvpn-debuginfo-2.4.3-150000.5.10.1
      openvpn-debugsource-2.4.3-150000.5.10.1
      openvpn-devel-2.4.3-150000.5.10.1
      openvpn-down-root-plugin-2.4.3-150000.5.10.1
      openvpn-down-root-plugin-debuginfo-2.4.3-150000.5.10.1

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      openvpn-2.4.3-150000.5.10.1
      openvpn-auth-pam-plugin-2.4.3-150000.5.10.1
      openvpn-auth-pam-plugin-debuginfo-2.4.3-150000.5.10.1
      openvpn-debuginfo-2.4.3-150000.5.10.1
      openvpn-debugsource-2.4.3-150000.5.10.1
      openvpn-devel-2.4.3-150000.5.10.1
      openvpn-down-root-plugin-2.4.3-150000.5.10.1
      openvpn-down-root-plugin-debuginfo-2.4.3-150000.5.10.1


References:

   https://www.suse.com/security/cve/CVE-2022-0547.html
   https://bugzilla.suse.com/1197341