Discover Government News


   openSUSE Security Update: Security update for hugin
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2024:0047-1
Rating:             important
References:         #1219819 #1219820 #1219821 #1219822 
Cross-References:   CVE-2024-25442 CVE-2024-25443 CVE-2024-25445
                    CVE-2024-25446
Affected Products:
                    openSUSE Backports SLE-15-SP5
______________________________________________________________________________

   An update that fixes four vulnerabilities is now available.

Description:

   This update for hugin fixes the following issues:

   Update to version 2023.0.0:

     * PTBatcherGUI can now also queue user defined assistant and user
       defined output sequences.
     * PTBatcherGUI: Added option to generate panorama sequences from an
       existing pto template.
     * Assistant: Added option to select different output options like
       projection, FOV or canvas size depending on different variables (e.g.
       image count, field of view, lens type).
     * Allow building with epoxy instead of GLEW for OpenGL pointer
       management.
     * Several improvements to crop tool (outside crop, aspect ratio, ...).
     * Several bug fixes (e.g. in verdandi/internal blender).
     * Updated translations.
   - fixed: boo#1219819 (CVE-2024-25442), boo#1219820 (CVE-2024-25443)
     boo#1219821 (CVE-2024-25445), boo#1219822 (CVE-2024-25446)


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Backports SLE-15-SP5:

      zypper in -t patch openSUSE-2024-47=1



Package List:

   - openSUSE Backports SLE-15-SP5 (aarch64 ppc64le s390x x86_64):

      hugin-2023.0.0-bp155.2.3.1


References:

   https://www.suse.com/security/cve/CVE-2024-25442.html
   https://www.suse.com/security/cve/CVE-2024-25443.html
   https://www.suse.com/security/cve/CVE-2024-25445.html
   https://www.suse.com/security/cve/CVE-2024-25446.html
   https://bugzilla.suse.com/1219819
   https://bugzilla.suse.com/1219820
   https://bugzilla.suse.com/1219821
   https://bugzilla.suse.com/1219822

openSUSE: 2024:0047-1 important: hugin

February 14, 2024
An update that fixes four vulnerabilities is now available

Description

This update for hugin fixes the following issues: Update to version 2023.0.0: * PTBatcherGUI can now also queue user defined assistant and user defined output sequences. * PTBatcherGUI: Added option to generate panorama sequences from an existing pto template. * Assistant: Added option to select different output options like projection, FOV or canvas size depending on different variables (e.g. image count, field of view, lens type). * Allow building with epoxy instead of GLEW for OpenGL pointer management. * Several improvements to crop tool (outside crop, aspect ratio, ...). * Several bug fixes (e.g. in verdandi/internal blender). * Updated translations. - fixed: boo#1219819 (CVE-2024-25442), boo#1219820 (CVE-2024-25443) boo#1219821 (CVE-2024-25445), boo#1219822 (CVE-2024-25446)

 

Patch

Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Backports SLE-15-SP5: zypper in -t patch openSUSE-2024-47=1


Package List

- openSUSE Backports SLE-15-SP5 (aarch64 ppc64le s390x x86_64): hugin-2023.0.0-bp155.2.3.1


References

https://www.suse.com/security/cve/CVE-2024-25442.html https://www.suse.com/security/cve/CVE-2024-25443.html https://www.suse.com/security/cve/CVE-2024-25445.html https://www.suse.com/security/cve/CVE-2024-25446.html https://bugzilla.suse.com/1219819 https://bugzilla.suse.com/1219820 https://bugzilla.suse.com/1219821 https://bugzilla.suse.com/1219822


Severity
Announcement ID: openSUSE-SU-2024:0047-1
Rating: important
Affected Products: openSUSE Backports SLE-15-SP5 .

Related News