Oracle7: ELSA-2022-6815: squid security Important Security Update ...
Oracle Linux Security Advisory ELSA-2022-6815

https://linux.oracle.com/errata/ELSA-2022-6815.html

The following updated rpms for Oracle Linux 7 have been uploaded to the Unbreakable Linux Network:

x86_64:
squid-3.5.20-17.0.1.el7_9.8.x86_64.rpm
squid-migration-script-3.5.20-17.0.1.el7_9.8.x86_64.rpm
squid-sysvinit-3.5.20-17.0.1.el7_9.8.x86_64.rpm


SRPMS:
https://oss.oracle.com/ol7/SRPMS-updates/squid-3.5.20-17.0.1.el7_9.8.src.rpm

Related CVEs:

CVE-2022-41318




Description of changes:

[7:3.5.20-17.0.1]
- Mutiple CVE fixes for squid [Orabug: 33146289]
- Resolves: CVE-2021-28651 squid: Bug 5104: Memory leak in RFC 2169 response parsing (#778)
- Resolves: CVE-2021-28652 squid: Bug 5106: Broken cache manager URL parsing (#788)
- Resolves: CVE-2021-31806,31807,31808 squid: Handle more Range requests (#790)
- Resolves: CVE-2021-33620 squid: Handle more partial responses (#791)

[7:3.5.20-17.8]
- Resolves: #2130254 - CVE-2022-41318 squid: buffer-over-read in SSPI and SMB
  authentication


_______________________________________________
El-errata mailing list
[email protected]
https://oss.oracle.com/mailman/listinfo/el-errata

Oracle7: ELSA-2022-6815: squid security Important Security Update

Summary

Description of changes: [7:3.5.20-17.0.1] - Mutiple CVE fixes for squid [Orabug: 33146289] - Resolves: CVE-2021-28651 squid: Bug 5104: Memory leak in RFC 2169 response parsing (#778) - Resolves: CVE-2021-28652 squid: Bug 5106: Broken cache manager URL parsing (#788) - Resolves: CVE-2021-31806,31807,31808 squid: Handle more Range requests (#790) - Resolves: CVE-2021-33620 squid: Handle more partial responses (#791) [7:3.5.20-17.8] - Resolves: #2130254 - CVE-2022-41318 squid: buffer-over-read in SSPI and SMB authentication

i386

x86_64

squid-3.5.20-17.0.1.el7_9.8.x86_64.rpm squid-migration-script-3.5.20-17.0.1.el7_9.8.x86_64.rpm squid-sysvinit-3.5.20-17.0.1.el7_9.8.x86_64.rpm

SRPMS

https://oss.oracle.com/ol7/SRPMS-updates/squid-3.5.20-17.0.1.el7_9.8.src.rpm

Severity
Related CVEs: CVE-2022-41318

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.