Oracle Linux Security Advisory ELSA-2023-1743

https://linux.oracle.com/errata/ELSA-2023-1743.html

The following updated rpms for Oracle Linux 8 have been uploaded to the Unbreakable Linux Network:

x86_64:
nodejs-14.21.3-1.module+el8.7.0+21031+52889874.x86_64.rpm
nodejs-devel-14.21.3-1.module+el8.7.0+21031+52889874.x86_64.rpm
nodejs-docs-14.21.3-1.module+el8.7.0+21031+52889874.noarch.rpm
nodejs-full-i18n-14.21.3-1.module+el8.7.0+21031+52889874.x86_64.rpm
nodejs-nodemon-2.0.20-3.module+el8.7.0+21031+52889874.noarch.rpm
nodejs-packaging-23-3.module+el8.3.0+7818+6cd30d85.noarch.rpm
npm-6.14.18-1.14.21.3.1.module+el8.7.0+21031+52889874.x86_64.rpm

aarch64:
nodejs-14.21.3-1.module+el8.7.0+21031+52889874.aarch64.rpm
nodejs-devel-14.21.3-1.module+el8.7.0+21031+52889874.aarch64.rpm
nodejs-docs-14.21.3-1.module+el8.7.0+21031+52889874.noarch.rpm
nodejs-full-i18n-14.21.3-1.module+el8.7.0+21031+52889874.aarch64.rpm
nodejs-nodemon-2.0.20-3.module+el8.7.0+21031+52889874.noarch.rpm
nodejs-packaging-23-3.module+el8.3.0+7818+6cd30d85.noarch.rpm
npm-6.14.18-1.14.21.3.1.module+el8.7.0+21031+52889874.aarch64.rpm


SRPMS:
https://oss.oracle.com:443/ol8/SRPMS-updates//nodejs-14.21.3-1.module+el8.7.0+21031+52889874.src.rpm
https://oss.oracle.com:443/ol8/SRPMS-updates//nodejs-nodemon-2.0.20-3.module+el8.7.0+21031+52889874.src.rpm
https://oss.oracle.com:443/ol8/SRPMS-updates//nodejs-packaging-23-3.module+el8.3.0+7818+6cd30d85.src.rpm

Related CVEs:

CVE-2021-35065
CVE-2022-3517
CVE-2022-4904
CVE-2022-25881
CVE-2022-38900
CVE-2023-23918
CVE-2023-23920




Description of changes:

nodejs
[1:14.21.3-1]
- Rebase to 14.21.3
  Resolves: rhbz#2153712
  Resolves: CVE-2022-25881 CVE-2023-23918 CVE-2023-23920 CVE-2022-38900
  Resolves: CVE-2022-4904

_______________________________________________
El-errata mailing list
El-errata@oss.oracle.com
https://oss.oracle.com/mailman/listinfo/el-errata

Oracle8: ELSA-2023-1743: nodejs:14 security, bug fix, and enhancement Important Security U

The following updated rpms for Oracle Linux 8 have been uploaded to the Unbreakable Linux Network:

Summary

nodejs [1:14.21.3-1] - Rebase to 14.21.3 Resolves: rhbz#2153712 Resolves: CVE-2022-25881 CVE-2023-23918 CVE-2023-23920 CVE-2022-38900 Resolves: CVE-2022-4904

SRPMs

https://oss.oracle.com:443/ol8/SRPMS-updates//nodejs-14.21.3-1.module+el8.7.0+21031+52889874.src.rpm https://oss.oracle.com:443/ol8/SRPMS-updates//nodejs-nodemon-2.0.20-3.module+el8.7.0+21031+52889874.src.rpm https://oss.oracle.com:443/ol8/SRPMS-updates//nodejs-packaging-23-3.module+el8.3.0+7818+6cd30d85.src.rpm

x86_64

nodejs-14.21.3-1.module+el8.7.0+21031+52889874.x86_64.rpm nodejs-devel-14.21.3-1.module+el8.7.0+21031+52889874.x86_64.rpm nodejs-docs-14.21.3-1.module+el8.7.0+21031+52889874.noarch.rpm nodejs-full-i18n-14.21.3-1.module+el8.7.0+21031+52889874.x86_64.rpm nodejs-nodemon-2.0.20-3.module+el8.7.0+21031+52889874.noarch.rpm nodejs-packaging-23-3.module+el8.3.0+7818+6cd30d85.noarch.rpm npm-6.14.18-1.14.21.3.1.module+el8.7.0+21031+52889874.x86_64.rpm

aarch64

nodejs-14.21.3-1.module+el8.7.0+21031+52889874.aarch64.rpm nodejs-devel-14.21.3-1.module+el8.7.0+21031+52889874.aarch64.rpm nodejs-docs-14.21.3-1.module+el8.7.0+21031+52889874.noarch.rpm nodejs-full-i18n-14.21.3-1.module+el8.7.0+21031+52889874.aarch64.rpm nodejs-nodemon-2.0.20-3.module+el8.7.0+21031+52889874.noarch.rpm nodejs-packaging-23-3.module+el8.3.0+7818+6cd30d85.noarch.rpm npm-6.14.18-1.14.21.3.1.module+el8.7.0+21031+52889874.aarch64.rpm

i386

Severity
Related CVEs: CVE-2021-35065 CVE-2022-3517 CVE-2022-4904 CVE-2022-25881 CVE-2022-38900 CVE-2023-23918 CVE-2023-23920

Related News