Discover Government News

Oracle Linux Security Advisory ELSA-2024-0748

https://linux.oracle.com/errata/ELSA-2024-0748.html

The following updated rpms for Oracle Linux 8 have been uploaded to the Unbreakable Linux Network:

x86_64:
aardvark-dns-1.0.1-38.0.1.module+el8.9.0+90148+6046e3c3.x86_64.rpm
buildah-1.24.6-7.module+el8.9.0+90148+6046e3c3.x86_64.rpm
buildah-tests-1.24.6-7.module+el8.9.0+90148+6046e3c3.x86_64.rpm
cockpit-podman-46-1.module+el8.9.0+90148+6046e3c3.noarch.rpm
conmon-2.1.4-2.module+el8.9.0+90148+6046e3c3.x86_64.rpm
containernetworking-plugins-1.1.1-6.module+el8.9.0+90148+6046e3c3.x86_64.rpm
containers-common-1-38.0.1.module+el8.9.0+90148+6046e3c3.x86_64.rpm
container-selinux-2.205.0-3.module+el8.9.0+90148+6046e3c3.noarch.rpm
crit-3.15-3.module+el8.9.0+90148+6046e3c3.x86_64.rpm
criu-3.15-3.module+el8.9.0+90148+6046e3c3.x86_64.rpm
criu-devel-3.15-3.module+el8.9.0+90148+6046e3c3.x86_64.rpm
criu-libs-3.15-3.module+el8.9.0+90148+6046e3c3.x86_64.rpm
crun-1.8.7-1.module+el8.9.0+90148+6046e3c3.x86_64.rpm
fuse-overlayfs-1.9-2.module+el8.9.0+90148+6046e3c3.x86_64.rpm
libslirp-4.4.0-1.module+el8.9.0+90148+6046e3c3.x86_64.rpm
libslirp-devel-4.4.0-1.module+el8.9.0+90148+6046e3c3.x86_64.rpm
netavark-1.0.1-38.0.1.module+el8.9.0+90148+6046e3c3.x86_64.rpm
oci-seccomp-bpf-hook-1.2.5-2.module+el8.9.0+90148+6046e3c3.x86_64.rpm
podman-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.x86_64.rpm
podman-catatonit-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.x86_64.rpm
podman-docker-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.noarch.rpm
podman-gvproxy-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.x86_64.rpm
podman-plugins-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.x86_64.rpm
podman-remote-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.x86_64.rpm
podman-tests-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.x86_64.rpm
python3-criu-3.15-3.module+el8.9.0+90148+6046e3c3.x86_64.rpm
python3-podman-4.0.0-2.module+el8.9.0+90148+6046e3c3.noarch.rpm
runc-1.1.12-1.module+el8.9.0+90148+6046e3c3.x86_64.rpm
skopeo-1.6.2-9.module+el8.9.0+90148+6046e3c3.x86_64.rpm
skopeo-tests-1.6.2-9.module+el8.9.0+90148+6046e3c3.x86_64.rpm
slirp4netns-1.1.8-3.module+el8.9.0+90148+6046e3c3.x86_64.rpm
udica-0.2.6-4.module+el8.9.0+90148+6046e3c3.noarch.rpm

aarch64:
aardvark-dns-1.0.1-38.0.1.module+el8.9.0+90148+6046e3c3.aarch64.rpm
buildah-1.24.6-7.module+el8.9.0+90148+6046e3c3.aarch64.rpm
buildah-tests-1.24.6-7.module+el8.9.0+90148+6046e3c3.aarch64.rpm
cockpit-podman-46-1.module+el8.9.0+90148+6046e3c3.noarch.rpm
conmon-2.1.4-2.module+el8.9.0+90148+6046e3c3.aarch64.rpm
containernetworking-plugins-1.1.1-6.module+el8.9.0+90148+6046e3c3.aarch64.rpm
containers-common-1-38.0.1.module+el8.9.0+90148+6046e3c3.aarch64.rpm
container-selinux-2.205.0-3.module+el8.9.0+90148+6046e3c3.noarch.rpm
crit-3.15-3.module+el8.9.0+90148+6046e3c3.aarch64.rpm
criu-3.15-3.module+el8.9.0+90148+6046e3c3.aarch64.rpm
criu-devel-3.15-3.module+el8.9.0+90148+6046e3c3.aarch64.rpm
criu-libs-3.15-3.module+el8.9.0+90148+6046e3c3.aarch64.rpm
crun-1.8.7-1.module+el8.9.0+90148+6046e3c3.aarch64.rpm
fuse-overlayfs-1.9-2.module+el8.9.0+90148+6046e3c3.aarch64.rpm
libslirp-4.4.0-1.module+el8.9.0+90148+6046e3c3.aarch64.rpm
libslirp-devel-4.4.0-1.module+el8.9.0+90148+6046e3c3.aarch64.rpm
netavark-1.0.1-38.0.1.module+el8.9.0+90148+6046e3c3.aarch64.rpm
oci-seccomp-bpf-hook-1.2.5-2.module+el8.9.0+90148+6046e3c3.aarch64.rpm
podman-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.aarch64.rpm
podman-catatonit-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.aarch64.rpm
podman-docker-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.noarch.rpm
podman-gvproxy-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.aarch64.rpm
podman-plugins-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.aarch64.rpm
podman-remote-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.aarch64.rpm
podman-tests-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.aarch64.rpm
python3-criu-3.15-3.module+el8.9.0+90148+6046e3c3.aarch64.rpm
python3-podman-4.0.0-2.module+el8.9.0+90148+6046e3c3.noarch.rpm
runc-1.1.12-1.module+el8.9.0+90148+6046e3c3.aarch64.rpm
skopeo-1.6.2-9.module+el8.9.0+90148+6046e3c3.aarch64.rpm
skopeo-tests-1.6.2-9.module+el8.9.0+90148+6046e3c3.aarch64.rpm
slirp4netns-1.1.8-3.module+el8.9.0+90148+6046e3c3.aarch64.rpm
udica-0.2.6-4.module+el8.9.0+90148+6046e3c3.noarch.rpm


SRPMS:
https://oss.oracle.com:443/ol8/SRPMS-updates//buildah-1.24.6-7.module+el8.9.0+90148+6046e3c3.src.rpm
https://oss.oracle.com:443/ol8/SRPMS-updates//cockpit-podman-46-1.module+el8.9.0+90148+6046e3c3.src.rpm
https://oss.oracle.com:443/ol8/SRPMS-updates//conmon-2.1.4-2.module+el8.9.0+90148+6046e3c3.src.rpm
https://oss.oracle.com:443/ol8/SRPMS-updates//containernetworking-plugins-1.1.1-6.module+el8.9.0+90148+6046e3c3.src.rpm
https://oss.oracle.com:443/ol8/SRPMS-updates//containers-common-1-38.0.1.module+el8.9.0+90148+6046e3c3.src.rpm
https://oss.oracle.com:443/ol8/SRPMS-updates//container-selinux-2.205.0-3.module+el8.9.0+90148+6046e3c3.src.rpm
https://oss.oracle.com:443/ol8/SRPMS-updates//criu-3.15-3.module+el8.9.0+90148+6046e3c3.src.rpm
https://oss.oracle.com:443/ol8/SRPMS-updates//crun-1.8.7-1.module+el8.9.0+90148+6046e3c3.src.rpm
https://oss.oracle.com:443/ol8/SRPMS-updates//fuse-overlayfs-1.9-2.module+el8.9.0+90148+6046e3c3.src.rpm
https://oss.oracle.com:443/ol8/SRPMS-updates//libslirp-4.4.0-1.module+el8.9.0+90148+6046e3c3.src.rpm
https://oss.oracle.com:443/ol8/SRPMS-updates//oci-seccomp-bpf-hook-1.2.5-2.module+el8.9.0+90148+6046e3c3.src.rpm
https://oss.oracle.com:443/ol8/SRPMS-updates//podman-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.src.rpm
https://oss.oracle.com:443/ol8/SRPMS-updates//python-podman-4.0.0-2.module+el8.9.0+90148+6046e3c3.src.rpm
https://oss.oracle.com:443/ol8/SRPMS-updates//runc-1.1.12-1.module+el8.9.0+90148+6046e3c3.src.rpm
https://oss.oracle.com:443/ol8/SRPMS-updates//skopeo-1.6.2-9.module+el8.9.0+90148+6046e3c3.src.rpm
https://oss.oracle.com:443/ol8/SRPMS-updates//slirp4netns-1.1.8-3.module+el8.9.0+90148+6046e3c3.src.rpm
https://oss.oracle.com:443/ol8/SRPMS-updates//udica-0.2.6-4.module+el8.9.0+90148+6046e3c3.src.rpm

Related CVEs:

CVE-2023-45287
CVE-2024-21626




Description of changes:

buildah
cockpit-podman
conmon
containernetworking-plugins
containers-common
container-selinux
criu
crun
fuse-overlayfs
libslirp
oci-seccomp-bpf-hook
podman
[2:4.0.2-25.0.1]
- update to the latest content of https://github.com/containers/podman/tree/v4.0-rhel
(https://github.com/containers/podman/commit/427a15f)
- Resolves: RHEL-17145

running containers
python-podman
runc
[1:1.1.12-1]
- update to https://github.com/opencontainers/runc/releases/tag/v1.1.12
- Resolves: RHEL-21863

skopeo
slirp4netns
udica


_______________________________________________
El-errata mailing list
El-errata@oss.oracle.com
https://oss.oracle.com/mailman/listinfo/el-errata

Oracle8: ELSA-2024-0748: container-tools:4.0 Important Security Update

The following updated rpms for Oracle Linux 8 have been uploaded to the Unbreakable Linux Network:

Summary

buildah cockpit-podman conmon containernetworking-plugins containers-common container-selinux criu crun fuse-overlayfs libslirp oci-seccomp-bpf-hook podman [2:4.0.2-25.0.1] - update to the latest content of https://github.com/containers/podman/tree/v4.0-rhel (https://github.com/containers/podman/commit/427a15f) - Resolves: RHEL-17145 running containers python-podman runc [1:1.1.12-1] - update to https://github.com/opencontainers/runc/releases/tag/v1.1.12 - Resolves: RHEL-21863 skopeo slirp4netns udica

SRPMs

https://oss.oracle.com:443/ol8/SRPMS-updates//buildah-1.24.6-7.module+el8.9.0+90148+6046e3c3.src.rpm https://oss.oracle.com:443/ol8/SRPMS-updates//cockpit-podman-46-1.module+el8.9.0+90148+6046e3c3.src.rpm https://oss.oracle.com:443/ol8/SRPMS-updates//conmon-2.1.4-2.module+el8.9.0+90148+6046e3c3.src.rpm https://oss.oracle.com:443/ol8/SRPMS-updates//containernetworking-plugins-1.1.1-6.module+el8.9.0+90148+6046e3c3.src.rpm https://oss.oracle.com:443/ol8/SRPMS-updates//containers-common-1-38.0.1.module+el8.9.0+90148+6046e3c3.src.rpm https://oss.oracle.com:443/ol8/SRPMS-updates//container-selinux-2.205.0-3.module+el8.9.0+90148+6046e3c3.src.rpm https://oss.oracle.com:443/ol8/SRPMS-updates//criu-3.15-3.module+el8.9.0+90148+6046e3c3.src.rpm https://oss.oracle.com:443/ol8/SRPMS-updates//crun-1.8.7-1.module+el8.9.0+90148+6046e3c3.src.rpm https://oss.oracle.com:443/ol8/SRPMS-updates//fuse-overlayfs-1.9-2.module+el8.9.0+90148+6046e3c3.src.rpm https://oss.oracle.com:443/ol8/SRPMS-updates//libslirp-4.4.0-1.module+el8.9.0+90148+6046e3c3.src.rpm https://oss.oracle.com:443/ol8/SRPMS-updates//oci-seccomp-bpf-hook-1.2.5-2.module+el8.9.0+90148+6046e3c3.src.rpm https://oss.oracle.com:443/ol8/SRPMS-updates//podman-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.src.rpm https://oss.oracle.com:443/ol8/SRPMS-updates//python-podman-4.0.0-2.module+el8.9.0+90148+6046e3c3.src.rpm https://oss.oracle.com:443/ol8/SRPMS-updates//runc-1.1.12-1.module+el8.9.0+90148+6046e3c3.src.rpm https://oss.oracle.com:443/ol8/SRPMS-updates//skopeo-1.6.2-9.module+el8.9.0+90148+6046e3c3.src.rpm https://oss.oracle.com:443/ol8/SRPMS-updates//slirp4netns-1.1.8-3.module+el8.9.0+90148+6046e3c3.src.rpm https://oss.oracle.com:443/ol8/SRPMS-updates//udica-0.2.6-4.module+el8.9.0+90148+6046e3c3.src.rpm

x86_64

aardvark-dns-1.0.1-38.0.1.module+el8.9.0+90148+6046e3c3.x86_64.rpm buildah-1.24.6-7.module+el8.9.0+90148+6046e3c3.x86_64.rpm buildah-tests-1.24.6-7.module+el8.9.0+90148+6046e3c3.x86_64.rpm cockpit-podman-46-1.module+el8.9.0+90148+6046e3c3.noarch.rpm conmon-2.1.4-2.module+el8.9.0+90148+6046e3c3.x86_64.rpm containernetworking-plugins-1.1.1-6.module+el8.9.0+90148+6046e3c3.x86_64.rpm containers-common-1-38.0.1.module+el8.9.0+90148+6046e3c3.x86_64.rpm container-selinux-2.205.0-3.module+el8.9.0+90148+6046e3c3.noarch.rpm crit-3.15-3.module+el8.9.0+90148+6046e3c3.x86_64.rpm criu-3.15-3.module+el8.9.0+90148+6046e3c3.x86_64.rpm criu-devel-3.15-3.module+el8.9.0+90148+6046e3c3.x86_64.rpm criu-libs-3.15-3.module+el8.9.0+90148+6046e3c3.x86_64.rpm crun-1.8.7-1.module+el8.9.0+90148+6046e3c3.x86_64.rpm fuse-overlayfs-1.9-2.module+el8.9.0+90148+6046e3c3.x86_64.rpm libslirp-4.4.0-1.module+el8.9.0+90148+6046e3c3.x86_64.rpm libslirp-devel-4.4.0-1.module+el8.9.0+90148+6046e3c3.x86_64.rpm netavark-1.0.1-38.0.1.module+el8.9.0+90148+6046e3c3.x86_64.rpm oci-seccomp-bpf-hook-1.2.5-2.module+el8.9.0+90148+6046e3c3.x86_64.rpm podman-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.x86_64.rpm podman-catatonit-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.x86_64.rpm podman-docker-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.noarch.rpm podman-gvproxy-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.x86_64.rpm podman-plugins-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.x86_64.rpm podman-remote-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.x86_64.rpm podman-tests-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.x86_64.rpm python3-criu-3.15-3.module+el8.9.0+90148+6046e3c3.x86_64.rpm python3-podman-4.0.0-2.module+el8.9.0+90148+6046e3c3.noarch.rpm runc-1.1.12-1.module+el8.9.0+90148+6046e3c3.x86_64.rpm skopeo-1.6.2-9.module+el8.9.0+90148+6046e3c3.x86_64.rpm skopeo-tests-1.6.2-9.module+el8.9.0+90148+6046e3c3.x86_64.rpm slirp4netns-1.1.8-3.module+el8.9.0+90148+6046e3c3.x86_64.rpm udica-0.2.6-4.module+el8.9.0+90148+6046e3c3.noarch.rpm

aarch64

aardvark-dns-1.0.1-38.0.1.module+el8.9.0+90148+6046e3c3.aarch64.rpm buildah-1.24.6-7.module+el8.9.0+90148+6046e3c3.aarch64.rpm buildah-tests-1.24.6-7.module+el8.9.0+90148+6046e3c3.aarch64.rpm cockpit-podman-46-1.module+el8.9.0+90148+6046e3c3.noarch.rpm conmon-2.1.4-2.module+el8.9.0+90148+6046e3c3.aarch64.rpm containernetworking-plugins-1.1.1-6.module+el8.9.0+90148+6046e3c3.aarch64.rpm containers-common-1-38.0.1.module+el8.9.0+90148+6046e3c3.aarch64.rpm container-selinux-2.205.0-3.module+el8.9.0+90148+6046e3c3.noarch.rpm crit-3.15-3.module+el8.9.0+90148+6046e3c3.aarch64.rpm criu-3.15-3.module+el8.9.0+90148+6046e3c3.aarch64.rpm criu-devel-3.15-3.module+el8.9.0+90148+6046e3c3.aarch64.rpm criu-libs-3.15-3.module+el8.9.0+90148+6046e3c3.aarch64.rpm crun-1.8.7-1.module+el8.9.0+90148+6046e3c3.aarch64.rpm fuse-overlayfs-1.9-2.module+el8.9.0+90148+6046e3c3.aarch64.rpm libslirp-4.4.0-1.module+el8.9.0+90148+6046e3c3.aarch64.rpm libslirp-devel-4.4.0-1.module+el8.9.0+90148+6046e3c3.aarch64.rpm netavark-1.0.1-38.0.1.module+el8.9.0+90148+6046e3c3.aarch64.rpm oci-seccomp-bpf-hook-1.2.5-2.module+el8.9.0+90148+6046e3c3.aarch64.rpm podman-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.aarch64.rpm podman-catatonit-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.aarch64.rpm podman-docker-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.noarch.rpm podman-gvproxy-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.aarch64.rpm podman-plugins-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.aarch64.rpm podman-remote-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.aarch64.rpm podman-tests-4.0.2-25.0.1.module+el8.9.0+90148+6046e3c3.aarch64.rpm python3-criu-3.15-3.module+el8.9.0+90148+6046e3c3.aarch64.rpm python3-podman-4.0.0-2.module+el8.9.0+90148+6046e3c3.noarch.rpm runc-1.1.12-1.module+el8.9.0+90148+6046e3c3.aarch64.rpm skopeo-1.6.2-9.module+el8.9.0+90148+6046e3c3.aarch64.rpm skopeo-tests-1.6.2-9.module+el8.9.0+90148+6046e3c3.aarch64.rpm slirp4netns-1.1.8-3.module+el8.9.0+90148+6046e3c3.aarch64.rpm udica-0.2.6-4.module+el8.9.0+90148+6046e3c3.noarch.rpm

i386

Severity
Related CVEs: CVE-2023-45287 CVE-2024-21626

Related News