Oracle Linux Security Advisory ELSA-2023-4330

https://linux.oracle.com/errata/ELSA-2023-4330.html

The following updated rpms for Oracle Linux 9 have been uploaded to the Unbreakable Linux Network:

x86_64:
nodejs-18.16.1-1.module+el9.2.0+21133+486db26c.x86_64.rpm
nodejs-devel-18.16.1-1.module+el9.2.0+21133+486db26c.x86_64.rpm
nodejs-docs-18.16.1-1.module+el9.2.0+21133+486db26c.noarch.rpm
nodejs-full-i18n-18.16.1-1.module+el9.2.0+21133+486db26c.x86_64.rpm
nodejs-nodemon-2.0.20-2.module+el9.2.0+21038+115df6a2.noarch.rpm
nodejs-packaging-2021.06-4.module+el9.1.0+20762+f52d7401.noarch.rpm
nodejs-packaging-bundler-2021.06-4.module+el9.1.0+20762+f52d7401.noarch.rpm
npm-9.5.1-1.18.16.1.1.module+el9.2.0+21133+486db26c.x86_64.rpm

aarch64:
nodejs-18.16.1-1.module+el9.2.0+21133+486db26c.aarch64.rpm
nodejs-devel-18.16.1-1.module+el9.2.0+21133+486db26c.aarch64.rpm
nodejs-docs-18.16.1-1.module+el9.2.0+21133+486db26c.noarch.rpm
nodejs-full-i18n-18.16.1-1.module+el9.2.0+21133+486db26c.aarch64.rpm
nodejs-nodemon-2.0.20-2.module+el9.2.0+21038+115df6a2.noarch.rpm
nodejs-packaging-2021.06-4.module+el9.1.0+20762+f52d7401.noarch.rpm
nodejs-packaging-bundler-2021.06-4.module+el9.1.0+20762+f52d7401.noarch.rpm
npm-9.5.1-1.18.16.1.1.module+el9.2.0+21133+486db26c.aarch64.rpm


SRPMS:
https://oss.oracle.com/ol9/SRPMS-updates//nodejs-18.16.1-1.module+el9.2.0+21133+486db26c.src.rpm
https://oss.oracle.com/ol9/SRPMS-updates//nodejs-nodemon-2.0.20-2.module+el9.2.0+21038+115df6a2.src.rpm
https://oss.oracle.com/ol9/SRPMS-updates//nodejs-packaging-2021.06-4.module+el9.1.0+20762+f52d7401.src.rpm

Related CVEs:

CVE-2023-30581
CVE-2023-30588
CVE-2023-30589
CVE-2023-30590




Description of changes:

nodejs
[1:18.16.1-1]
- Rebase to 18.16.1
  Resolves: rhbz#2188292 rhbz#2187683
  Resolves: CVE-2023-30581 CVE-2023-30588 CVE-2023-30589 CVE-2023-30590
- Replace /usr/etc/npmrc symlink with builtin configuration
  Resolves: rhbz#2222285

nodejs-nodemon
nodejs-packaging


_______________________________________________
El-errata mailing list
[email protected]
https://oss.oracle.com/mailman/listinfo/el-errata

Oracle9: ELSA-2023-4330 : 18 security, bug fix, and enhancement Moderate Security Update

The following updated rpms for Oracle Linux 9 have been uploaded to the Unbreakable Linux Network:

Summary

nodejs [1:18.16.1-1] - Rebase to 18.16.1 Resolves: rhbz#2188292 rhbz#2187683 Resolves: CVE-2023-30581 CVE-2023-30588 CVE-2023-30589 CVE-2023-30590 - Replace /usr/etc/npmrc symlink with builtin configuration Resolves: rhbz#2222285 nodejs-nodemon nodejs-packaging

SRPMs

https://oss.oracle.com/ol9/SRPMS-updates//nodejs-18.16.1-1.module+el9.2.0+21133+486db26c.src.rpm https://oss.oracle.com/ol9/SRPMS-updates//nodejs-nodemon-2.0.20-2.module+el9.2.0+21038+115df6a2.src.rpm https://oss.oracle.com/ol9/SRPMS-updates//nodejs-packaging-2021.06-4.module+el9.1.0+20762+f52d7401.src.rpm

x86_64

nodejs-18.16.1-1.module+el9.2.0+21133+486db26c.x86_64.rpm nodejs-devel-18.16.1-1.module+el9.2.0+21133+486db26c.x86_64.rpm nodejs-docs-18.16.1-1.module+el9.2.0+21133+486db26c.noarch.rpm nodejs-full-i18n-18.16.1-1.module+el9.2.0+21133+486db26c.x86_64.rpm nodejs-nodemon-2.0.20-2.module+el9.2.0+21038+115df6a2.noarch.rpm nodejs-packaging-2021.06-4.module+el9.1.0+20762+f52d7401.noarch.rpm nodejs-packaging-bundler-2021.06-4.module+el9.1.0+20762+f52d7401.noarch.rpm npm-9.5.1-1.18.16.1.1.module+el9.2.0+21133+486db26c.x86_64.rpm

aarch64

nodejs-18.16.1-1.module+el9.2.0+21133+486db26c.aarch64.rpm nodejs-devel-18.16.1-1.module+el9.2.0+21133+486db26c.aarch64.rpm nodejs-docs-18.16.1-1.module+el9.2.0+21133+486db26c.noarch.rpm nodejs-full-i18n-18.16.1-1.module+el9.2.0+21133+486db26c.aarch64.rpm nodejs-nodemon-2.0.20-2.module+el9.2.0+21038+115df6a2.noarch.rpm nodejs-packaging-2021.06-4.module+el9.1.0+20762+f52d7401.noarch.rpm nodejs-packaging-bundler-2021.06-4.module+el9.1.0+20762+f52d7401.noarch.rpm npm-9.5.1-1.18.16.1.1.module+el9.2.0+21133+486db26c.aarch64.rpm

i386

Severity
Related CVEs: CVE-2023-30581 CVE-2023-30588 CVE-2023-30589 CVE-2023-30590
Feedback