RedHat: Important: gpdf security update | LinuxSecurity.com
- ---------------------------------------------------------------------
                   Red Hat Security Advisory

Synopsis:          Important: gpdf security update
Advisory ID:       RHSA-2005:867-01
Advisory URL:      https://rhn.redhat.com/errata/RHSA-2005-867.html
Issue date:        2005-12-20
Updated on:        2005-12-20
Product:           Red Hat Enterprise Linux
CVE Names:         CVE-2005-3191 CVE-2005-3192 CVE-2005-3193
- ---------------------------------------------------------------------

1. Summary:

An updated gpdf package that fixes several security issues is now available
for Red Hat Enterprise Linux 4.

This update has been rated as having important security impact by the Red
Hat Security Response Team.

2. Relevant releases/architectures:

Red Hat Enterprise Linux AS version 4 - i386, ia64, ppc, s390, s390x, x86_64
Red Hat Enterprise Linux Desktop version 4 - i386, x86_64
Red Hat Enterprise Linux ES version 4 - i386, ia64, x86_64
Red Hat Enterprise Linux WS version 4 - i386, ia64, x86_64

3. Problem description:

The gpdf package is a GNOME based viewer for Portable Document Format
(PDF) files.

Several flaws were discovered in gpdf. An attacker could construct a
carefully crafted PDF file that could cause gpdf to crash or possibly
execute arbitrary code when opened. The Common Vulnerabilities and
Exposures project assigned the names CVE-2005-3191, CVE-2005-3192, and
CVE-2005-3193 to these issues.

Users of gpdf should upgrade to this updated package, which contains a
backported patch to resolve these issues.

4. Solution:

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

This update is available via Red Hat Network.  To use Red Hat Network,
launch the Red Hat Update Agent with the following command:

up2date

This will start an interactive process that will result in the appropriate
RPMs being upgraded on your system.

5. Bug IDs fixed (https://bugzilla.redhat.com/):

175100 - CVE-2005-3193 xpdf issues (CVE-2005-3191 CVE-2005-3192)


6. RPMs required:

Red Hat Enterprise Linux AS version 4:

SRPMS:
ftp://updates.redhat.com/enterprise/4AS/en/os/SRPMS/gpdf-2.8.2-7.3.src.rpm
b365aac32d140ef324ab0eb2c7cf3bfd  gpdf-2.8.2-7.3.src.rpm

i386:
a3f8659efab116042f37cfc9d227dc82  gpdf-2.8.2-7.3.i386.rpm

ia64:
d429fc7fef00acef1468cddd11d2bbea  gpdf-2.8.2-7.3.ia64.rpm

ppc:
af418aad8b7c3b556359d41b42860745  gpdf-2.8.2-7.3.ppc.rpm

s390:
dc073f271f99420aea8d2bf7a3fc13a4  gpdf-2.8.2-7.3.s390.rpm

s390x:
3978d2d5f302b2313f6a06162dffdc20  gpdf-2.8.2-7.3.s390x.rpm

x86_64:
e7aff4c218078b599959d90b968fffd0  gpdf-2.8.2-7.3.x86_64.rpm

Red Hat Enterprise Linux Desktop version 4:

SRPMS:
ftp://updates.redhat.com/enterprise/4Desktop/en/os/SRPMS/gpdf-2.8.2-7.3.src.rpm
b365aac32d140ef324ab0eb2c7cf3bfd  gpdf-2.8.2-7.3.src.rpm

i386:
a3f8659efab116042f37cfc9d227dc82  gpdf-2.8.2-7.3.i386.rpm

x86_64:
e7aff4c218078b599959d90b968fffd0  gpdf-2.8.2-7.3.x86_64.rpm

Red Hat Enterprise Linux ES version 4:

SRPMS:
ftp://updates.redhat.com/enterprise/4ES/en/os/SRPMS/gpdf-2.8.2-7.3.src.rpm
b365aac32d140ef324ab0eb2c7cf3bfd  gpdf-2.8.2-7.3.src.rpm

i386:
a3f8659efab116042f37cfc9d227dc82  gpdf-2.8.2-7.3.i386.rpm

ia64:
d429fc7fef00acef1468cddd11d2bbea  gpdf-2.8.2-7.3.ia64.rpm

x86_64:
e7aff4c218078b599959d90b968fffd0  gpdf-2.8.2-7.3.x86_64.rpm

Red Hat Enterprise Linux WS version 4:

SRPMS:
ftp://updates.redhat.com/enterprise/4WS/en/os/SRPMS/gpdf-2.8.2-7.3.src.rpm
b365aac32d140ef324ab0eb2c7cf3bfd  gpdf-2.8.2-7.3.src.rpm

i386:
a3f8659efab116042f37cfc9d227dc82  gpdf-2.8.2-7.3.i386.rpm

ia64:
d429fc7fef00acef1468cddd11d2bbea  gpdf-2.8.2-7.3.ia64.rpm

x86_64:
e7aff4c218078b599959d90b968fffd0  gpdf-2.8.2-7.3.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and 
details on how to verify the signature are available from
https://www.redhat.com/security/team/key/#package

7. References:

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3191
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3192
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3193

8. Contact:

The Red Hat security contact is .  More contact
details at https://www.redhat.com/security/team/contact/

Copyright 2005 Red Hat, Inc.

RedHat: Important: gpdf security update

An updated gpdf package that fixes several security issues is now available for Red Hat Enterprise Linux 4

Summary

Solution

Before applying this update, make sure all previously released errata relevant to your system have been applied.

This update is available via Red Hat Network. To use Red Hat Network, launch the Red Hat Update Agent with the following command:

up2date

This will start an interactive process that will result in the appropriate RPMs being upgraded on your system.

5. Bug IDs fixed (https://bugzilla.redhat.com/):

175100 - CVE-2005-3193 xpdf issues (CVE-2005-3191 CVE-2005-3192)


6. RPMs required:

Red Hat Enterprise Linux AS version 4:

SRPMS: ftp://updates.redhat.com/enterprise/4AS/en/os/SRPMS/gpdf-2.8.2-7.3.src.rpm b365aac32d140ef324ab0eb2c7cf3bfd gpdf-2.8.2-7.3.src.rpm

i386: a3f8659efab116042f37cfc9d227dc82 gpdf-2.8.2-7.3.i386.rpm

ia64: d429fc7fef00acef1468cddd11d2bbea gpdf-2.8.2-7.3.ia64.rpm

ppc: af418aad8b7c3b556359d41b42860745 gpdf-2.8.2-7.3.ppc.rpm

s390: dc073f271f99420aea8d2bf7a3fc13a4 gpdf-2.8.2-7.3.s390.rpm

s390x: 3978d2d5f302b2313f6a06162dffdc20 gpdf-2.8.2-7.3.s390x.rpm

x86_64: e7aff4c218078b599959d90b968fffd0 gpdf-2.8.2-7.3.x86_64.rpm

Red Hat Enterprise Linux Desktop version 4:

SRPMS: ftp://updates.redhat.com/enterprise/4Desktop/en/os/SRPMS/gpdf-2.8.2-7.3.src.rpm b365aac32d140ef324ab0eb2c7cf3bfd gpdf-2.8.2-7.3.src.rpm

i386: a3f8659efab116042f37cfc9d227dc82 gpdf-2.8.2-7.3.i386.rpm

x86_64: e7aff4c218078b599959d90b968fffd0 gpdf-2.8.2-7.3.x86_64.rpm

Red Hat Enterprise Linux ES version 4:

SRPMS: ftp://updates.redhat.com/enterprise/4ES/en/os/SRPMS/gpdf-2.8.2-7.3.src.rpm b365aac32d140ef324ab0eb2c7cf3bfd gpdf-2.8.2-7.3.src.rpm

i386: a3f8659efab116042f37cfc9d227dc82 gpdf-2.8.2-7.3.i386.rpm

ia64: d429fc7fef00acef1468cddd11d2bbea gpdf-2.8.2-7.3.ia64.rpm

x86_64: e7aff4c218078b599959d90b968fffd0 gpdf-2.8.2-7.3.x86_64.rpm

Red Hat Enterprise Linux WS version 4:

SRPMS: ftp://updates.redhat.com/enterprise/4WS/en/os/SRPMS/gpdf-2.8.2-7.3.src.rpm b365aac32d140ef324ab0eb2c7cf3bfd gpdf-2.8.2-7.3.src.rpm

i386: a3f8659efab116042f37cfc9d227dc82 gpdf-2.8.2-7.3.i386.rpm

ia64: d429fc7fef00acef1468cddd11d2bbea gpdf-2.8.2-7.3.ia64.rpm

x86_64: e7aff4c218078b599959d90b968fffd0 gpdf-2.8.2-7.3.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from https://www.redhat.com/security/team/key/#package

References

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3191 https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3192 https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3193

Package List

Severity
Advisory ID: RHSA-2005:867-01
Advisory URL: https://rhn.redhat.com/errata/RHSA-2005-867.html
Issued Date: : 2005-12-20
Updated on: 2005-12-20
Product: Red Hat Enterprise Linux
CVE Names: CVE-2005-3191 CVE-2005-3192 CVE-2005-3193 - ---------------------------------------------------------------------

Topic

An updated gpdf package that fixes several security issues is now available for Red Hat Enterprise Linux 4.

This update has been rated as having important security impact by the Red Hat Security Response Team.

Relevant Releases Architectures

Red Hat Enterprise Linux AS version 4 - i386, ia64, ppc, s390, s390x, x86_64

Red Hat Enterprise Linux Desktop version 4 - i386, x86_64

Red Hat Enterprise Linux ES version 4 - i386, ia64, x86_64

Red Hat Enterprise Linux WS version 4 - i386, ia64, x86_64

3. Problem description:

The gpdf package is a GNOME based viewer for Portable Document Format

(PDF) files.

Several flaws were discovered in gpdf. An attacker could construct a

carefully crafted PDF file that could cause gpdf to crash or possibly

execute arbitrary code when opened. The Common Vulnerabilities and

Exposures project assigned the names CVE-2005-3191, CVE-2005-3192, and

CVE-2005-3193 to these issues.

Users of gpdf should upgrade to this updated package, which contains a

backported patch to resolve these issues.

Bugs Fixed

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.