Linux Security
    Linux Security
    Linux Security

    RedHat: RHSA-2020-4295:01 Moderate: rh-postgresql96-postgresql security

    Date 21 Oct 2020
    204
    Posted By LinuxSecurity Advisories
    An update for rh-postgresql96-postgresql is now available for Red Hat Software Collections. Red Hat Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which
    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA256
    
    =====================================================================
                       Red Hat Security Advisory
    
    Synopsis:          Moderate: rh-postgresql96-postgresql security update
    Advisory ID:       RHSA-2020:4295-01
    Product:           Red Hat Software Collections
    Advisory URL:      https://access.redhat.com/errata/RHSA-2020:4295
    Issue date:        2020-10-21
    CVE Names:         CVE-2019-10130 CVE-2019-10208 CVE-2020-1720 
                       CVE-2020-14350 
    =====================================================================
    
    1. Summary:
    
    An update for rh-postgresql96-postgresql is now available for Red Hat
    Software Collections.
    
    Red Hat Product Security has rated this update as having a security impact
    of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which
    gives a detailed severity rating, is available for each vulnerability from
    the CVE link(s) in the References section.
    
    2. Relevant releases/architectures:
    
    Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) - aarch64, ppc64le, s390x, x86_64
    Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) - x86_64
    
    3. Description:
    
    PostgreSQL is an advanced object-relational database management system
    (DBMS).
    
    The following packages have been upgraded to a later upstream version:
    rh-postgresql96-postgresql (9.6.19). (BZ#1881766, BZ#1881769, BZ#1881771,
    BZ#1881773)
    
    Security Fix(es):
    
    * postgresql: TYPE in pg_temp executes arbitrary SQL during SECURITY
    DEFINER execution (CVE-2019-10208)
    
    * postgresql: Uncontrolled search path element in CREATE EXTENSION
    (CVE-2020-14350)
    
    * postgresql: Selectivity estimators bypass row security policies
    (CVE-2019-10130)
    
    * postgresql: ALTER ... DEPENDS ON EXTENSION is missing authorization
    checks (CVE-2020-1720)
    
    For more details about the security issue(s), including the impact, a CVSS
    score, acknowledgments, and other related information, refer to the CVE
    page(s) listed in the References section.
    
    4. Solution:
    
    For details on how to apply this update, which includes the changes
    described in this advisory, refer to:
    
    https://access.redhat.com/articles/11258
    
    If the postgresql service is running, it will be automatically restarted
    after installing this update.
    
    5. Bugs fixed (https://bugzilla.redhat.com/):
    
    1707109 - CVE-2019-10130 postgresql: Selectivity estimators bypass row security policies
    1734416 - CVE-2019-10208 postgresql: TYPE in pg_temp executes arbitrary SQL during SECURITY DEFINER execution
    1798852 - CVE-2020-1720 postgresql: ALTER ... DEPENDS ON EXTENSION is missing authorization checks
    1865746 - CVE-2020-14350 postgresql: Uncontrolled search path element in CREATE EXTENSION
    
    6. Package List:
    
    Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7):
    
    Source:
    rh-postgresql96-postgresql-9.6.19-1.el7.src.rpm
    
    aarch64:
    rh-postgresql96-postgresql-9.6.19-1.el7.aarch64.rpm
    rh-postgresql96-postgresql-contrib-9.6.19-1.el7.aarch64.rpm
    rh-postgresql96-postgresql-contrib-syspaths-9.6.19-1.el7.aarch64.rpm
    rh-postgresql96-postgresql-debuginfo-9.6.19-1.el7.aarch64.rpm
    rh-postgresql96-postgresql-devel-9.6.19-1.el7.aarch64.rpm
    rh-postgresql96-postgresql-docs-9.6.19-1.el7.aarch64.rpm
    rh-postgresql96-postgresql-libs-9.6.19-1.el7.aarch64.rpm
    rh-postgresql96-postgresql-plperl-9.6.19-1.el7.aarch64.rpm
    rh-postgresql96-postgresql-plpython-9.6.19-1.el7.aarch64.rpm
    rh-postgresql96-postgresql-pltcl-9.6.19-1.el7.aarch64.rpm
    rh-postgresql96-postgresql-server-9.6.19-1.el7.aarch64.rpm
    rh-postgresql96-postgresql-server-syspaths-9.6.19-1.el7.aarch64.rpm
    rh-postgresql96-postgresql-static-9.6.19-1.el7.aarch64.rpm
    rh-postgresql96-postgresql-syspaths-9.6.19-1.el7.aarch64.rpm
    rh-postgresql96-postgresql-test-9.6.19-1.el7.aarch64.rpm
    
    ppc64le:
    rh-postgresql96-postgresql-9.6.19-1.el7.ppc64le.rpm
    rh-postgresql96-postgresql-contrib-9.6.19-1.el7.ppc64le.rpm
    rh-postgresql96-postgresql-contrib-syspaths-9.6.19-1.el7.ppc64le.rpm
    rh-postgresql96-postgresql-debuginfo-9.6.19-1.el7.ppc64le.rpm
    rh-postgresql96-postgresql-devel-9.6.19-1.el7.ppc64le.rpm
    rh-postgresql96-postgresql-docs-9.6.19-1.el7.ppc64le.rpm
    rh-postgresql96-postgresql-libs-9.6.19-1.el7.ppc64le.rpm
    rh-postgresql96-postgresql-plperl-9.6.19-1.el7.ppc64le.rpm
    rh-postgresql96-postgresql-plpython-9.6.19-1.el7.ppc64le.rpm
    rh-postgresql96-postgresql-pltcl-9.6.19-1.el7.ppc64le.rpm
    rh-postgresql96-postgresql-server-9.6.19-1.el7.ppc64le.rpm
    rh-postgresql96-postgresql-server-syspaths-9.6.19-1.el7.ppc64le.rpm
    rh-postgresql96-postgresql-static-9.6.19-1.el7.ppc64le.rpm
    rh-postgresql96-postgresql-syspaths-9.6.19-1.el7.ppc64le.rpm
    rh-postgresql96-postgresql-test-9.6.19-1.el7.ppc64le.rpm
    
    s390x:
    rh-postgresql96-postgresql-9.6.19-1.el7.s390x.rpm
    rh-postgresql96-postgresql-contrib-9.6.19-1.el7.s390x.rpm
    rh-postgresql96-postgresql-contrib-syspaths-9.6.19-1.el7.s390x.rpm
    rh-postgresql96-postgresql-debuginfo-9.6.19-1.el7.s390x.rpm
    rh-postgresql96-postgresql-devel-9.6.19-1.el7.s390x.rpm
    rh-postgresql96-postgresql-docs-9.6.19-1.el7.s390x.rpm
    rh-postgresql96-postgresql-libs-9.6.19-1.el7.s390x.rpm
    rh-postgresql96-postgresql-plperl-9.6.19-1.el7.s390x.rpm
    rh-postgresql96-postgresql-plpython-9.6.19-1.el7.s390x.rpm
    rh-postgresql96-postgresql-pltcl-9.6.19-1.el7.s390x.rpm
    rh-postgresql96-postgresql-server-9.6.19-1.el7.s390x.rpm
    rh-postgresql96-postgresql-server-syspaths-9.6.19-1.el7.s390x.rpm
    rh-postgresql96-postgresql-static-9.6.19-1.el7.s390x.rpm
    rh-postgresql96-postgresql-syspaths-9.6.19-1.el7.s390x.rpm
    rh-postgresql96-postgresql-test-9.6.19-1.el7.s390x.rpm
    
    Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7):
    
    Source:
    rh-postgresql96-postgresql-9.6.19-1.el7.src.rpm
    
    aarch64:
    rh-postgresql96-postgresql-9.6.19-1.el7.aarch64.rpm
    rh-postgresql96-postgresql-contrib-9.6.19-1.el7.aarch64.rpm
    rh-postgresql96-postgresql-contrib-syspaths-9.6.19-1.el7.aarch64.rpm
    rh-postgresql96-postgresql-debuginfo-9.6.19-1.el7.aarch64.rpm
    rh-postgresql96-postgresql-devel-9.6.19-1.el7.aarch64.rpm
    rh-postgresql96-postgresql-docs-9.6.19-1.el7.aarch64.rpm
    rh-postgresql96-postgresql-libs-9.6.19-1.el7.aarch64.rpm
    rh-postgresql96-postgresql-plperl-9.6.19-1.el7.aarch64.rpm
    rh-postgresql96-postgresql-plpython-9.6.19-1.el7.aarch64.rpm
    rh-postgresql96-postgresql-pltcl-9.6.19-1.el7.aarch64.rpm
    rh-postgresql96-postgresql-server-9.6.19-1.el7.aarch64.rpm
    rh-postgresql96-postgresql-server-syspaths-9.6.19-1.el7.aarch64.rpm
    rh-postgresql96-postgresql-static-9.6.19-1.el7.aarch64.rpm
    rh-postgresql96-postgresql-syspaths-9.6.19-1.el7.aarch64.rpm
    rh-postgresql96-postgresql-test-9.6.19-1.el7.aarch64.rpm
    
    ppc64le:
    rh-postgresql96-postgresql-9.6.19-1.el7.ppc64le.rpm
    rh-postgresql96-postgresql-contrib-9.6.19-1.el7.ppc64le.rpm
    rh-postgresql96-postgresql-contrib-syspaths-9.6.19-1.el7.ppc64le.rpm
    rh-postgresql96-postgresql-debuginfo-9.6.19-1.el7.ppc64le.rpm
    rh-postgresql96-postgresql-devel-9.6.19-1.el7.ppc64le.rpm
    rh-postgresql96-postgresql-docs-9.6.19-1.el7.ppc64le.rpm
    rh-postgresql96-postgresql-libs-9.6.19-1.el7.ppc64le.rpm
    rh-postgresql96-postgresql-plperl-9.6.19-1.el7.ppc64le.rpm
    rh-postgresql96-postgresql-plpython-9.6.19-1.el7.ppc64le.rpm
    rh-postgresql96-postgresql-pltcl-9.6.19-1.el7.ppc64le.rpm
    rh-postgresql96-postgresql-server-9.6.19-1.el7.ppc64le.rpm
    rh-postgresql96-postgresql-server-syspaths-9.6.19-1.el7.ppc64le.rpm
    rh-postgresql96-postgresql-static-9.6.19-1.el7.ppc64le.rpm
    rh-postgresql96-postgresql-syspaths-9.6.19-1.el7.ppc64le.rpm
    rh-postgresql96-postgresql-test-9.6.19-1.el7.ppc64le.rpm
    
    s390x:
    rh-postgresql96-postgresql-9.6.19-1.el7.s390x.rpm
    rh-postgresql96-postgresql-contrib-9.6.19-1.el7.s390x.rpm
    rh-postgresql96-postgresql-contrib-syspaths-9.6.19-1.el7.s390x.rpm
    rh-postgresql96-postgresql-debuginfo-9.6.19-1.el7.s390x.rpm
    rh-postgresql96-postgresql-devel-9.6.19-1.el7.s390x.rpm
    rh-postgresql96-postgresql-docs-9.6.19-1.el7.s390x.rpm
    rh-postgresql96-postgresql-libs-9.6.19-1.el7.s390x.rpm
    rh-postgresql96-postgresql-plperl-9.6.19-1.el7.s390x.rpm
    rh-postgresql96-postgresql-plpython-9.6.19-1.el7.s390x.rpm
    rh-postgresql96-postgresql-pltcl-9.6.19-1.el7.s390x.rpm
    rh-postgresql96-postgresql-server-9.6.19-1.el7.s390x.rpm
    rh-postgresql96-postgresql-server-syspaths-9.6.19-1.el7.s390x.rpm
    rh-postgresql96-postgresql-static-9.6.19-1.el7.s390x.rpm
    rh-postgresql96-postgresql-syspaths-9.6.19-1.el7.s390x.rpm
    rh-postgresql96-postgresql-test-9.6.19-1.el7.s390x.rpm
    
    x86_64:
    rh-postgresql96-postgresql-9.6.19-1.el7.x86_64.rpm
    rh-postgresql96-postgresql-contrib-9.6.19-1.el7.x86_64.rpm
    rh-postgresql96-postgresql-contrib-syspaths-9.6.19-1.el7.x86_64.rpm
    rh-postgresql96-postgresql-debuginfo-9.6.19-1.el7.x86_64.rpm
    rh-postgresql96-postgresql-devel-9.6.19-1.el7.x86_64.rpm
    rh-postgresql96-postgresql-docs-9.6.19-1.el7.x86_64.rpm
    rh-postgresql96-postgresql-libs-9.6.19-1.el7.x86_64.rpm
    rh-postgresql96-postgresql-plperl-9.6.19-1.el7.x86_64.rpm
    rh-postgresql96-postgresql-plpython-9.6.19-1.el7.x86_64.rpm
    rh-postgresql96-postgresql-pltcl-9.6.19-1.el7.x86_64.rpm
    rh-postgresql96-postgresql-server-9.6.19-1.el7.x86_64.rpm
    rh-postgresql96-postgresql-server-syspaths-9.6.19-1.el7.x86_64.rpm
    rh-postgresql96-postgresql-static-9.6.19-1.el7.x86_64.rpm
    rh-postgresql96-postgresql-syspaths-9.6.19-1.el7.x86_64.rpm
    rh-postgresql96-postgresql-test-9.6.19-1.el7.x86_64.rpm
    
    Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7):
    
    Source:
    rh-postgresql96-postgresql-9.6.19-1.el7.src.rpm
    
    x86_64:
    rh-postgresql96-postgresql-9.6.19-1.el7.x86_64.rpm
    rh-postgresql96-postgresql-contrib-9.6.19-1.el7.x86_64.rpm
    rh-postgresql96-postgresql-contrib-syspaths-9.6.19-1.el7.x86_64.rpm
    rh-postgresql96-postgresql-debuginfo-9.6.19-1.el7.x86_64.rpm
    rh-postgresql96-postgresql-devel-9.6.19-1.el7.x86_64.rpm
    rh-postgresql96-postgresql-docs-9.6.19-1.el7.x86_64.rpm
    rh-postgresql96-postgresql-libs-9.6.19-1.el7.x86_64.rpm
    rh-postgresql96-postgresql-plperl-9.6.19-1.el7.x86_64.rpm
    rh-postgresql96-postgresql-plpython-9.6.19-1.el7.x86_64.rpm
    rh-postgresql96-postgresql-pltcl-9.6.19-1.el7.x86_64.rpm
    rh-postgresql96-postgresql-server-9.6.19-1.el7.x86_64.rpm
    rh-postgresql96-postgresql-server-syspaths-9.6.19-1.el7.x86_64.rpm
    rh-postgresql96-postgresql-static-9.6.19-1.el7.x86_64.rpm
    rh-postgresql96-postgresql-syspaths-9.6.19-1.el7.x86_64.rpm
    rh-postgresql96-postgresql-test-9.6.19-1.el7.x86_64.rpm
    
    These packages are GPG signed by Red Hat for security.  Our key and
    details on how to verify the signature are available from
    https://access.redhat.com/security/team/key/
    
    7. References:
    
    https://access.redhat.com/security/cve/CVE-2019-10130
    https://access.redhat.com/security/cve/CVE-2019-10208
    https://access.redhat.com/security/cve/CVE-2020-1720
    https://access.redhat.com/security/cve/CVE-2020-14350
    https://access.redhat.com/security/updates/classification/#moderate
    
    8. Contact:
    
    The Red Hat security contact is . More contact
    details at https://access.redhat.com/security/team/contact/
    
    Copyright 2020 Red Hat, Inc.
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1
    
    iQIVAwUBX5Ayh9zjgjWX9erEAQjI8A//U4euOM0KLXCQV+LkjP3U4ef1QMrjHvua
    00jEadQL3Kc/y4yb5YL8WkbWJf+T9yH7PolaS05neY//UovyE4afXMYVdY98EM6T
    h/R+ULmkxS0zY7K7B69G9F4OO1wa4URf/qagn2urSRbCc0Y4OSrUuYjOIrC7DL0V
    JCglJ3JkceKb1YTdui6CoeCeh4vjrBjh2+YmgdId1qnochIA8jM2wi2tactBd724
    sNca2jyAeMT/CmBoX0WhTp47Ly99K2FxzxgNskuja9ukx4GZabS8sVD+EBkmRvzZ
    r6PWhn4980GzqAtTGaZ0UQuiRBg81jicTvWfocS9H330vUjwyiepP6oFVuntBEou
    zdnGa2BjvJF2HsLqTeRq9S4m7/WzMLMIbEFre1S3y4xqFMuK+rgVY5rFmiTFpfEL
    S7zMlpb4FwGq//gorniN2xMsFq2+gGeLmBFxJqxScWSiBV+iDH2YJFaH4nTGuP/6
    LAoUhlMG+E3ZOWWSE+VQnSvET+FKmkfUhnV7qwXEtKH2+vfHgVdRcfgZnO09lqU2
    /BLpVxGNVhkOB7CM9tM9JziddtsRTDETdCSK01n9uxCHHoXLamLKxfF8JEujChhn
    XOfF+icIUFAJu95AaIhRDzUORZHPi37BltsF9hl3Q2tXXltCK6XBvb75YlORgxsM
    aRhforJCInM=
    =bRgk
    -----END PGP SIGNATURE-----
    
    --
    RHSA-announce mailing list
    This email address is being protected from spambots. You need JavaScript enabled to view it.
    https://www.redhat.com/mailman/listinfo/rhsa-announce
    

    Advisories

    LinuxSecurity Poll

    I agree with Linus Torvalds - Apple's new M1-powered laptops should run on Linux.

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 2 answer(s).
    /main-polls/45-i-agree-with-linus-torvalds-apple-s-new-m1-powered-laptops-should-run-on-linux?task=poll.vote&format=json
    45
    radio
    [{"id":"158","title":"True","votes":"18","type":"x","order":"1","pct":3.5,"resources":[]},{"id":"159","title":"False","votes":"496","type":"x","order":"2","pct":96.5,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350

    Please vote first in order to view vote results.


    VIEW MORE POLLS

    bottom 200

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.