-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Important: Red Hat Single Sign-On 7.4.5 security update
Advisory ID:       RHSA-2021:0327-01
Product:           Red Hat Single Sign-On
Advisory URL:      https://access.redhat.com/errata/RHSA-2021:0327
Issue date:        2021-02-01
CVE Names:         CVE-2020-10770 CVE-2020-13956 CVE-2020-25640 
                   CVE-2020-25689 CVE-2020-27782 
=====================================================================

1. Summary:

A security update is now available for Red Hat Single Sign-On 7.4 from the
Customer Portal.

Red Hat Product Security has rated this update as having a security impact
of Important. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available for each vulnerability
from the CVE link(s) in the References section.

2. Description:

Red Hat Single Sign-On 7.4 is a standalone server, based on the Keycloak
project, that provides authentication and standards-based single sign-on
capabilities for web and mobile applications.

This release of Red Hat Single Sign-On 7.4.5 serves as a replacement for
Red Hat Single Sign-On 7.4.4, and includes bug fixes and enhancements,
which are documented in the Release Notes document linked to in the
References.

Security Fix(es):

* undertow: special character in query results in server errors
(CVE-2020-27782)

* keycloak: Default Client configuration is vulnerable to SSRF using
"request_uri" parameter (CVE-2020-10770)

* apache-httpclient: incorrect handling of malformed authority component in
request URIs (CVE-2020-13956)

* wildfly: resource adapter logs plaintext JMS password at warning level on
connection error (CVE-2020-25640)

* wildfly-core: memory leak in WildFly host-controller in domain mode while
not able to reconnect to domain-controller (CVE-2020-25689)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

3. Solution:

Before applying the update, back up your existing installation, including
all applications, configuration files, databases and database settings, and
so on.

The References section of this erratum contains a download link (you must
log in to download the update).

4. Bugs fixed (https://bugzilla.redhat.com/):

1846270 - CVE-2020-10770 keycloak: Default Client configuration is vulnerable to SSRF using "request_uri" parameter
1881637 - CVE-2020-25640 wildfly: resource adapter logs plaintext JMS password at warning level on connection error
1886587 - CVE-2020-13956 apache-httpclient: incorrect handling of malformed authority component in request URIs
1893070 - CVE-2020-25689 wildfly-core: memory leak in WildFly host-controller in domain mode while not able to reconnect to domain-controller
1901304 - CVE-2020-27782 undertow: special character in query results in server errors

5. References:

https://access.redhat.com/security/cve/CVE-2020-10770
https://access.redhat.com/security/cve/CVE-2020-13956
https://access.redhat.com/security/cve/CVE-2020-25640
https://access.redhat.com/security/cve/CVE-2020-25689
https://access.redhat.com/security/cve/CVE-2020-27782
https://access.redhat.com/security/updates/classification/#important
https://access.redhat.com/jbossnetwork/restricted/listSoftware.html?downloadType=securityPatches&product=core.service.rhsso&version=7.4
https://access.redhat.com/documentation/en-us/red_hat_single_sign-on/7.4/html/release_notes/index

6. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2021 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBYBhPDtzjgjWX9erEAQjORQ//cfWMyWGtytmQcKnk71PXXnv5GfyLDlP4
b7mwJ43OF3UpEMMJOU0CDy+abQQXRKBGHuzz7RVWXa1a/U2BRwFX7yw3ZMwO9ilO
pNgNXO9LGew3+HeDmz9sXmWBRXbf65dFlvrHxU0GjuSbp/xWCoXx3fcy6ObE5gxO
F04qi9y0JM1C+Rc7bYjtqjXSFNrbT7E2zrQXFSIyLfbpw61/f0brAT/4kanMf30w
HorLGN9mxNS0t1iVx7pUjePmN//dar1ejpkQegdE1a0P0B6IxJi5j3yQzeVmgn6+
FXEvMnT+Zc2VUFxFpHfKiYW/CT0laynaGxA02R07/j4NCUSR+hu4/u8nbzuZumlb
3nh6OtqfZUpmoVH/aWvdrMDxb7drnEShnF7ntu3m1TJxa1aPJN7sjw/1bnGJTjVO
Dj7G2pVuUcjoOAxClqmonPmdHNam9hlKcnAtqQ3Db4Z5T4Q+YrzvaojhP3ttBmf4
yE8vcKthr03/Ra7rZai1EQ6vuiawOZfHN+XUMi0oOAcunt0NzVJnA12156eSASvf
qrVwFURGleI1fEQpLmwc8Kowcatuslc9oNShZF3YD5LCxfOe8L8nK9iTBscWUR3Y
pv5I2WB8dDkA64JAFDMPGVW32FHkuOe7mQIuN+8+hjccsvBIMSPZn+nbaTQEwa0m
tu549Rq2hCo=
=REzE
-----END PGP SIGNATURE-----

--
RHSA-announce mailing list
[email protected]
https://www.redhat.com/mailman/listinfo/rhsa-announce