-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Moderate: perl security update
Advisory ID:       RHSA-2021:1032-01
Product:           Red Hat Enterprise Linux
Advisory URL:      https://access.redhat.com/errata/RHSA-2021:1032
Issue date:        2021-03-30
CVE Names:         CVE-2020-10543 CVE-2020-10878 CVE-2020-12723 
=====================================================================

1. Summary:

An update for perl is now available for Red Hat Enterprise Linux 7.7
Extended Update Support.

Red Hat Product Security has rated this update as having a security impact
of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which
gives a detailed severity rating, is available for each vulnerability from
the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux ComputeNode EUS (v. 7.7) - noarch, x86_64
Red Hat Enterprise Linux ComputeNode Optional EUS (v. 7.7) - x86_64
Red Hat Enterprise Linux Server EUS (v. 7.7) - noarch, ppc64, ppc64le, s390x, x86_64
Red Hat Enterprise Linux Server Optional EUS (v. 7.7) - ppc64, ppc64le, s390x, x86_64

3. Description:

Perl is a high-level programming language that is commonly used for system
administration utilities and web programming.

Security Fix(es):

* perl: heap-based buffer overflow in regular expression compiler leads to
DoS (CVE-2020-10543)

* perl: corruption of intermediate language state of compiled regular
expression due to integer overflow leads to DoS (CVE-2020-10878)

* perl: corruption of intermediate language state of compiled regular
expression due to recursive S_study_chunk() calls leads to DoS
(CVE-2020-12723)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

1837975 - CVE-2020-10543 perl: heap-based buffer overflow in regular expression compiler leads to DoS
1837988 - CVE-2020-10878 perl: corruption of intermediate language state of compiled regular expression due to integer overflow leads to DoS
1838000 - CVE-2020-12723 perl: corruption of intermediate language state of compiled regular expression due to recursive S_study_chunk() calls leads to DoS
1930185 - perl FTBFS: ../cpan/Time-Local/t/Local.t test fails in year 2020 [rhel-7.7.z]

6. Package List:

Red Hat Enterprise Linux ComputeNode EUS (v. 7.7):

Source:
perl-5.16.3-294.el7_7.1.src.rpm

noarch:
perl-CPAN-1.9800-294.el7_7.1.noarch.rpm
perl-ExtUtils-CBuilder-0.28.2.6-294.el7_7.1.noarch.rpm
perl-ExtUtils-Embed-1.30-294.el7_7.1.noarch.rpm
perl-ExtUtils-Install-1.58-294.el7_7.1.noarch.rpm
perl-IO-Zlib-1.10-294.el7_7.1.noarch.rpm
perl-Locale-Maketext-Simple-0.21-294.el7_7.1.noarch.rpm
perl-Module-CoreList-2.76.02-294.el7_7.1.noarch.rpm
perl-Module-Loaded-0.08-294.el7_7.1.noarch.rpm
perl-Object-Accessor-0.42-294.el7_7.1.noarch.rpm
perl-Package-Constants-0.02-294.el7_7.1.noarch.rpm
perl-Pod-Escapes-1.04-294.el7_7.1.noarch.rpm

x86_64:
perl-5.16.3-294.el7_7.1.x86_64.rpm
perl-Time-Piece-1.20.1-294.el7_7.1.x86_64.rpm
perl-core-5.16.3-294.el7_7.1.x86_64.rpm
perl-debuginfo-5.16.3-294.el7_7.1.i686.rpm
perl-debuginfo-5.16.3-294.el7_7.1.x86_64.rpm
perl-devel-5.16.3-294.el7_7.1.i686.rpm
perl-devel-5.16.3-294.el7_7.1.x86_64.rpm
perl-libs-5.16.3-294.el7_7.1.i686.rpm
perl-libs-5.16.3-294.el7_7.1.x86_64.rpm
perl-macros-5.16.3-294.el7_7.1.x86_64.rpm

Red Hat Enterprise Linux ComputeNode Optional EUS (v. 7.7):

x86_64:
perl-debuginfo-5.16.3-294.el7_7.1.x86_64.rpm
perl-tests-5.16.3-294.el7_7.1.x86_64.rpm

Red Hat Enterprise Linux Server EUS (v. 7.7):

Source:
perl-5.16.3-294.el7_7.1.src.rpm

noarch:
perl-CPAN-1.9800-294.el7_7.1.noarch.rpm
perl-ExtUtils-CBuilder-0.28.2.6-294.el7_7.1.noarch.rpm
perl-ExtUtils-Embed-1.30-294.el7_7.1.noarch.rpm
perl-ExtUtils-Install-1.58-294.el7_7.1.noarch.rpm
perl-IO-Zlib-1.10-294.el7_7.1.noarch.rpm
perl-Locale-Maketext-Simple-0.21-294.el7_7.1.noarch.rpm
perl-Module-CoreList-2.76.02-294.el7_7.1.noarch.rpm
perl-Module-Loaded-0.08-294.el7_7.1.noarch.rpm
perl-Object-Accessor-0.42-294.el7_7.1.noarch.rpm
perl-Package-Constants-0.02-294.el7_7.1.noarch.rpm
perl-Pod-Escapes-1.04-294.el7_7.1.noarch.rpm

ppc64:
perl-5.16.3-294.el7_7.1.ppc64.rpm
perl-Time-Piece-1.20.1-294.el7_7.1.ppc64.rpm
perl-core-5.16.3-294.el7_7.1.ppc64.rpm
perl-debuginfo-5.16.3-294.el7_7.1.ppc.rpm
perl-debuginfo-5.16.3-294.el7_7.1.ppc64.rpm
perl-devel-5.16.3-294.el7_7.1.ppc.rpm
perl-devel-5.16.3-294.el7_7.1.ppc64.rpm
perl-libs-5.16.3-294.el7_7.1.ppc.rpm
perl-libs-5.16.3-294.el7_7.1.ppc64.rpm
perl-macros-5.16.3-294.el7_7.1.ppc64.rpm

ppc64le:
perl-5.16.3-294.el7_7.1.ppc64le.rpm
perl-Time-Piece-1.20.1-294.el7_7.1.ppc64le.rpm
perl-core-5.16.3-294.el7_7.1.ppc64le.rpm
perl-debuginfo-5.16.3-294.el7_7.1.ppc64le.rpm
perl-devel-5.16.3-294.el7_7.1.ppc64le.rpm
perl-libs-5.16.3-294.el7_7.1.ppc64le.rpm
perl-macros-5.16.3-294.el7_7.1.ppc64le.rpm

s390x:
perl-5.16.3-294.el7_7.1.s390x.rpm
perl-Time-Piece-1.20.1-294.el7_7.1.s390x.rpm
perl-core-5.16.3-294.el7_7.1.s390x.rpm
perl-debuginfo-5.16.3-294.el7_7.1.s390.rpm
perl-debuginfo-5.16.3-294.el7_7.1.s390x.rpm
perl-devel-5.16.3-294.el7_7.1.s390.rpm
perl-devel-5.16.3-294.el7_7.1.s390x.rpm
perl-libs-5.16.3-294.el7_7.1.s390.rpm
perl-libs-5.16.3-294.el7_7.1.s390x.rpm
perl-macros-5.16.3-294.el7_7.1.s390x.rpm

x86_64:
perl-5.16.3-294.el7_7.1.x86_64.rpm
perl-Time-Piece-1.20.1-294.el7_7.1.x86_64.rpm
perl-core-5.16.3-294.el7_7.1.x86_64.rpm
perl-debuginfo-5.16.3-294.el7_7.1.i686.rpm
perl-debuginfo-5.16.3-294.el7_7.1.x86_64.rpm
perl-devel-5.16.3-294.el7_7.1.i686.rpm
perl-devel-5.16.3-294.el7_7.1.x86_64.rpm
perl-libs-5.16.3-294.el7_7.1.i686.rpm
perl-libs-5.16.3-294.el7_7.1.x86_64.rpm
perl-macros-5.16.3-294.el7_7.1.x86_64.rpm

Red Hat Enterprise Linux Server Optional EUS (v. 7.7):

ppc64:
perl-debuginfo-5.16.3-294.el7_7.1.ppc64.rpm
perl-tests-5.16.3-294.el7_7.1.ppc64.rpm

ppc64le:
perl-debuginfo-5.16.3-294.el7_7.1.ppc64le.rpm
perl-tests-5.16.3-294.el7_7.1.ppc64le.rpm

s390x:
perl-debuginfo-5.16.3-294.el7_7.1.s390x.rpm
perl-tests-5.16.3-294.el7_7.1.s390x.rpm

x86_64:
perl-debuginfo-5.16.3-294.el7_7.1.x86_64.rpm
perl-tests-5.16.3-294.el7_7.1.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2020-10543
https://access.redhat.com/security/cve/CVE-2020-10878
https://access.redhat.com/security/cve/CVE-2020-12723
https://access.redhat.com/security/updates/classification/#moderate

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2021 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBYGLwtdzjgjWX9erEAQh/SA/9GENjf1AD4oPsRe6GzOIPR5HIuRSixHcc
RUyMNqGsQ+piL824iq37aGqtl96Dvp67BpbeHEzAWTg3bPmrsaM1eXOR5awF9wuc
f99kmE2UCTzdhtp4MDBrzRFidpi1FEwqNhOa9pSZH1My6+3PDhV4XtXysgQ7SDlw
HJqf3mvfPrZdGcqNoOHWWjRyoH0OodJkPFn1ZoKAXn70HCVuTa0wcng18cWd8zs1
v210iFTCFWaDZpWc69HSV56+crM3alWfW8myDBdaVq9g4iWmK51pbA9Yp4AS4Hjy
09DzL8MJ3QEJjUYoo+siaaNz8bQGyCckhbrSDOgjUjU/QXxRouN5YyjIOnO8DOBc
g7Qp2fceXmt8q7dn1YOgIFXGHbjwbMYiDhs39Fn6MuT3r1+ofbj/KMWa2icL5Nje
ZetQ5eI+3A+irpef4wS0xMgEgr3PkGKmuxxauoq+y7BgbqD1EDs/ItHVzQKfPdPF
m7uQ2mmqdO4rasKRGB0d4pO4yFCqyf6lBqxAEjexY0hyp1JPyJolGmWpYJP6LtJ4
7eKIPjnQgxCWOySa//2xxMSDVLj088zvLGf8eq2xmwV1+cyUXWQ9dkxdyImTO9IZ
W6xporFLVbxX+fajaoZQQdHj7UxGpJY3rKofgFQQleRz22JSbvKhqydR36QFBRsR
WUNYnqDSxIM=
=ci9w
-----END PGP SIGNATURE-----

--
RHSA-announce mailing list
[email protected]
https://listman.redhat.com/mailman/listinfo/rhsa-announce