RedHat: RHSA-2021-1566:01 Important: OpenShift Container Platform 4...

Advisories

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Important: OpenShift Container Platform 4.6.30 packages and security update
Advisory ID:       RHSA-2021:1566-01
Product:           Red Hat OpenShift Enterprise
Advisory URL:      https://access.redhat.com/errata/RHSA-2021:1566
Issue date:        2021-05-26
CVE Names:         CVE-2021-30465 
=====================================================================

1. Summary:

Red Hat OpenShift Container Platform release 4.6.30 is now available with
updates to packages and images that fix several bugs and add enhancements.

This release includes a security update for Red Hat OpenShift Container
Platform 4.6.

Red Hat Product Security has rated this update as having a security impact
of Important. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available for each vulnerability
from the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat OpenShift Container Platform 4.6 - ppc64le, s390x, x86_64

3. Description:

Red Hat OpenShift Container Platform is Red Hat's cloud computing
Kubernetes application platform solution designed for on-premise or private
cloud deployments.

This advisory contains the RPM packages for Red Hat OpenShift Container
Platform 4.6.30. See the following advisory for the container images for
this release:

https://access.redhat.com/errata/RHBA-2021:1565

The runC tool is a lightweight, portable implementation of the Open
Container Format (OCF) that provides container runtime.

Security Fix(es):

* runc: vulnerable to symlink exchange attack (CVE-2021-30465)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

All OpenShift Container Platform 4.6 users are advised to upgrade to these
updated packages and images when they are available in the appropriate
release
channel. To check for available updates, use the OpenShift Console or the
CLI oc command. Instructions for upgrading a cluster are available at
https://docs.openshift.com/container-platform/4.6/updating/updating-cluster
- -between-minor.html#understanding-upgrade-channels_updating-cluster-between
- -minor

4. Solution:

For OpenShift Container Platform 4.6 see the following documentation, which
will be updated shortly for this release, for important instructions on how
to upgrade your cluster and fully apply this asynchronous errata update:

https://docs.openshift.com/container-platform/4.6/release_notes/ocp-4-6-rel
ease-notes.html

Details on how to access this content are available at
https://docs.openshift.com/container-platform/4.6/updating/updating-cluster
- -cli.html

5. Bugs fixed (https://bugzilla.redhat.com/):

1954736 - CVE-2021-30465 runc: vulnerable to symlink exchange attack
1961019 - Placeholder bug for OCP 4.6.0 rpm release

6. Package List:

Red Hat OpenShift Container Platform 4.6:

Source:
openshift-4.6.0-202105150940.p0.git.9caf8fe.el7.src.rpm
runc-1.0.0-87.rhaos4.6.git23384e2.el7.src.rpm

x86_64:
openshift-hyperkube-4.6.0-202105150940.p0.git.9caf8fe.el7.x86_64.rpm
runc-1.0.0-87.rhaos4.6.git23384e2.el7.x86_64.rpm
runc-debuginfo-1.0.0-87.rhaos4.6.git23384e2.el7.x86_64.rpm

Red Hat OpenShift Container Platform 4.6:

Source:
openshift-4.6.0-202105150940.p0.git.9caf8fe.el8.src.rpm
runc-1.0.0-87.rhaos4.6.git23384e2.el8.src.rpm

ppc64le:
openshift-hyperkube-4.6.0-202105150940.p0.git.9caf8fe.el8.ppc64le.rpm
runc-1.0.0-87.rhaos4.6.git23384e2.el8.ppc64le.rpm
runc-debuginfo-1.0.0-87.rhaos4.6.git23384e2.el8.ppc64le.rpm
runc-debugsource-1.0.0-87.rhaos4.6.git23384e2.el8.ppc64le.rpm

s390x:
openshift-hyperkube-4.6.0-202105150940.p0.git.9caf8fe.el8.s390x.rpm
runc-1.0.0-87.rhaos4.6.git23384e2.el8.s390x.rpm
runc-debuginfo-1.0.0-87.rhaos4.6.git23384e2.el8.s390x.rpm
runc-debugsource-1.0.0-87.rhaos4.6.git23384e2.el8.s390x.rpm

x86_64:
openshift-hyperkube-4.6.0-202105150940.p0.git.9caf8fe.el8.x86_64.rpm
runc-1.0.0-87.rhaos4.6.git23384e2.el8.x86_64.rpm
runc-debuginfo-1.0.0-87.rhaos4.6.git23384e2.el8.x86_64.rpm
runc-debugsource-1.0.0-87.rhaos4.6.git23384e2.el8.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2021-30465
https://access.redhat.com/security/updates/classification/#important
https://access.redhat.com/security/vulnerabilities/RHSB-2021-004

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2021 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBYK3kL9zjgjWX9erEAQiExA/6AgcSsSXP8zb1b6KrfrKDpHS+7CZyi8kx
/sWXxA+J5t64gleb5qC0QaOpSDo6xIAt0Yj9cAQOe5czXZlisyUQGNb9jue7Kbqt
/Xwn8FmVuCGRIrFvDcQL4m+ve9/99Nt6JcNVh8RFjYghmnj3nHkKCc94JpcYdxX4
XJvlNIobgD8KCsuVXwyeR5C7Is3tb/0MonwnmEY3fvJ9Ui0XfWCjEnIeHEFycEv2
SsUyPlOpnwlMZ5arkzWPHspFf6e/fCrSYq68pYMwoF2gHVJFfqftsV0z71wSB4qC
6QjrJqatTp+8EVi4XKj3fO+7zLLqC2VeFGXhEh5B2q5ii03x+Y73EYvWPQ2MsrYw
LP8zktTUU2G5uOYzKBiNuVvXEJLABj662ZFe3byr/oakduvinAC/BKX2zHsXlDf7
HcuGfqIRVRN5WELpYvf+uzPNKtFz47U+i0YzKP0wRmy7T3RNmpz703RA3S0Y4AyD
IWNTDG/zfP9EDmGtTreQuxWAUOglANCSoXryAY1XS2ZT7lqlmhqYudzuxJb3QQ+m
uE9w00AxwkZgeIpwy8sWQl3ncFBMChkJn1AyQmdUOY0dgxrS39CJbFWbOx/blrPS
H/pzlfQMZTgg9/2dVZnHMQkom2eUTD9s2o0szbbnonukAunBd+ImMD2BqBuRiWbu
2B6URYVvx1A=
=BqF1
-----END PGP SIGNATURE-----

--
RHSA-announce mailing list
[email protected]
https://listman.redhat.com/mailman/listinfo/rhsa-announce

RedHat: RHSA-2021-1566:01 Important: OpenShift Container Platform 4.6.30

Red Hat OpenShift Container Platform release 4.6.30 is now available with updates to packages and images that fix several bugs and add enhancements

Summary

Red Hat OpenShift Container Platform is Red Hat's cloud computing Kubernetes application platform solution designed for on-premise or private cloud deployments.
This advisory contains the RPM packages for Red Hat OpenShift Container Platform 4.6.30. See the following advisory for the container images for this release:
https://access.redhat.com/errata/RHBA-2021:1565
The runC tool is a lightweight, portable implementation of the Open Container Format (OCF) that provides container runtime.
Security Fix(es):
* runc: vulnerable to symlink exchange attack (CVE-2021-30465)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
All OpenShift Container Platform 4.6 users are advised to upgrade to these updated packages and images when they are available in the appropriate release channel. To check for available updates, use the OpenShift Console or the CLI oc command. Instructions for upgrading a cluster are available at https://docs.openshift.com/container-platform/4.6/updating/updating-cluster - -between-minor.html#understanding-upgrade-channels_updating-cluster-between - -minor

Solution

For OpenShift Container Platform 4.6 see the following documentation, whichwill be updated shortly for this release, for important instructions on howto upgrade your cluster and fully apply this asynchronous errata update:https://docs.openshift.com/container-platform/4.6/release_notes/ocp-4-6-release-notes.htmlDetails on how to access this content are available athttps://docs.openshift.com/container-platform/4.6/updating/updating-cluster- -cli.html

References

https://access.redhat.com/security/cve/CVE-2021-30465 https://access.redhat.com/security/updates/classification/#important https://access.redhat.com/security/vulnerabilities/RHSB-2021-004

Package List

Red Hat OpenShift Container Platform 4.6:
Source: openshift-4.6.0-202105150940.p0.git.9caf8fe.el7.src.rpm runc-1.0.0-87.rhaos4.6.git23384e2.el7.src.rpm
x86_64: openshift-hyperkube-4.6.0-202105150940.p0.git.9caf8fe.el7.x86_64.rpm runc-1.0.0-87.rhaos4.6.git23384e2.el7.x86_64.rpm runc-debuginfo-1.0.0-87.rhaos4.6.git23384e2.el7.x86_64.rpm
Red Hat OpenShift Container Platform 4.6:
Source: openshift-4.6.0-202105150940.p0.git.9caf8fe.el8.src.rpm runc-1.0.0-87.rhaos4.6.git23384e2.el8.src.rpm
ppc64le: openshift-hyperkube-4.6.0-202105150940.p0.git.9caf8fe.el8.ppc64le.rpm runc-1.0.0-87.rhaos4.6.git23384e2.el8.ppc64le.rpm runc-debuginfo-1.0.0-87.rhaos4.6.git23384e2.el8.ppc64le.rpm runc-debugsource-1.0.0-87.rhaos4.6.git23384e2.el8.ppc64le.rpm
s390x: openshift-hyperkube-4.6.0-202105150940.p0.git.9caf8fe.el8.s390x.rpm runc-1.0.0-87.rhaos4.6.git23384e2.el8.s390x.rpm runc-debuginfo-1.0.0-87.rhaos4.6.git23384e2.el8.s390x.rpm runc-debugsource-1.0.0-87.rhaos4.6.git23384e2.el8.s390x.rpm
x86_64: openshift-hyperkube-4.6.0-202105150940.p0.git.9caf8fe.el8.x86_64.rpm runc-1.0.0-87.rhaos4.6.git23384e2.el8.x86_64.rpm runc-debuginfo-1.0.0-87.rhaos4.6.git23384e2.el8.x86_64.rpm runc-debugsource-1.0.0-87.rhaos4.6.git23384e2.el8.x86_64.rpm
These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from https://access.redhat.com/security/team/key/

Severity
Advisory ID: RHSA-2021:1566-01
Product: Red Hat OpenShift Enterprise
Advisory URL: https://access.redhat.com/errata/RHSA-2021:1566
Issued Date: : 2021-05-26
CVE Names: CVE-2021-30465

Topic

Red Hat OpenShift Container Platform release 4.6.30 is now available withupdates to packages and images that fix several bugs and add enhancements.This release includes a security update for Red Hat OpenShift ContainerPlatform 4.6.Red Hat Product Security has rated this update as having a security impactof Important. A Common Vulnerability Scoring System (CVSS) base score,which gives a detailed severity rating, is available for each vulnerabilityfrom the CVE link(s) in the References section.

Relevant Releases Architectures

Red Hat OpenShift Container Platform 4.6 - ppc64le, s390x, x86_64

Bugs Fixed

1954736 - CVE-2021-30465 runc: vulnerable to symlink exchange attack

1961019 - Placeholder bug for OCP 4.6.0 rpm release

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.