RedHat: RHSA-2021-2394:01 Important: rh-postgresql12-postgresql sec...

Advisories

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Important: rh-postgresql12-postgresql security update
Advisory ID:       RHSA-2021:2394-01
Product:           Red Hat Software Collections
Advisory URL:      https://access.redhat.com/errata/RHSA-2021:2394
Issue date:        2021-06-14
CVE Names:         CVE-2021-3393 CVE-2021-32027 CVE-2021-32028 
                   CVE-2021-32029 
=====================================================================

1. Summary:

An update for rh-postgresql12-postgresql is now available for Red Hat
Software Collections.

Red Hat Product Security has rated this update as having a security impact
of Important. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available for each vulnerability
from the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) - ppc64le, s390x, x86_64
Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.7) - ppc64le, s390x, x86_64
Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) - x86_64

3. Description:

PostgreSQL is an advanced object-relational database management system
(DBMS). 

The following packages have been upgraded to a later upstream version:
rh-postgresql12-postgresql (12.7).

Security Fix(es):

* postgresql: Buffer overrun from integer overflow in array subscripting
calculations (CVE-2021-32027)

* postgresql: Memory disclosure in INSERT ... ON CONFLICT ... DO UPDATE
(CVE-2021-32028)

* postgresql: Memory disclosure in partitioned-table UPDATE ... RETURNING
(CVE-2021-32029)

* postgresql: Partition constraint violation errors leak values of denied
columns (CVE-2021-3393)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

If the postgresql service is running, it will be automatically restarted
after installing this update.

5. Bugs fixed (https://bugzilla.redhat.com/):

1924005 - CVE-2021-3393 postgresql: Partition constraint violation errors leak values of denied columns
1956876 - CVE-2021-32027 postgresql: Buffer overrun from integer overflow in array subscripting calculations
1956877 - CVE-2021-32028 postgresql: Memory disclosure in INSERT ... ON CONFLICT ... DO UPDATE
1956883 - CVE-2021-32029 postgresql: Memory disclosure in partitioned-table UPDATE ... RETURNING

6. Package List:

Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7):

Source:
rh-postgresql12-postgresql-12.7-1.el7.src.rpm

ppc64le:
rh-postgresql12-postgresql-12.7-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-contrib-12.7-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-contrib-syspaths-12.7-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-debuginfo-12.7-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-devel-12.7-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-docs-12.7-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-libs-12.7-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-plperl-12.7-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-plpython-12.7-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-pltcl-12.7-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-server-12.7-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-server-syspaths-12.7-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-static-12.7-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-syspaths-12.7-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-test-12.7-1.el7.ppc64le.rpm

s390x:
rh-postgresql12-postgresql-12.7-1.el7.s390x.rpm
rh-postgresql12-postgresql-contrib-12.7-1.el7.s390x.rpm
rh-postgresql12-postgresql-contrib-syspaths-12.7-1.el7.s390x.rpm
rh-postgresql12-postgresql-debuginfo-12.7-1.el7.s390x.rpm
rh-postgresql12-postgresql-devel-12.7-1.el7.s390x.rpm
rh-postgresql12-postgresql-docs-12.7-1.el7.s390x.rpm
rh-postgresql12-postgresql-libs-12.7-1.el7.s390x.rpm
rh-postgresql12-postgresql-plperl-12.7-1.el7.s390x.rpm
rh-postgresql12-postgresql-plpython-12.7-1.el7.s390x.rpm
rh-postgresql12-postgresql-pltcl-12.7-1.el7.s390x.rpm
rh-postgresql12-postgresql-server-12.7-1.el7.s390x.rpm
rh-postgresql12-postgresql-server-syspaths-12.7-1.el7.s390x.rpm
rh-postgresql12-postgresql-static-12.7-1.el7.s390x.rpm
rh-postgresql12-postgresql-syspaths-12.7-1.el7.s390x.rpm
rh-postgresql12-postgresql-test-12.7-1.el7.s390x.rpm

x86_64:
rh-postgresql12-postgresql-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-contrib-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-contrib-syspaths-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-debuginfo-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-devel-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-docs-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-libs-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-plperl-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-plpython-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-pltcl-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-server-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-server-syspaths-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-static-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-syspaths-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-test-12.7-1.el7.x86_64.rpm

Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.7):

Source:
rh-postgresql12-postgresql-12.7-1.el7.src.rpm

ppc64le:
rh-postgresql12-postgresql-12.7-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-contrib-12.7-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-contrib-syspaths-12.7-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-debuginfo-12.7-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-devel-12.7-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-docs-12.7-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-libs-12.7-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-plperl-12.7-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-plpython-12.7-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-pltcl-12.7-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-server-12.7-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-server-syspaths-12.7-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-static-12.7-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-syspaths-12.7-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-test-12.7-1.el7.ppc64le.rpm

s390x:
rh-postgresql12-postgresql-12.7-1.el7.s390x.rpm
rh-postgresql12-postgresql-contrib-12.7-1.el7.s390x.rpm
rh-postgresql12-postgresql-contrib-syspaths-12.7-1.el7.s390x.rpm
rh-postgresql12-postgresql-debuginfo-12.7-1.el7.s390x.rpm
rh-postgresql12-postgresql-devel-12.7-1.el7.s390x.rpm
rh-postgresql12-postgresql-docs-12.7-1.el7.s390x.rpm
rh-postgresql12-postgresql-libs-12.7-1.el7.s390x.rpm
rh-postgresql12-postgresql-plperl-12.7-1.el7.s390x.rpm
rh-postgresql12-postgresql-plpython-12.7-1.el7.s390x.rpm
rh-postgresql12-postgresql-pltcl-12.7-1.el7.s390x.rpm
rh-postgresql12-postgresql-server-12.7-1.el7.s390x.rpm
rh-postgresql12-postgresql-server-syspaths-12.7-1.el7.s390x.rpm
rh-postgresql12-postgresql-static-12.7-1.el7.s390x.rpm
rh-postgresql12-postgresql-syspaths-12.7-1.el7.s390x.rpm
rh-postgresql12-postgresql-test-12.7-1.el7.s390x.rpm

x86_64:
rh-postgresql12-postgresql-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-contrib-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-contrib-syspaths-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-debuginfo-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-devel-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-docs-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-libs-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-plperl-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-plpython-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-pltcl-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-server-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-server-syspaths-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-static-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-syspaths-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-test-12.7-1.el7.x86_64.rpm

Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7):

Source:
rh-postgresql12-postgresql-12.7-1.el7.src.rpm

x86_64:
rh-postgresql12-postgresql-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-contrib-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-contrib-syspaths-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-debuginfo-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-devel-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-docs-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-libs-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-plperl-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-plpython-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-pltcl-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-server-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-server-syspaths-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-static-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-syspaths-12.7-1.el7.x86_64.rpm
rh-postgresql12-postgresql-test-12.7-1.el7.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2021-3393
https://access.redhat.com/security/cve/CVE-2021-32027
https://access.redhat.com/security/cve/CVE-2021-32028
https://access.redhat.com/security/cve/CVE-2021-32029
https://access.redhat.com/security/updates/classification/#important

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2021 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBYMce2tzjgjWX9erEAQhc0hAAoghTZw+E3vEWBoWFUqk0HMOwBbtVNac/
nJviFfeLH97nOIWxaUPnig+Rnw1/6h8QubZKzweKAy5fMUsNDPU5CGZSuWGmfDm1
cfXIsHYtxkXEU22cYLJOVkH+b4xt9j4mGfvLODm5sC+4Gruzl5MkYvv7OHTNHpu5
XMKkD0/9oK+Q5cJvfVHa1ygcdfSeB/hxdJkRevnCpaNiTFTLoUGYe20hAs4JQw2Q
sfMCRHP/CA6bbA552YZFRn7vDdjifRLlH7I5MPlAAJDAjMPoUiljpoI7jCWcD8B5
ZnVkzTvB2QW3YUgk8vbcAit+yNz0lTrZgGkSXdwZnXNUJ7BpwqDe/o3uzs/lZLsI
dcOjn3VlF2e4Q+fcmCVGoJrlOUM4JqiHxX9WWoAcgDOp/G83nIqyCw4iT0IJVvDL
TRkvenr081TCvnzbkZXhhmO/K6q/V0ozt6MtAHTp0/Rx3Ex/pmjR/SdxEOZcc350
u1qFsTyz6rOYO/SnZfotBe6vjxaMLd7VOMBSFBz0FWHrrW7gldPar3em4BgqBpJU
Fz/a5Ht4h1pnBNEnoVYRpQVfSYgINPaoTxqfXI5/X335ydmCYN4u9CPhQYzC25Pp
1FzXSD0oZR+hMjYsKUSy+qB+K8JjgYcfA3wtPB0eE/adXECldzU/9BG/ewjjLQEI
68mSyMaTIdA=
=U5YR
-----END PGP SIGNATURE-----

--
RHSA-announce mailing list
[email protected]
https://listman.redhat.com/mailman/listinfo/rhsa-announce

RedHat: RHSA-2021-2394:01 Important: rh-postgresql12-postgresql security

An update for rh-postgresql12-postgresql is now available for Red Hat Software Collections

Summary

PostgreSQL is an advanced object-relational database management system (DBMS).
The following packages have been upgraded to a later upstream version: rh-postgresql12-postgresql (12.7).
Security Fix(es):
* postgresql: Buffer overrun from integer overflow in array subscripting calculations (CVE-2021-32027)
* postgresql: Memory disclosure in INSERT ... ON CONFLICT ... DO UPDATE (CVE-2021-32028)
* postgresql: Memory disclosure in partitioned-table UPDATE ... RETURNING (CVE-2021-32029)
* postgresql: Partition constraint violation errors leak values of denied columns (CVE-2021-3393)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

Solution

For details on how to apply this update, which includes the changesdescribed in this advisory, refer to:https://access.redhat.com/articles/11258If the postgresql service is running, it will be automatically restartedafter installing this update.

References

https://access.redhat.com/security/cve/CVE-2021-3393 https://access.redhat.com/security/cve/CVE-2021-32027 https://access.redhat.com/security/cve/CVE-2021-32028 https://access.redhat.com/security/cve/CVE-2021-32029 https://access.redhat.com/security/updates/classification/#important

Package List

Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7):
Source: rh-postgresql12-postgresql-12.7-1.el7.src.rpm
ppc64le: rh-postgresql12-postgresql-12.7-1.el7.ppc64le.rpm rh-postgresql12-postgresql-contrib-12.7-1.el7.ppc64le.rpm rh-postgresql12-postgresql-contrib-syspaths-12.7-1.el7.ppc64le.rpm rh-postgresql12-postgresql-debuginfo-12.7-1.el7.ppc64le.rpm rh-postgresql12-postgresql-devel-12.7-1.el7.ppc64le.rpm rh-postgresql12-postgresql-docs-12.7-1.el7.ppc64le.rpm rh-postgresql12-postgresql-libs-12.7-1.el7.ppc64le.rpm rh-postgresql12-postgresql-plperl-12.7-1.el7.ppc64le.rpm rh-postgresql12-postgresql-plpython-12.7-1.el7.ppc64le.rpm rh-postgresql12-postgresql-pltcl-12.7-1.el7.ppc64le.rpm rh-postgresql12-postgresql-server-12.7-1.el7.ppc64le.rpm rh-postgresql12-postgresql-server-syspaths-12.7-1.el7.ppc64le.rpm rh-postgresql12-postgresql-static-12.7-1.el7.ppc64le.rpm rh-postgresql12-postgresql-syspaths-12.7-1.el7.ppc64le.rpm rh-postgresql12-postgresql-test-12.7-1.el7.ppc64le.rpm
s390x: rh-postgresql12-postgresql-12.7-1.el7.s390x.rpm rh-postgresql12-postgresql-contrib-12.7-1.el7.s390x.rpm rh-postgresql12-postgresql-contrib-syspaths-12.7-1.el7.s390x.rpm rh-postgresql12-postgresql-debuginfo-12.7-1.el7.s390x.rpm rh-postgresql12-postgresql-devel-12.7-1.el7.s390x.rpm rh-postgresql12-postgresql-docs-12.7-1.el7.s390x.rpm rh-postgresql12-postgresql-libs-12.7-1.el7.s390x.rpm rh-postgresql12-postgresql-plperl-12.7-1.el7.s390x.rpm rh-postgresql12-postgresql-plpython-12.7-1.el7.s390x.rpm rh-postgresql12-postgresql-pltcl-12.7-1.el7.s390x.rpm rh-postgresql12-postgresql-server-12.7-1.el7.s390x.rpm rh-postgresql12-postgresql-server-syspaths-12.7-1.el7.s390x.rpm rh-postgresql12-postgresql-static-12.7-1.el7.s390x.rpm rh-postgresql12-postgresql-syspaths-12.7-1.el7.s390x.rpm rh-postgresql12-postgresql-test-12.7-1.el7.s390x.rpm
x86_64: rh-postgresql12-postgresql-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-contrib-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-contrib-syspaths-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-debuginfo-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-devel-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-docs-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-libs-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-plperl-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-plpython-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-pltcl-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-server-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-server-syspaths-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-static-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-syspaths-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-test-12.7-1.el7.x86_64.rpm
Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.7):
Source: rh-postgresql12-postgresql-12.7-1.el7.src.rpm
ppc64le: rh-postgresql12-postgresql-12.7-1.el7.ppc64le.rpm rh-postgresql12-postgresql-contrib-12.7-1.el7.ppc64le.rpm rh-postgresql12-postgresql-contrib-syspaths-12.7-1.el7.ppc64le.rpm rh-postgresql12-postgresql-debuginfo-12.7-1.el7.ppc64le.rpm rh-postgresql12-postgresql-devel-12.7-1.el7.ppc64le.rpm rh-postgresql12-postgresql-docs-12.7-1.el7.ppc64le.rpm rh-postgresql12-postgresql-libs-12.7-1.el7.ppc64le.rpm rh-postgresql12-postgresql-plperl-12.7-1.el7.ppc64le.rpm rh-postgresql12-postgresql-plpython-12.7-1.el7.ppc64le.rpm rh-postgresql12-postgresql-pltcl-12.7-1.el7.ppc64le.rpm rh-postgresql12-postgresql-server-12.7-1.el7.ppc64le.rpm rh-postgresql12-postgresql-server-syspaths-12.7-1.el7.ppc64le.rpm rh-postgresql12-postgresql-static-12.7-1.el7.ppc64le.rpm rh-postgresql12-postgresql-syspaths-12.7-1.el7.ppc64le.rpm rh-postgresql12-postgresql-test-12.7-1.el7.ppc64le.rpm
s390x: rh-postgresql12-postgresql-12.7-1.el7.s390x.rpm rh-postgresql12-postgresql-contrib-12.7-1.el7.s390x.rpm rh-postgresql12-postgresql-contrib-syspaths-12.7-1.el7.s390x.rpm rh-postgresql12-postgresql-debuginfo-12.7-1.el7.s390x.rpm rh-postgresql12-postgresql-devel-12.7-1.el7.s390x.rpm rh-postgresql12-postgresql-docs-12.7-1.el7.s390x.rpm rh-postgresql12-postgresql-libs-12.7-1.el7.s390x.rpm rh-postgresql12-postgresql-plperl-12.7-1.el7.s390x.rpm rh-postgresql12-postgresql-plpython-12.7-1.el7.s390x.rpm rh-postgresql12-postgresql-pltcl-12.7-1.el7.s390x.rpm rh-postgresql12-postgresql-server-12.7-1.el7.s390x.rpm rh-postgresql12-postgresql-server-syspaths-12.7-1.el7.s390x.rpm rh-postgresql12-postgresql-static-12.7-1.el7.s390x.rpm rh-postgresql12-postgresql-syspaths-12.7-1.el7.s390x.rpm rh-postgresql12-postgresql-test-12.7-1.el7.s390x.rpm
x86_64: rh-postgresql12-postgresql-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-contrib-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-contrib-syspaths-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-debuginfo-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-devel-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-docs-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-libs-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-plperl-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-plpython-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-pltcl-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-server-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-server-syspaths-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-static-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-syspaths-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-test-12.7-1.el7.x86_64.rpm
Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7):
Source: rh-postgresql12-postgresql-12.7-1.el7.src.rpm
x86_64: rh-postgresql12-postgresql-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-contrib-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-contrib-syspaths-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-debuginfo-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-devel-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-docs-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-libs-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-plperl-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-plpython-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-pltcl-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-server-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-server-syspaths-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-static-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-syspaths-12.7-1.el7.x86_64.rpm rh-postgresql12-postgresql-test-12.7-1.el7.x86_64.rpm
These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from https://access.redhat.com/security/team/key/

Severity
Advisory ID: RHSA-2021:2394-01
Product: Red Hat Software Collections
Advisory URL: https://access.redhat.com/errata/RHSA-2021:2394
Issued Date: : 2021-06-14
CVE Names: CVE-2021-3393 CVE-2021-32027 CVE-2021-32028 CVE-2021-32029

Topic

An update for rh-postgresql12-postgresql is now available for Red HatSoftware Collections.Red Hat Product Security has rated this update as having a security impactof Important. A Common Vulnerability Scoring System (CVSS) base score,which gives a detailed severity rating, is available for each vulnerabilityfrom the CVE link(s) in the References section.

Relevant Releases Architectures

Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) - ppc64le, s390x, x86_64

Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.7) - ppc64le, s390x, x86_64

Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) - x86_64

Bugs Fixed

1924005 - CVE-2021-3393 postgresql: Partition constraint violation errors leak values of denied columns

1956876 - CVE-2021-32027 postgresql: Buffer overrun from integer overflow in array subscripting calculations

1956877 - CVE-2021-32028 postgresql: Memory disclosure in INSERT ... ON CONFLICT ... DO UPDATE

1956883 - CVE-2021-32029 postgresql: Memory disclosure in partitioned-table UPDATE ... RETURNING

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.