RedHat: RHSA-2021-3152:01 Important: exiv2 security update

Advisories

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Important: exiv2 security update
Advisory ID:       RHSA-2021:3152-01
Product:           Red Hat Enterprise Linux
Advisory URL:      https://access.redhat.com/errata/RHSA-2021:3152
Issue date:        2021-08-16
CVE Names:         CVE-2021-31291 
=====================================================================

1. Summary:

An update for exiv2 is now available for Red Hat Enterprise Linux 8.

Red Hat Product Security has rated this update as having a security impact
of Important. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available for each vulnerability
from the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat CodeReady Linux Builder (v. 8) - aarch64, noarch, ppc64le, s390x, x86_64
Red Hat Enterprise Linux AppStream (v. 8) - aarch64, ppc64le, s390x, x86_64

3. Description:

Exiv2 is a C++ library to access image metadata, supporting read and write
access to the Exif, IPTC and XMP metadata, Exif MakerNote support, extract
and delete methods for Exif thumbnails, classes to access Ifd, and support
for various image formats.

Security Fix(es):

* exiv2: Heap-based buffer overflow vulnerability in jp2image.cpp
(CVE-2021-31291)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

1990327 - CVE-2021-31291 exiv2: Heap-based buffer overflow vulnerability in jp2image.cpp

6. Package List:

Red Hat Enterprise Linux AppStream (v. 8):

Source:
exiv2-0.27.3-3.el8_4.src.rpm

aarch64:
exiv2-0.27.3-3.el8_4.aarch64.rpm
exiv2-debuginfo-0.27.3-3.el8_4.aarch64.rpm
exiv2-debugsource-0.27.3-3.el8_4.aarch64.rpm
exiv2-libs-0.27.3-3.el8_4.aarch64.rpm
exiv2-libs-debuginfo-0.27.3-3.el8_4.aarch64.rpm

ppc64le:
exiv2-0.27.3-3.el8_4.ppc64le.rpm
exiv2-debuginfo-0.27.3-3.el8_4.ppc64le.rpm
exiv2-debugsource-0.27.3-3.el8_4.ppc64le.rpm
exiv2-libs-0.27.3-3.el8_4.ppc64le.rpm
exiv2-libs-debuginfo-0.27.3-3.el8_4.ppc64le.rpm

s390x:
exiv2-0.27.3-3.el8_4.s390x.rpm
exiv2-debuginfo-0.27.3-3.el8_4.s390x.rpm
exiv2-debugsource-0.27.3-3.el8_4.s390x.rpm
exiv2-libs-0.27.3-3.el8_4.s390x.rpm
exiv2-libs-debuginfo-0.27.3-3.el8_4.s390x.rpm

x86_64:
exiv2-0.27.3-3.el8_4.x86_64.rpm
exiv2-debuginfo-0.27.3-3.el8_4.i686.rpm
exiv2-debuginfo-0.27.3-3.el8_4.x86_64.rpm
exiv2-debugsource-0.27.3-3.el8_4.i686.rpm
exiv2-debugsource-0.27.3-3.el8_4.x86_64.rpm
exiv2-libs-0.27.3-3.el8_4.i686.rpm
exiv2-libs-0.27.3-3.el8_4.x86_64.rpm
exiv2-libs-debuginfo-0.27.3-3.el8_4.i686.rpm
exiv2-libs-debuginfo-0.27.3-3.el8_4.x86_64.rpm

Red Hat CodeReady Linux Builder (v. 8):

aarch64:
exiv2-debuginfo-0.27.3-3.el8_4.aarch64.rpm
exiv2-debugsource-0.27.3-3.el8_4.aarch64.rpm
exiv2-devel-0.27.3-3.el8_4.aarch64.rpm
exiv2-libs-debuginfo-0.27.3-3.el8_4.aarch64.rpm

noarch:
exiv2-doc-0.27.3-3.el8_4.noarch.rpm

ppc64le:
exiv2-debuginfo-0.27.3-3.el8_4.ppc64le.rpm
exiv2-debugsource-0.27.3-3.el8_4.ppc64le.rpm
exiv2-devel-0.27.3-3.el8_4.ppc64le.rpm
exiv2-libs-debuginfo-0.27.3-3.el8_4.ppc64le.rpm

s390x:
exiv2-debuginfo-0.27.3-3.el8_4.s390x.rpm
exiv2-debugsource-0.27.3-3.el8_4.s390x.rpm
exiv2-devel-0.27.3-3.el8_4.s390x.rpm
exiv2-libs-debuginfo-0.27.3-3.el8_4.s390x.rpm

x86_64:
exiv2-debuginfo-0.27.3-3.el8_4.i686.rpm
exiv2-debuginfo-0.27.3-3.el8_4.x86_64.rpm
exiv2-debugsource-0.27.3-3.el8_4.i686.rpm
exiv2-debugsource-0.27.3-3.el8_4.x86_64.rpm
exiv2-devel-0.27.3-3.el8_4.i686.rpm
exiv2-devel-0.27.3-3.el8_4.x86_64.rpm
exiv2-libs-debuginfo-0.27.3-3.el8_4.i686.rpm
exiv2-libs-debuginfo-0.27.3-3.el8_4.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2021-31291
https://access.redhat.com/security/updates/classification/#important

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2021 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBYRo6NdzjgjWX9erEAQggJA//ck7uA5+LJZowxz/pxEM1G4GoGUVSkMgJ
9utZjsjwgmlMM7c4a0b2mNasSy7wbrWDyLmsPHfbOHEHRl995R6xfWAcdgHMM9Av
ANN6HEWf/MEmLcrorJCribuOUvMx5N2uE0iV6G/KNXB3cwD6qXOeJXUMIZVaHhOA
mQcs9XWcZhGq5rFhLhv4VP7p2HlZN39DF7L8LZ9RfnkN4PCIbvGBOkTRnnqxYZRz
KsRwzVPQ8G+IY7SRDS2j7Krcp+iyTGyN4EJKdrdAtCoCOOBTy2ab8DtC/fB7Oo6k
/f4S0Q07CTY5o23K+7MMvotFFMlwu+tGZVaJDW+tMLbcpJ1eAv2caFZVT1n16bfk
A3HsVreXNxX6iVkzxx0W35hf8WOmr6wtoW45Wp5oVf85eIKuaRjOxkDO7hThZCET
TIDG+mW96obKHXqVnKdP32KmwKwATKErPhEJaHj3FHV1m9FoZhZVwgwqvUTI5zxj
UkKVc2SFtdDzhphlwM8PhQ0w6biprkveHADfdUPt8zYj+ue1LHOX2kNfKGcSFawy
HPdjGyGI5V/L5XaJzn5hadP5SYHM8ESvtCAKeS10grMRUfh0Z70PMnqAN45D8iQ7
8STtMYGitCtOuI7LerrDkMWBuArP79HLOLGJdnBdfoQuFUAby0TdJ8ZbkyX0GFcH
kOak2fMdnHY=
=fdtK
-----END PGP SIGNATURE-----

--
RHSA-announce mailing list
[email protected]
https://listman.redhat.com/mailman/listinfo/rhsa-announce

RedHat: RHSA-2021-3152:01 Important: exiv2 security update

An update for exiv2 is now available for Red Hat Enterprise Linux 8

Summary

Exiv2 is a C++ library to access image metadata, supporting read and write access to the Exif, IPTC and XMP metadata, Exif MakerNote support, extract and delete methods for Exif thumbnails, classes to access Ifd, and support for various image formats.
Security Fix(es):
* exiv2: Heap-based buffer overflow vulnerability in jp2image.cpp (CVE-2021-31291)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

Solution

For details on how to apply this update, which includes the changesdescribed in this advisory, refer to:https://access.redhat.com/articles/11258

References

https://access.redhat.com/security/cve/CVE-2021-31291 https://access.redhat.com/security/updates/classification/#important

Package List

Red Hat Enterprise Linux AppStream (v. 8):
Source: exiv2-0.27.3-3.el8_4.src.rpm
aarch64: exiv2-0.27.3-3.el8_4.aarch64.rpm exiv2-debuginfo-0.27.3-3.el8_4.aarch64.rpm exiv2-debugsource-0.27.3-3.el8_4.aarch64.rpm exiv2-libs-0.27.3-3.el8_4.aarch64.rpm exiv2-libs-debuginfo-0.27.3-3.el8_4.aarch64.rpm
ppc64le: exiv2-0.27.3-3.el8_4.ppc64le.rpm exiv2-debuginfo-0.27.3-3.el8_4.ppc64le.rpm exiv2-debugsource-0.27.3-3.el8_4.ppc64le.rpm exiv2-libs-0.27.3-3.el8_4.ppc64le.rpm exiv2-libs-debuginfo-0.27.3-3.el8_4.ppc64le.rpm
s390x: exiv2-0.27.3-3.el8_4.s390x.rpm exiv2-debuginfo-0.27.3-3.el8_4.s390x.rpm exiv2-debugsource-0.27.3-3.el8_4.s390x.rpm exiv2-libs-0.27.3-3.el8_4.s390x.rpm exiv2-libs-debuginfo-0.27.3-3.el8_4.s390x.rpm
x86_64: exiv2-0.27.3-3.el8_4.x86_64.rpm exiv2-debuginfo-0.27.3-3.el8_4.i686.rpm exiv2-debuginfo-0.27.3-3.el8_4.x86_64.rpm exiv2-debugsource-0.27.3-3.el8_4.i686.rpm exiv2-debugsource-0.27.3-3.el8_4.x86_64.rpm exiv2-libs-0.27.3-3.el8_4.i686.rpm exiv2-libs-0.27.3-3.el8_4.x86_64.rpm exiv2-libs-debuginfo-0.27.3-3.el8_4.i686.rpm exiv2-libs-debuginfo-0.27.3-3.el8_4.x86_64.rpm
Red Hat CodeReady Linux Builder (v. 8):
aarch64: exiv2-debuginfo-0.27.3-3.el8_4.aarch64.rpm exiv2-debugsource-0.27.3-3.el8_4.aarch64.rpm exiv2-devel-0.27.3-3.el8_4.aarch64.rpm exiv2-libs-debuginfo-0.27.3-3.el8_4.aarch64.rpm
noarch: exiv2-doc-0.27.3-3.el8_4.noarch.rpm
ppc64le: exiv2-debuginfo-0.27.3-3.el8_4.ppc64le.rpm exiv2-debugsource-0.27.3-3.el8_4.ppc64le.rpm exiv2-devel-0.27.3-3.el8_4.ppc64le.rpm exiv2-libs-debuginfo-0.27.3-3.el8_4.ppc64le.rpm
s390x: exiv2-debuginfo-0.27.3-3.el8_4.s390x.rpm exiv2-debugsource-0.27.3-3.el8_4.s390x.rpm exiv2-devel-0.27.3-3.el8_4.s390x.rpm exiv2-libs-debuginfo-0.27.3-3.el8_4.s390x.rpm
x86_64: exiv2-debuginfo-0.27.3-3.el8_4.i686.rpm exiv2-debuginfo-0.27.3-3.el8_4.x86_64.rpm exiv2-debugsource-0.27.3-3.el8_4.i686.rpm exiv2-debugsource-0.27.3-3.el8_4.x86_64.rpm exiv2-devel-0.27.3-3.el8_4.i686.rpm exiv2-devel-0.27.3-3.el8_4.x86_64.rpm exiv2-libs-debuginfo-0.27.3-3.el8_4.i686.rpm exiv2-libs-debuginfo-0.27.3-3.el8_4.x86_64.rpm
These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from https://access.redhat.com/security/team/key/

Severity
Advisory ID: RHSA-2021:3152-01
Product: Red Hat Enterprise Linux
Advisory URL: https://access.redhat.com/errata/RHSA-2021:3152
Issued Date: : 2021-08-16
CVE Names: CVE-2021-31291

Topic

An update for exiv2 is now available for Red Hat Enterprise Linux 8.Red Hat Product Security has rated this update as having a security impactof Important. A Common Vulnerability Scoring System (CVSS) base score,which gives a detailed severity rating, is available for each vulnerabilityfrom the CVE link(s) in the References section.

Relevant Releases Architectures

Red Hat CodeReady Linux Builder (v. 8) - aarch64, noarch, ppc64le, s390x, x86_64

Red Hat Enterprise Linux AppStream (v. 8) - aarch64, ppc64le, s390x, x86_64

Bugs Fixed

1990327 - CVE-2021-31291 exiv2: Heap-based buffer overflow vulnerability in jp2image.cpp

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.