RedHat: RHSA-2023-0160:01 Moderate: rh-postgresql10-postgresql secu...
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Moderate: rh-postgresql10-postgresql security and bug fix update
Advisory ID:       RHSA-2023:0160-01
Product:           Red Hat Software Collections
Advisory URL:      https://access.redhat.com/errata/RHSA-2023:0160
Issue date:        2023-01-12
CVE Names:         CVE-2022-2625 
=====================================================================

1. Summary:

An update for rh-postgresql10-postgresql is now available for Red Hat
Software Collections.

Red Hat Product Security has rated this update as having a security impact
of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which
gives a detailed severity rating, is available for each vulnerability from
the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) - ppc64le, s390x, x86_64
Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) - x86_64

3. Description:

PostgreSQL is an advanced object-relational database management system
(DBMS).

The following packages have been upgraded to a later upstream version:
rh-postgresql10-postgresql (10.23).

Security Fix(es):

* postgresql: Extension scripts replace objects not belonging to the
extension. (CVE-2022-2625)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

Bug Fix(es):

* rh-postgresql10-postgresql: Update to the latest PostgreSQL version 10.23
(BZ#2157611)

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

If the postgresql service is running, it will be automatically restarted
after installing this update.

5. Bugs fixed (https://bugzilla.redhat.com/):

2113825 - CVE-2022-2625 postgresql: Extension scripts replace objects not belonging to the extension.
2157611 - rh-postgresql10-postgresql: Update to the latest PostgreSQL version 10.23 [rhscl-3.8.z]

6. Package List:

Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7):

Source:
rh-postgresql10-postgresql-10.23-1.el7.src.rpm

ppc64le:
rh-postgresql10-postgresql-10.23-1.el7.ppc64le.rpm
rh-postgresql10-postgresql-contrib-10.23-1.el7.ppc64le.rpm
rh-postgresql10-postgresql-contrib-syspaths-10.23-1.el7.ppc64le.rpm
rh-postgresql10-postgresql-debuginfo-10.23-1.el7.ppc64le.rpm
rh-postgresql10-postgresql-devel-10.23-1.el7.ppc64le.rpm
rh-postgresql10-postgresql-docs-10.23-1.el7.ppc64le.rpm
rh-postgresql10-postgresql-libs-10.23-1.el7.ppc64le.rpm
rh-postgresql10-postgresql-plperl-10.23-1.el7.ppc64le.rpm
rh-postgresql10-postgresql-plpython-10.23-1.el7.ppc64le.rpm
rh-postgresql10-postgresql-pltcl-10.23-1.el7.ppc64le.rpm
rh-postgresql10-postgresql-server-10.23-1.el7.ppc64le.rpm
rh-postgresql10-postgresql-server-syspaths-10.23-1.el7.ppc64le.rpm
rh-postgresql10-postgresql-static-10.23-1.el7.ppc64le.rpm
rh-postgresql10-postgresql-syspaths-10.23-1.el7.ppc64le.rpm
rh-postgresql10-postgresql-test-10.23-1.el7.ppc64le.rpm

s390x:
rh-postgresql10-postgresql-10.23-1.el7.s390x.rpm
rh-postgresql10-postgresql-contrib-10.23-1.el7.s390x.rpm
rh-postgresql10-postgresql-contrib-syspaths-10.23-1.el7.s390x.rpm
rh-postgresql10-postgresql-debuginfo-10.23-1.el7.s390x.rpm
rh-postgresql10-postgresql-devel-10.23-1.el7.s390x.rpm
rh-postgresql10-postgresql-docs-10.23-1.el7.s390x.rpm
rh-postgresql10-postgresql-libs-10.23-1.el7.s390x.rpm
rh-postgresql10-postgresql-plperl-10.23-1.el7.s390x.rpm
rh-postgresql10-postgresql-plpython-10.23-1.el7.s390x.rpm
rh-postgresql10-postgresql-pltcl-10.23-1.el7.s390x.rpm
rh-postgresql10-postgresql-server-10.23-1.el7.s390x.rpm
rh-postgresql10-postgresql-server-syspaths-10.23-1.el7.s390x.rpm
rh-postgresql10-postgresql-static-10.23-1.el7.s390x.rpm
rh-postgresql10-postgresql-syspaths-10.23-1.el7.s390x.rpm
rh-postgresql10-postgresql-test-10.23-1.el7.s390x.rpm

x86_64:
rh-postgresql10-postgresql-10.23-1.el7.x86_64.rpm
rh-postgresql10-postgresql-contrib-10.23-1.el7.x86_64.rpm
rh-postgresql10-postgresql-contrib-syspaths-10.23-1.el7.x86_64.rpm
rh-postgresql10-postgresql-debuginfo-10.23-1.el7.x86_64.rpm
rh-postgresql10-postgresql-devel-10.23-1.el7.x86_64.rpm
rh-postgresql10-postgresql-docs-10.23-1.el7.x86_64.rpm
rh-postgresql10-postgresql-libs-10.23-1.el7.x86_64.rpm
rh-postgresql10-postgresql-plperl-10.23-1.el7.x86_64.rpm
rh-postgresql10-postgresql-plpython-10.23-1.el7.x86_64.rpm
rh-postgresql10-postgresql-pltcl-10.23-1.el7.x86_64.rpm
rh-postgresql10-postgresql-server-10.23-1.el7.x86_64.rpm
rh-postgresql10-postgresql-server-syspaths-10.23-1.el7.x86_64.rpm
rh-postgresql10-postgresql-static-10.23-1.el7.x86_64.rpm
rh-postgresql10-postgresql-syspaths-10.23-1.el7.x86_64.rpm
rh-postgresql10-postgresql-test-10.23-1.el7.x86_64.rpm

Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7):

Source:
rh-postgresql10-postgresql-10.23-1.el7.src.rpm

x86_64:
rh-postgresql10-postgresql-10.23-1.el7.x86_64.rpm
rh-postgresql10-postgresql-contrib-10.23-1.el7.x86_64.rpm
rh-postgresql10-postgresql-contrib-syspaths-10.23-1.el7.x86_64.rpm
rh-postgresql10-postgresql-debuginfo-10.23-1.el7.x86_64.rpm
rh-postgresql10-postgresql-devel-10.23-1.el7.x86_64.rpm
rh-postgresql10-postgresql-docs-10.23-1.el7.x86_64.rpm
rh-postgresql10-postgresql-libs-10.23-1.el7.x86_64.rpm
rh-postgresql10-postgresql-plperl-10.23-1.el7.x86_64.rpm
rh-postgresql10-postgresql-plpython-10.23-1.el7.x86_64.rpm
rh-postgresql10-postgresql-pltcl-10.23-1.el7.x86_64.rpm
rh-postgresql10-postgresql-server-10.23-1.el7.x86_64.rpm
rh-postgresql10-postgresql-server-syspaths-10.23-1.el7.x86_64.rpm
rh-postgresql10-postgresql-static-10.23-1.el7.x86_64.rpm
rh-postgresql10-postgresql-syspaths-10.23-1.el7.x86_64.rpm
rh-postgresql10-postgresql-test-10.23-1.el7.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2022-2625
https://access.redhat.com/security/updates/classification/#moderate

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2023 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBY8A2kNzjgjWX9erEAQjivg/+KpxDuFgmrVStMcbCKvPW3o+DOdp+COkk
lD/fgU0+Q4YYeeOMm6DC9bd6hxV3SAozySBxEuvPR4Y6Mgz5XGIP+Z+10YVceK1s
UcGtaZKN6PsMVqqWWDpCz8JFio9hdOPI8Gw2SbnOtb1knBbGHW8zdt+3xp+vRdg8
168L57Ng3HIXo5bPObZFYa5M//Qxs5NpqVI5M4vJbwGhMAMRxTy4ttvuQX98dp7+
GosAZSKnZRSs3Kfgv91dDBxEdAXqIwutuTmgewpgOJl2uOuRSgdf6O4Iys3gcB9P
wUL3WyNnW3g056yf4qtrUHCYW8e9nryj8dv10spmSpbD/56t3gxeapTtMmUTxZoZ
S0itLTdhAeUsF3kwXtOehm5N3Kn57tQpbrgWjpfuri26P5ZUylO8XpnEZVXUV6/3
Hh5EZFTNWGgdFV2EGkUDJVkpBMlqxHrAgLKBFTJvpjJ6rGvAInJUbLa51oKQPyS2
DVW+RN29ASmUMz0tEf+zxpJ21NqkogD8G+RXxzadj9dxR7h3FoO2uEGxIQ/wpBNN
pvS6jHigVdTymnR2V7x4JEAxAgRkpLRKUHiCcBZw+epLiS+jUGWVRESWVq6JDpwi
yYuhaSo02TMjDUkF9HEOsAAwJRU2LWzoLAy1QrusolBZP+lDP/LhT6lDwhzoUPwl
BsDBF74jGFk=
=5LSM
-----END PGP SIGNATURE-----
--
RHSA-announce mailing list
[email protected]
https://listman.redhat.com/mailman/listinfo/rhsa-announce

RedHat: RHSA-2023-0160:01 Moderate: rh-postgresql10-postgresql security and

An update for rh-postgresql10-postgresql is now available for Red Hat Software Collections

Summary

PostgreSQL is an advanced object-relational database management system (DBMS).
The following packages have been upgraded to a later upstream version: rh-postgresql10-postgresql (10.23).
Security Fix(es):
* postgresql: Extension scripts replace objects not belonging to the extension. (CVE-2022-2625)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Bug Fix(es):
* rh-postgresql10-postgresql: Update to the latest PostgreSQL version 10.23 (BZ#2157611)

Solution

For details on how to apply this update, which includes the changesdescribed in this advisory, refer to:https://access.redhat.com/articles/11258If the postgresql service is running, it will be automatically restartedafter installing this update.

References

https://access.redhat.com/security/cve/CVE-2022-2625 https://access.redhat.com/security/updates/classification/#moderate

Package List

Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7):
Source: rh-postgresql10-postgresql-10.23-1.el7.src.rpm
ppc64le: rh-postgresql10-postgresql-10.23-1.el7.ppc64le.rpm rh-postgresql10-postgresql-contrib-10.23-1.el7.ppc64le.rpm rh-postgresql10-postgresql-contrib-syspaths-10.23-1.el7.ppc64le.rpm rh-postgresql10-postgresql-debuginfo-10.23-1.el7.ppc64le.rpm rh-postgresql10-postgresql-devel-10.23-1.el7.ppc64le.rpm rh-postgresql10-postgresql-docs-10.23-1.el7.ppc64le.rpm rh-postgresql10-postgresql-libs-10.23-1.el7.ppc64le.rpm rh-postgresql10-postgresql-plperl-10.23-1.el7.ppc64le.rpm rh-postgresql10-postgresql-plpython-10.23-1.el7.ppc64le.rpm rh-postgresql10-postgresql-pltcl-10.23-1.el7.ppc64le.rpm rh-postgresql10-postgresql-server-10.23-1.el7.ppc64le.rpm rh-postgresql10-postgresql-server-syspaths-10.23-1.el7.ppc64le.rpm rh-postgresql10-postgresql-static-10.23-1.el7.ppc64le.rpm rh-postgresql10-postgresql-syspaths-10.23-1.el7.ppc64le.rpm rh-postgresql10-postgresql-test-10.23-1.el7.ppc64le.rpm
s390x: rh-postgresql10-postgresql-10.23-1.el7.s390x.rpm rh-postgresql10-postgresql-contrib-10.23-1.el7.s390x.rpm rh-postgresql10-postgresql-contrib-syspaths-10.23-1.el7.s390x.rpm rh-postgresql10-postgresql-debuginfo-10.23-1.el7.s390x.rpm rh-postgresql10-postgresql-devel-10.23-1.el7.s390x.rpm rh-postgresql10-postgresql-docs-10.23-1.el7.s390x.rpm rh-postgresql10-postgresql-libs-10.23-1.el7.s390x.rpm rh-postgresql10-postgresql-plperl-10.23-1.el7.s390x.rpm rh-postgresql10-postgresql-plpython-10.23-1.el7.s390x.rpm rh-postgresql10-postgresql-pltcl-10.23-1.el7.s390x.rpm rh-postgresql10-postgresql-server-10.23-1.el7.s390x.rpm rh-postgresql10-postgresql-server-syspaths-10.23-1.el7.s390x.rpm rh-postgresql10-postgresql-static-10.23-1.el7.s390x.rpm rh-postgresql10-postgresql-syspaths-10.23-1.el7.s390x.rpm rh-postgresql10-postgresql-test-10.23-1.el7.s390x.rpm
x86_64: rh-postgresql10-postgresql-10.23-1.el7.x86_64.rpm rh-postgresql10-postgresql-contrib-10.23-1.el7.x86_64.rpm rh-postgresql10-postgresql-contrib-syspaths-10.23-1.el7.x86_64.rpm rh-postgresql10-postgresql-debuginfo-10.23-1.el7.x86_64.rpm rh-postgresql10-postgresql-devel-10.23-1.el7.x86_64.rpm rh-postgresql10-postgresql-docs-10.23-1.el7.x86_64.rpm rh-postgresql10-postgresql-libs-10.23-1.el7.x86_64.rpm rh-postgresql10-postgresql-plperl-10.23-1.el7.x86_64.rpm rh-postgresql10-postgresql-plpython-10.23-1.el7.x86_64.rpm rh-postgresql10-postgresql-pltcl-10.23-1.el7.x86_64.rpm rh-postgresql10-postgresql-server-10.23-1.el7.x86_64.rpm rh-postgresql10-postgresql-server-syspaths-10.23-1.el7.x86_64.rpm rh-postgresql10-postgresql-static-10.23-1.el7.x86_64.rpm rh-postgresql10-postgresql-syspaths-10.23-1.el7.x86_64.rpm rh-postgresql10-postgresql-test-10.23-1.el7.x86_64.rpm
Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7):
Source: rh-postgresql10-postgresql-10.23-1.el7.src.rpm
x86_64: rh-postgresql10-postgresql-10.23-1.el7.x86_64.rpm rh-postgresql10-postgresql-contrib-10.23-1.el7.x86_64.rpm rh-postgresql10-postgresql-contrib-syspaths-10.23-1.el7.x86_64.rpm rh-postgresql10-postgresql-debuginfo-10.23-1.el7.x86_64.rpm rh-postgresql10-postgresql-devel-10.23-1.el7.x86_64.rpm rh-postgresql10-postgresql-docs-10.23-1.el7.x86_64.rpm rh-postgresql10-postgresql-libs-10.23-1.el7.x86_64.rpm rh-postgresql10-postgresql-plperl-10.23-1.el7.x86_64.rpm rh-postgresql10-postgresql-plpython-10.23-1.el7.x86_64.rpm rh-postgresql10-postgresql-pltcl-10.23-1.el7.x86_64.rpm rh-postgresql10-postgresql-server-10.23-1.el7.x86_64.rpm rh-postgresql10-postgresql-server-syspaths-10.23-1.el7.x86_64.rpm rh-postgresql10-postgresql-static-10.23-1.el7.x86_64.rpm rh-postgresql10-postgresql-syspaths-10.23-1.el7.x86_64.rpm rh-postgresql10-postgresql-test-10.23-1.el7.x86_64.rpm
These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from https://access.redhat.com/security/team/key/

Severity
Advisory ID: RHSA-2023:0160-01
Product: Red Hat Software Collections
Advisory URL: https://access.redhat.com/errata/RHSA-2023:0160
Issued Date: : 2023-01-12
CVE Names: CVE-2022-2625

Topic

An update for rh-postgresql10-postgresql is now available for Red HatSoftware Collections.Red Hat Product Security has rated this update as having a security impactof Moderate. A Common Vulnerability Scoring System (CVSS) base score, whichgives a detailed severity rating, is available for each vulnerability fromthe CVE link(s) in the References section.

Relevant Releases Architectures

Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) - ppc64le, s390x, x86_64

Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) - x86_64

Bugs Fixed

2113825 - CVE-2022-2625 postgresql: Extension scripts replace objects not belonging to the extension.

2157611 - rh-postgresql10-postgresql: Update to the latest PostgreSQL version 10.23 [rhscl-3.8.z]

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.