RedHat: RHSA-2023-0128:01 Moderate: java-1.8.0-ibm security update ...
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Moderate: java-1.8.0-ibm security update
Advisory ID:       RHSA-2023:0128-01
Product:           Red Hat Enterprise Linux
Advisory URL:      https://access.redhat.com/errata/RHSA-2023:0128
Issue date:        2023-01-12
CVE Names:         CVE-2022-21619 CVE-2022-21624 CVE-2022-21626 
                   CVE-2022-21628 
=====================================================================

1. Summary:

An update for java-1.8.0-ibm is now available for Red Hat Enterprise Linux
8.

Red Hat Product Security has rated this update as having a security impact
of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which
gives a detailed severity rating, is available for each vulnerability from
the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux Supplementary (v. 8) - ppc64le, s390x, x86_64

3. Description:

IBM Java SE version 8 includes the IBM Java Runtime Environment and the IBM
Java Software Development Kit.

This update upgrades IBM Java SE 8 to version 8 SR7-FP20.

Security Fix(es):

* OpenJDK: excessive memory allocation in X.509 certificate parsing
(Security, 8286533) (CVE-2022-21626)

* OpenJDK: HttpServer no connection count limit (Lightweight HTTP Server,
8286918) (CVE-2022-21628)

* OpenJDK: improper handling of long NTLM client hostnames (Security,
8286526) (CVE-2022-21619)

* OpenJDK: insufficient randomization of JNDI DNS port numbers (JNDI,
8286910) (CVE-2022-21624)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

All running instances of IBM Java must be restarted for this update to take
effect.

5. Bugs fixed (https://bugzilla.redhat.com/):

2133745 - CVE-2022-21619 OpenJDK: improper handling of long NTLM client hostnames (Security, 8286526)
2133753 - CVE-2022-21626 OpenJDK: excessive memory allocation in X.509 certificate parsing (Security, 8286533)
2133765 - CVE-2022-21624 OpenJDK: insufficient randomization of JNDI DNS port numbers (JNDI, 8286910)
2133769 - CVE-2022-21628 OpenJDK: HttpServer no connection count limit (Lightweight HTTP Server, 8286918)

6. Package List:

Red Hat Enterprise Linux Supplementary (v. 8):

ppc64le:
java-1.8.0-ibm-1.8.0.7.20-1.el8_7.ppc64le.rpm
java-1.8.0-ibm-demo-1.8.0.7.20-1.el8_7.ppc64le.rpm
java-1.8.0-ibm-devel-1.8.0.7.20-1.el8_7.ppc64le.rpm
java-1.8.0-ibm-headless-1.8.0.7.20-1.el8_7.ppc64le.rpm
java-1.8.0-ibm-jdbc-1.8.0.7.20-1.el8_7.ppc64le.rpm
java-1.8.0-ibm-plugin-1.8.0.7.20-1.el8_7.ppc64le.rpm
java-1.8.0-ibm-src-1.8.0.7.20-1.el8_7.ppc64le.rpm
java-1.8.0-ibm-webstart-1.8.0.7.20-1.el8_7.ppc64le.rpm

s390x:
java-1.8.0-ibm-1.8.0.7.20-1.el8_7.s390x.rpm
java-1.8.0-ibm-demo-1.8.0.7.20-1.el8_7.s390x.rpm
java-1.8.0-ibm-devel-1.8.0.7.20-1.el8_7.s390x.rpm
java-1.8.0-ibm-headless-1.8.0.7.20-1.el8_7.s390x.rpm
java-1.8.0-ibm-jdbc-1.8.0.7.20-1.el8_7.s390x.rpm
java-1.8.0-ibm-src-1.8.0.7.20-1.el8_7.s390x.rpm

x86_64:
java-1.8.0-ibm-1.8.0.7.20-1.el8_7.x86_64.rpm
java-1.8.0-ibm-demo-1.8.0.7.20-1.el8_7.x86_64.rpm
java-1.8.0-ibm-devel-1.8.0.7.20-1.el8_7.x86_64.rpm
java-1.8.0-ibm-headless-1.8.0.7.20-1.el8_7.x86_64.rpm
java-1.8.0-ibm-jdbc-1.8.0.7.20-1.el8_7.x86_64.rpm
java-1.8.0-ibm-plugin-1.8.0.7.20-1.el8_7.x86_64.rpm
java-1.8.0-ibm-src-1.8.0.7.20-1.el8_7.x86_64.rpm
java-1.8.0-ibm-webstart-1.8.0.7.20-1.el8_7.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2022-21619
https://access.redhat.com/security/cve/CVE-2022-21624
https://access.redhat.com/security/cve/CVE-2022-21626
https://access.redhat.com/security/cve/CVE-2022-21628
https://access.redhat.com/security/updates/classification/#moderate

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2023 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBY7/i+tzjgjWX9erEAQgXZhAAnPO4wozg4xq9yVOJ3Ena/VncnYPboIzf
wV07vvXXaO4oYNyV0rTVYH6vM26ZMpG949nlcpXAtv3DKHyCpLXFS9qHmFseQ3nC
PEPHuBZaT5LEU/v/tyaj24UYR/t2RnaLeycHKfzWhPhs6YChB5XuhQwQkAtJT7uE
6VXj6JNSI58jLC1eFkQNoXs2W0k+TKw8ZmZUMcnCqmXTAyGUSlwxr2XGQTvPiKFY
yL3b5+hOeuXIVdgsk+wdCGE4kelsB05fUtpVTxvDyrSxtYdHYRsQ33VuDTMJU81R
Ib/KdMEBHX5T3PPuv0HZb3R82a97BBlKuYSTmaJzgBuP4JgynMe0JUU5eof4W2lG
fQU8a9Gfx7BRO+Tp3npDsFNPuMAWU7Q8G90dmpYKo5neebpxJBvBYiHRySrZxEd2
b6o7/DcT1Hc4jocrtrv6T4jYXerVM9f5f4JBGaE+NlBdWWw8B/ffeB81hBqgooKE
yPxg1PmWrh2tyD3EEVNEa801EKT0uyh8HJd60M4Tltej81G/eUAlUjQc2RypZlIl
j+uDjeBFVVHL8ESjhAgbCcL2LAhZa/VMRkh9wa5xGT8gCY3nJNhwOdtoUru6QbH4
zJWVBXI24tj5MfdK6BGWtywTOLlm3XwOt9eZsnMvC7e/WuRYLNcRjvBTUnjZTgBo
kEylWEHnWb4=
=sUX9
-----END PGP SIGNATURE-----
--
RHSA-announce mailing list
[email protected]
https://listman.redhat.com/mailman/listinfo/rhsa-announce

RedHat: RHSA-2023-0128:01 Moderate: java-1.8.0-ibm security update

An update for java-1.8.0-ibm is now available for Red Hat Enterprise Linux 8

Summary

IBM Java SE version 8 includes the IBM Java Runtime Environment and the IBM Java Software Development Kit.
This update upgrades IBM Java SE 8 to version 8 SR7-FP20.
Security Fix(es):
* OpenJDK: excessive memory allocation in X.509 certificate parsing (Security, 8286533) (CVE-2022-21626)
* OpenJDK: HttpServer no connection count limit (Lightweight HTTP Server, 8286918) (CVE-2022-21628)
* OpenJDK: improper handling of long NTLM client hostnames (Security, 8286526) (CVE-2022-21619)
* OpenJDK: insufficient randomization of JNDI DNS port numbers (JNDI, 8286910) (CVE-2022-21624)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

Solution

For details on how to apply this update, which includes the changesdescribed in this advisory, refer to:https://access.redhat.com/articles/11258All running instances of IBM Java must be restarted for this update to takeeffect.

References

https://access.redhat.com/security/cve/CVE-2022-21619 https://access.redhat.com/security/cve/CVE-2022-21624 https://access.redhat.com/security/cve/CVE-2022-21626 https://access.redhat.com/security/cve/CVE-2022-21628 https://access.redhat.com/security/updates/classification/#moderate

Package List

Red Hat Enterprise Linux Supplementary (v. 8):
ppc64le: java-1.8.0-ibm-1.8.0.7.20-1.el8_7.ppc64le.rpm java-1.8.0-ibm-demo-1.8.0.7.20-1.el8_7.ppc64le.rpm java-1.8.0-ibm-devel-1.8.0.7.20-1.el8_7.ppc64le.rpm java-1.8.0-ibm-headless-1.8.0.7.20-1.el8_7.ppc64le.rpm java-1.8.0-ibm-jdbc-1.8.0.7.20-1.el8_7.ppc64le.rpm java-1.8.0-ibm-plugin-1.8.0.7.20-1.el8_7.ppc64le.rpm java-1.8.0-ibm-src-1.8.0.7.20-1.el8_7.ppc64le.rpm java-1.8.0-ibm-webstart-1.8.0.7.20-1.el8_7.ppc64le.rpm
s390x: java-1.8.0-ibm-1.8.0.7.20-1.el8_7.s390x.rpm java-1.8.0-ibm-demo-1.8.0.7.20-1.el8_7.s390x.rpm java-1.8.0-ibm-devel-1.8.0.7.20-1.el8_7.s390x.rpm java-1.8.0-ibm-headless-1.8.0.7.20-1.el8_7.s390x.rpm java-1.8.0-ibm-jdbc-1.8.0.7.20-1.el8_7.s390x.rpm java-1.8.0-ibm-src-1.8.0.7.20-1.el8_7.s390x.rpm
x86_64: java-1.8.0-ibm-1.8.0.7.20-1.el8_7.x86_64.rpm java-1.8.0-ibm-demo-1.8.0.7.20-1.el8_7.x86_64.rpm java-1.8.0-ibm-devel-1.8.0.7.20-1.el8_7.x86_64.rpm java-1.8.0-ibm-headless-1.8.0.7.20-1.el8_7.x86_64.rpm java-1.8.0-ibm-jdbc-1.8.0.7.20-1.el8_7.x86_64.rpm java-1.8.0-ibm-plugin-1.8.0.7.20-1.el8_7.x86_64.rpm java-1.8.0-ibm-src-1.8.0.7.20-1.el8_7.x86_64.rpm java-1.8.0-ibm-webstart-1.8.0.7.20-1.el8_7.x86_64.rpm
These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from https://access.redhat.com/security/team/key/

Severity
Advisory ID: RHSA-2023:0128-01
Product: Red Hat Enterprise Linux
Advisory URL: https://access.redhat.com/errata/RHSA-2023:0128
Issued Date: : 2023-01-12
CVE Names: CVE-2022-21619 CVE-2022-21624 CVE-2022-21626 CVE-2022-21628

Topic

An update for java-1.8.0-ibm is now available for Red Hat Enterprise Linux8.Red Hat Product Security has rated this update as having a security impactof Moderate. A Common Vulnerability Scoring System (CVSS) base score, whichgives a detailed severity rating, is available for each vulnerability fromthe CVE link(s) in the References section.

Relevant Releases Architectures

Red Hat Enterprise Linux Supplementary (v. 8) - ppc64le, s390x, x86_64

Bugs Fixed

2133745 - CVE-2022-21619 OpenJDK: improper handling of long NTLM client hostnames (Security, 8286526)

2133753 - CVE-2022-21626 OpenJDK: excessive memory allocation in X.509 certificate parsing (Security, 8286533)

2133765 - CVE-2022-21624 OpenJDK: insufficient randomization of JNDI DNS port numbers (JNDI, 8286910)

2133769 - CVE-2022-21628 OpenJDK: HttpServer no connection count limit (Lightweight HTTP Server, 8286918)

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.