RedHat: RHSA-2023-0282:01 Important: sudo security update | LinuxSe...
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Important: sudo security update
Advisory ID:       RHSA-2023:0282-01
Product:           Red Hat Enterprise Linux
Advisory URL:      https://access.redhat.com/errata/RHSA-2023:0282
Issue date:        2023-01-23
CVE Names:         CVE-2023-22809 
=====================================================================

1. Summary:

An update for sudo is now available for Red Hat Enterprise Linux 9.

Red Hat Product Security has rated this update as having a security impact
of Important. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available for each vulnerability
from the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux AppStream (v. 9) - aarch64, ppc64le, s390x, x86_64
Red Hat Enterprise Linux BaseOS (v. 9) - aarch64, ppc64le, s390x, x86_64

3. Description:

The sudo packages contain the sudo utility which allows system
administrators to provide certain users with the permission to execute
privileged commands, which are used for system management purposes, without
having to log in as root.

Security Fix(es):

* sudo: arbitrary file write with privileges of the RunAs user
(CVE-2023-22809)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

2161142 - CVE-2023-22809 sudo: arbitrary file write with privileges of the RunAs user

6. Package List:

Red Hat Enterprise Linux AppStream (v. 9):

aarch64:
sudo-debuginfo-1.9.5p2-7.el9_1.1.aarch64.rpm
sudo-debugsource-1.9.5p2-7.el9_1.1.aarch64.rpm
sudo-python-plugin-1.9.5p2-7.el9_1.1.aarch64.rpm
sudo-python-plugin-debuginfo-1.9.5p2-7.el9_1.1.aarch64.rpm

ppc64le:
sudo-debuginfo-1.9.5p2-7.el9_1.1.ppc64le.rpm
sudo-debugsource-1.9.5p2-7.el9_1.1.ppc64le.rpm
sudo-python-plugin-1.9.5p2-7.el9_1.1.ppc64le.rpm
sudo-python-plugin-debuginfo-1.9.5p2-7.el9_1.1.ppc64le.rpm

s390x:
sudo-debuginfo-1.9.5p2-7.el9_1.1.s390x.rpm
sudo-debugsource-1.9.5p2-7.el9_1.1.s390x.rpm
sudo-python-plugin-1.9.5p2-7.el9_1.1.s390x.rpm
sudo-python-plugin-debuginfo-1.9.5p2-7.el9_1.1.s390x.rpm

x86_64:
sudo-debuginfo-1.9.5p2-7.el9_1.1.x86_64.rpm
sudo-debugsource-1.9.5p2-7.el9_1.1.x86_64.rpm
sudo-python-plugin-1.9.5p2-7.el9_1.1.x86_64.rpm
sudo-python-plugin-debuginfo-1.9.5p2-7.el9_1.1.x86_64.rpm

Red Hat Enterprise Linux BaseOS (v. 9):

Source:
sudo-1.9.5p2-7.el9_1.1.src.rpm

aarch64:
sudo-1.9.5p2-7.el9_1.1.aarch64.rpm
sudo-debuginfo-1.9.5p2-7.el9_1.1.aarch64.rpm
sudo-debugsource-1.9.5p2-7.el9_1.1.aarch64.rpm
sudo-python-plugin-debuginfo-1.9.5p2-7.el9_1.1.aarch64.rpm

ppc64le:
sudo-1.9.5p2-7.el9_1.1.ppc64le.rpm
sudo-debuginfo-1.9.5p2-7.el9_1.1.ppc64le.rpm
sudo-debugsource-1.9.5p2-7.el9_1.1.ppc64le.rpm
sudo-python-plugin-debuginfo-1.9.5p2-7.el9_1.1.ppc64le.rpm

s390x:
sudo-1.9.5p2-7.el9_1.1.s390x.rpm
sudo-debuginfo-1.9.5p2-7.el9_1.1.s390x.rpm
sudo-debugsource-1.9.5p2-7.el9_1.1.s390x.rpm
sudo-python-plugin-debuginfo-1.9.5p2-7.el9_1.1.s390x.rpm

x86_64:
sudo-1.9.5p2-7.el9_1.1.x86_64.rpm
sudo-debuginfo-1.9.5p2-7.el9_1.1.x86_64.rpm
sudo-debugsource-1.9.5p2-7.el9_1.1.x86_64.rpm
sudo-python-plugin-debuginfo-1.9.5p2-7.el9_1.1.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2023-22809
https://access.redhat.com/security/updates/classification/#important

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2023 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBY85iytzjgjWX9erEAQgSOA/9HsVG8QpHwWmZLGNDktHMFAtuYVfr7ZHY
DjULGU64gvHLtucB72tvb8tKBIlcANGrb+eMIceeAUd+3xSMbgqvwnW/ky0EXiIP
zIa4WWCIkmuNFM055mfmfodXwW/tuLvoDRrwXAXOB3Hitx6JRge91k2RgYI9tCm+
9lp1BJhl4q46XEXMLLKJA3HpJ73cjQIbU7foGPUhA11DZBAy5bY4nCe6dZk2veVL
Y++nvxkj6IHrjtqwMVxehkhdyNp5Ld4c/MXk+UeJXXWLFqAj7pJBLqEoJJOdJ8sU
ktEffGrTyEj/m0D7Q68nboLe4+r0Aloz6aJ6M1Qml2aUzGyXQkT21v0lae4FDSVx
xbiPCbINmZxVCqXvBzuTtqjiBnQ2S3Ac0EN9f2Sa7nFhNvejPkmsYPshM3aJbqdW
zRpTGtvMbSlihrXosX6VxCxZvsy4DmX46MQlftBa8aiwiaPtFcb2/ZR7J3+k+Ill
e/wOGWZmSv+nSCWjkP+IAMMPfr+TXJVO1WVBlYx83tMpn5vispVzW2DhyHhjXOxo
MbYHUUFw5LdvidWqheuJEyP+eDFLu7Uj9/3XsUqGWPnHU8I/ZVp4jWZe9pgmWWys
8kflMeQlWRPwFiHUarSesJt3Ddyt+wcc02feM0bzAd284wTdw4pQ5yG/7jLGoyyG
yj0AfEyrkJA=
=UQ99
-----END PGP SIGNATURE-----
--
RHSA-announce mailing list
[email protected]
https://listman.redhat.com/mailman/listinfo/rhsa-announce

RedHat: RHSA-2023-0282:01 Important: sudo security update

An update for sudo is now available for Red Hat Enterprise Linux 9

Summary

The sudo packages contain the sudo utility which allows system administrators to provide certain users with the permission to execute privileged commands, which are used for system management purposes, without having to log in as root.
Security Fix(es):
* sudo: arbitrary file write with privileges of the RunAs user (CVE-2023-22809)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

Solution

For details on how to apply this update, which includes the changesdescribed in this advisory, refer to:https://access.redhat.com/articles/11258

References

https://access.redhat.com/security/cve/CVE-2023-22809 https://access.redhat.com/security/updates/classification/#important

Package List

Red Hat Enterprise Linux AppStream (v. 9):
aarch64: sudo-debuginfo-1.9.5p2-7.el9_1.1.aarch64.rpm sudo-debugsource-1.9.5p2-7.el9_1.1.aarch64.rpm sudo-python-plugin-1.9.5p2-7.el9_1.1.aarch64.rpm sudo-python-plugin-debuginfo-1.9.5p2-7.el9_1.1.aarch64.rpm
ppc64le: sudo-debuginfo-1.9.5p2-7.el9_1.1.ppc64le.rpm sudo-debugsource-1.9.5p2-7.el9_1.1.ppc64le.rpm sudo-python-plugin-1.9.5p2-7.el9_1.1.ppc64le.rpm sudo-python-plugin-debuginfo-1.9.5p2-7.el9_1.1.ppc64le.rpm
s390x: sudo-debuginfo-1.9.5p2-7.el9_1.1.s390x.rpm sudo-debugsource-1.9.5p2-7.el9_1.1.s390x.rpm sudo-python-plugin-1.9.5p2-7.el9_1.1.s390x.rpm sudo-python-plugin-debuginfo-1.9.5p2-7.el9_1.1.s390x.rpm
x86_64: sudo-debuginfo-1.9.5p2-7.el9_1.1.x86_64.rpm sudo-debugsource-1.9.5p2-7.el9_1.1.x86_64.rpm sudo-python-plugin-1.9.5p2-7.el9_1.1.x86_64.rpm sudo-python-plugin-debuginfo-1.9.5p2-7.el9_1.1.x86_64.rpm
Red Hat Enterprise Linux BaseOS (v. 9):
Source: sudo-1.9.5p2-7.el9_1.1.src.rpm
aarch64: sudo-1.9.5p2-7.el9_1.1.aarch64.rpm sudo-debuginfo-1.9.5p2-7.el9_1.1.aarch64.rpm sudo-debugsource-1.9.5p2-7.el9_1.1.aarch64.rpm sudo-python-plugin-debuginfo-1.9.5p2-7.el9_1.1.aarch64.rpm
ppc64le: sudo-1.9.5p2-7.el9_1.1.ppc64le.rpm sudo-debuginfo-1.9.5p2-7.el9_1.1.ppc64le.rpm sudo-debugsource-1.9.5p2-7.el9_1.1.ppc64le.rpm sudo-python-plugin-debuginfo-1.9.5p2-7.el9_1.1.ppc64le.rpm
s390x: sudo-1.9.5p2-7.el9_1.1.s390x.rpm sudo-debuginfo-1.9.5p2-7.el9_1.1.s390x.rpm sudo-debugsource-1.9.5p2-7.el9_1.1.s390x.rpm sudo-python-plugin-debuginfo-1.9.5p2-7.el9_1.1.s390x.rpm
x86_64: sudo-1.9.5p2-7.el9_1.1.x86_64.rpm sudo-debuginfo-1.9.5p2-7.el9_1.1.x86_64.rpm sudo-debugsource-1.9.5p2-7.el9_1.1.x86_64.rpm sudo-python-plugin-debuginfo-1.9.5p2-7.el9_1.1.x86_64.rpm
These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from https://access.redhat.com/security/team/key/

Severity
Advisory ID: RHSA-2023:0282-01
Product: Red Hat Enterprise Linux
Advisory URL: https://access.redhat.com/errata/RHSA-2023:0282
Issued Date: : 2023-01-23
CVE Names: CVE-2023-22809

Topic

An update for sudo is now available for Red Hat Enterprise Linux 9.Red Hat Product Security has rated this update as having a security impactof Important. A Common Vulnerability Scoring System (CVSS) base score,which gives a detailed severity rating, is available for each vulnerabilityfrom the CVE link(s) in the References section.

Relevant Releases Architectures

Red Hat Enterprise Linux AppStream (v. 9) - aarch64, ppc64le, s390x, x86_64

Red Hat Enterprise Linux BaseOS (v. 9) - aarch64, ppc64le, s390x, x86_64

Bugs Fixed

2161142 - CVE-2023-22809 sudo: arbitrary file write with privileges of the RunAs user

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.