RedHat: RHSA-2023-0281:01 Important: sudo security update | LinuxSe...
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Important: sudo security update
Advisory ID:       RHSA-2023:0281-01
Product:           Red Hat Enterprise Linux
Advisory URL:      https://access.redhat.com/errata/RHSA-2023:0281
Issue date:        2023-01-23
CVE Names:         CVE-2023-22809 
=====================================================================

1. Summary:

An update for sudo is now available for Red Hat Enterprise Linux 9.0
Extended Update Support.

Red Hat Product Security has rated this update as having a security impact
of Important. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available for each vulnerability
from the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux AppStream EUS (v.9.0) - aarch64, ppc64le, s390x, x86_64
Red Hat Enterprise Linux BaseOS EUS (v.9.0) - aarch64, ppc64le, s390x, x86_64

3. Description:

The sudo packages contain the sudo utility which allows system
administrators to provide certain users with the permission to execute
privileged commands, which are used for system management purposes, without
having to log in as root.

Security Fix(es):

* sudo: arbitrary file write with privileges of the RunAs user
(CVE-2023-22809)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

2161142 - CVE-2023-22809 sudo: arbitrary file write with privileges of the RunAs user

6. Package List:

Red Hat Enterprise Linux AppStream EUS (v.9.0):

aarch64:
sudo-debuginfo-1.9.5p2-7.el9_0.2.aarch64.rpm
sudo-debugsource-1.9.5p2-7.el9_0.2.aarch64.rpm
sudo-python-plugin-1.9.5p2-7.el9_0.2.aarch64.rpm
sudo-python-plugin-debuginfo-1.9.5p2-7.el9_0.2.aarch64.rpm

ppc64le:
sudo-debuginfo-1.9.5p2-7.el9_0.2.ppc64le.rpm
sudo-debugsource-1.9.5p2-7.el9_0.2.ppc64le.rpm
sudo-python-plugin-1.9.5p2-7.el9_0.2.ppc64le.rpm
sudo-python-plugin-debuginfo-1.9.5p2-7.el9_0.2.ppc64le.rpm

s390x:
sudo-debuginfo-1.9.5p2-7.el9_0.2.s390x.rpm
sudo-debugsource-1.9.5p2-7.el9_0.2.s390x.rpm
sudo-python-plugin-1.9.5p2-7.el9_0.2.s390x.rpm
sudo-python-plugin-debuginfo-1.9.5p2-7.el9_0.2.s390x.rpm

x86_64:
sudo-debuginfo-1.9.5p2-7.el9_0.2.x86_64.rpm
sudo-debugsource-1.9.5p2-7.el9_0.2.x86_64.rpm
sudo-python-plugin-1.9.5p2-7.el9_0.2.x86_64.rpm
sudo-python-plugin-debuginfo-1.9.5p2-7.el9_0.2.x86_64.rpm

Red Hat Enterprise Linux BaseOS EUS (v.9.0):

Source:
sudo-1.9.5p2-7.el9_0.2.src.rpm

aarch64:
sudo-1.9.5p2-7.el9_0.2.aarch64.rpm
sudo-debuginfo-1.9.5p2-7.el9_0.2.aarch64.rpm
sudo-debugsource-1.9.5p2-7.el9_0.2.aarch64.rpm
sudo-python-plugin-debuginfo-1.9.5p2-7.el9_0.2.aarch64.rpm

ppc64le:
sudo-1.9.5p2-7.el9_0.2.ppc64le.rpm
sudo-debuginfo-1.9.5p2-7.el9_0.2.ppc64le.rpm
sudo-debugsource-1.9.5p2-7.el9_0.2.ppc64le.rpm
sudo-python-plugin-debuginfo-1.9.5p2-7.el9_0.2.ppc64le.rpm

s390x:
sudo-1.9.5p2-7.el9_0.2.s390x.rpm
sudo-debuginfo-1.9.5p2-7.el9_0.2.s390x.rpm
sudo-debugsource-1.9.5p2-7.el9_0.2.s390x.rpm
sudo-python-plugin-debuginfo-1.9.5p2-7.el9_0.2.s390x.rpm

x86_64:
sudo-1.9.5p2-7.el9_0.2.x86_64.rpm
sudo-debuginfo-1.9.5p2-7.el9_0.2.x86_64.rpm
sudo-debugsource-1.9.5p2-7.el9_0.2.x86_64.rpm
sudo-python-plugin-debuginfo-1.9.5p2-7.el9_0.2.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2023-22809
https://access.redhat.com/security/updates/classification/#important

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2023 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBY85i09zjgjWX9erEAQh8OBAAnxvinp6nO/DkV4wq44pVPt/HpiAe41Hp
F7YhOTGxdsSd7R5mqZv0lO866B2HFNa4Wr3SdBFv341lxmjmdV5/5KorD4NpYwkn
cWZoOw4Zb7Z2CHux/TeekEq7fYk3CUJz8i62K6qZ6nu9vRBAih2229Jcp3wt3/yS
j9uc8MCUmxSRJTJxnhglEL1boJQdD2nqqbRPdZhm825n591R2aFKQxfx+7klBscJ
nQOrpg5Q/JlOdrYedNJ0Dr3f2+9y2eSwfZMZEpEcBiGHrd8h0OCUIlALjvEswG4s
KDv08We7JjKw8/UK5OmrwsLh7nm8o+H5F4CGkmTk/CQTmH24mOtVMytj+nYAFjuY
vgxKQLjta1I9QEsUAvk9P/3hzoqCuEl1VEFRhUR6yvixLdElv9Rneqj6FinNED6t
CUWv4IybBTybgEd0szC9Z0Gl5f6wV6a1Wh76cI2meyTm9mP2fCFrHPrz4JIyHXXi
o28fT3ODs6fKmBBu0J2PLdm2dtNLstT6IvvE17bBNzvcm3V9yGUgDUfiGV4sB9+d
qR9xk8UA7KGYxsx5rCmyLQ/RexsXWDBP9Vr7fgT5EHxf/Mc1+OPpeiRNUfu5zw5+
0FxVQH0zBvG0i4AcVTrl+TKXRbkbOgbE2UJrMvUsLs+yRj3Jz1msiD0ZPir0j8d6
EzXzQQdCuAg=
=vWt9
-----END PGP SIGNATURE-----
--
RHSA-announce mailing list
[email protected]
https://listman.redhat.com/mailman/listinfo/rhsa-announce

RedHat: RHSA-2023-0281:01 Important: sudo security update

An update for sudo is now available for Red Hat Enterprise Linux 9.0 Extended Update Support

Summary

The sudo packages contain the sudo utility which allows system administrators to provide certain users with the permission to execute privileged commands, which are used for system management purposes, without having to log in as root.
Security Fix(es):
* sudo: arbitrary file write with privileges of the RunAs user (CVE-2023-22809)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

Solution

For details on how to apply this update, which includes the changesdescribed in this advisory, refer to:https://access.redhat.com/articles/11258

References

https://access.redhat.com/security/cve/CVE-2023-22809 https://access.redhat.com/security/updates/classification/#important

Package List

Red Hat Enterprise Linux AppStream EUS (v.9.0):
aarch64: sudo-debuginfo-1.9.5p2-7.el9_0.2.aarch64.rpm sudo-debugsource-1.9.5p2-7.el9_0.2.aarch64.rpm sudo-python-plugin-1.9.5p2-7.el9_0.2.aarch64.rpm sudo-python-plugin-debuginfo-1.9.5p2-7.el9_0.2.aarch64.rpm
ppc64le: sudo-debuginfo-1.9.5p2-7.el9_0.2.ppc64le.rpm sudo-debugsource-1.9.5p2-7.el9_0.2.ppc64le.rpm sudo-python-plugin-1.9.5p2-7.el9_0.2.ppc64le.rpm sudo-python-plugin-debuginfo-1.9.5p2-7.el9_0.2.ppc64le.rpm
s390x: sudo-debuginfo-1.9.5p2-7.el9_0.2.s390x.rpm sudo-debugsource-1.9.5p2-7.el9_0.2.s390x.rpm sudo-python-plugin-1.9.5p2-7.el9_0.2.s390x.rpm sudo-python-plugin-debuginfo-1.9.5p2-7.el9_0.2.s390x.rpm
x86_64: sudo-debuginfo-1.9.5p2-7.el9_0.2.x86_64.rpm sudo-debugsource-1.9.5p2-7.el9_0.2.x86_64.rpm sudo-python-plugin-1.9.5p2-7.el9_0.2.x86_64.rpm sudo-python-plugin-debuginfo-1.9.5p2-7.el9_0.2.x86_64.rpm
Red Hat Enterprise Linux BaseOS EUS (v.9.0):
Source: sudo-1.9.5p2-7.el9_0.2.src.rpm
aarch64: sudo-1.9.5p2-7.el9_0.2.aarch64.rpm sudo-debuginfo-1.9.5p2-7.el9_0.2.aarch64.rpm sudo-debugsource-1.9.5p2-7.el9_0.2.aarch64.rpm sudo-python-plugin-debuginfo-1.9.5p2-7.el9_0.2.aarch64.rpm
ppc64le: sudo-1.9.5p2-7.el9_0.2.ppc64le.rpm sudo-debuginfo-1.9.5p2-7.el9_0.2.ppc64le.rpm sudo-debugsource-1.9.5p2-7.el9_0.2.ppc64le.rpm sudo-python-plugin-debuginfo-1.9.5p2-7.el9_0.2.ppc64le.rpm
s390x: sudo-1.9.5p2-7.el9_0.2.s390x.rpm sudo-debuginfo-1.9.5p2-7.el9_0.2.s390x.rpm sudo-debugsource-1.9.5p2-7.el9_0.2.s390x.rpm sudo-python-plugin-debuginfo-1.9.5p2-7.el9_0.2.s390x.rpm
x86_64: sudo-1.9.5p2-7.el9_0.2.x86_64.rpm sudo-debuginfo-1.9.5p2-7.el9_0.2.x86_64.rpm sudo-debugsource-1.9.5p2-7.el9_0.2.x86_64.rpm sudo-python-plugin-debuginfo-1.9.5p2-7.el9_0.2.x86_64.rpm
These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from https://access.redhat.com/security/team/key/

Severity
Advisory ID: RHSA-2023:0281-01
Product: Red Hat Enterprise Linux
Advisory URL: https://access.redhat.com/errata/RHSA-2023:0281
Issued Date: : 2023-01-23
CVE Names: CVE-2023-22809

Topic

An update for sudo is now available for Red Hat Enterprise Linux 9.0Extended Update Support.Red Hat Product Security has rated this update as having a security impactof Important. A Common Vulnerability Scoring System (CVSS) base score,which gives a detailed severity rating, is available for each vulnerabilityfrom the CVE link(s) in the References section.

Relevant Releases Architectures

Red Hat Enterprise Linux AppStream EUS (v.9.0) - aarch64, ppc64le, s390x, x86_64

Red Hat Enterprise Linux BaseOS EUS (v.9.0) - aarch64, ppc64le, s390x, x86_64

Bugs Fixed

2161142 - CVE-2023-22809 sudo: arbitrary file write with privileges of the RunAs user

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.