Discover Government News

{"type":"TYPE_ENHANCEMENT","shortCode":"RL","name":"RLEA-2024:0890","synopsis":"nodejs:18 bug fix and enhancement update","severity":"SEVERITY_UNKNOWN","topic":"An update is available for nodejs-nodemon, module.nodejs, nodejs, module.nodejs-nodemon, module.nodejs-packaging, nodejs-packaging.\nThis update affects Rocky Linux 8.\nA Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE list","description":"Node.js is a software development platform for building fast and scalable\nnetwork applications in the JavaScript programming language.\n\nBug Fix(es) and Enhancement(s):\n\n* nodejs:18\/nodejs: Rebase to latest upstream version (JIRA:Rocky Linux-21439)","solution":null,"affectedProducts":["Rocky Linux 8"],"fixes":[],"cves":[],"references":[],"publishedAt":"2024-03-12T15:42:26.241001Z","rpms":{"Rocky Linux 8":{"nvras":["nodejs-1:18.19.0-1.module+el8.9.0+1727+17e65eb5.aarch64.rpm","nodejs-1:18.19.0-1.module+el8.9.0+1727+17e65eb5.src.rpm","nodejs-debuginfo-1:18.19.0-1.module+el8.9.0+1727+17e65eb5.aarch64.rpm","nodejs-debugsource-1:18.19.0-1.module+el8.9.0+1727+17e65eb5.aarch64.rpm","nodejs-devel-1:18.19.0-1.module+el8.9.0+1727+17e65eb5.aarch64.rpm","nodejs-docs-1:18.19.0-1.module+el8.9.0+1727+17e65eb5.noarch.rpm","nodejs-full-i18n-1:18.19.0-1.module+el8.9.0+1727+17e65eb5.aarch64.rpm","nodejs-nodemon-0:3.0.1-1.module+el8.8.0+1459+02651ab6.noarch.rpm","nodejs-nodemon-0:3.0.1-1.module+el8.8.0+1459+02651ab6.src.rpm","nodejs-packaging-0:2021.06-4.module+el8.7.0+1072+5b168780.noarch.rpm","nodejs-packaging-0:2021.06-4.module+el8.7.0+1072+5b168780.src.rpm","nodejs-packaging-bundler-0:2021.06-4.module+el8.7.0+1072+5b168780.noarch.rpm","npm-1:10.2.3-1.18.19.0.1.module+el8.9.0+1727+17e65eb5.aarch64.rpm"]}},"rebootSuggested":false,"buildReferences":[]}

Rocky Linux: RLEA-2024:0890 18 bug fix and enhancement update

March 12, 2024
An update is available for nodejs-nodemon, module.nodejs, nodejs, module.nodejs-nodemon, module.nodejs-packaging, nodejs-packaging. This update affects Rocky Linux 8. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE list

Summary

An update is available for nodejs-nodemon, module.nodejs, nodejs, module.nodejs-nodemon, module.nodejs-packaging, nodejs-packaging. This update affects Rocky Linux 8. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE list


Node.js is a software development platform for building fast and scalable network applications in the JavaScript programming language. Bug Fix(es) and Enhancement(s): * nodejs:18/nodejs: Rebase to latest upstream version (JIRA:Rocky Linux-21439)

RPMs

nodejs-1:18.19.0-1.module+el8.9.0+1727+17e65eb5.aarch64.rpm

nodejs-1:18.19.0-1.module+el8.9.0+1727+17e65eb5.src.rpm

nodejs-debuginfo-1:18.19.0-1.module+el8.9.0+1727+17e65eb5.aarch64.rpm

nodejs-debugsource-1:18.19.0-1.module+el8.9.0+1727+17e65eb5.aarch64.rpm

nodejs-devel-1:18.19.0-1.module+el8.9.0+1727+17e65eb5.aarch64.rpm

nodejs-docs-1:18.19.0-1.module+el8.9.0+1727+17e65eb5.noarch.rpm

nodejs-full-i18n-1:18.19.0-1.module+el8.9.0+1727+17e65eb5.aarch64.rpm

nodejs-nodemon-0:3.0.1-1.module+el8.8.0+1459+02651ab6.noarch.rpm

nodejs-nodemon-0:3.0.1-1.module+el8.8.0+1459+02651ab6.src.rpm

nodejs-packaging-0:2021.06-4.module+el8.7.0+1072+5b168780.noarch.rpm

nodejs-packaging-0:2021.06-4.module+el8.7.0+1072+5b168780.src.rpm

nodejs-packaging-bundler-0:2021.06-4.module+el8.7.0+1072+5b168780.noarch.rpm

npm-1:10.2.3-1.18.19.0.1.module+el8.9.0+1727+17e65eb5.aarch64.rpm

References

No References

CVEs

Severity
Name: RLEA-2024:0890
Affected Products: Rocky Linux 8

Fixes


Related News