Rocky Linux: RLSA-2023:3109 apr-util security update | LinuxSecuri...
{"type":"TYPE_SECURITY","shortCode":"RL","name":"RLSA-2023:3109","synopsis":"Important: apr-util security update","severity":"SEVERITY_IMPORTANT","topic":"An update is available for apr-util.\nThis update affects Rocky Linux 8.\nA Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE list","description":"The Apache Portable Runtime (APR) is a portability library used by the\nApache HTTP Server and other projects. apr-util is a library which provides\nadditional utility interfaces for APR; including support for XML parsing,\nLDAP, database interfaces, URI parsing, and more.\n\nSecurity Fix(es):\n\n* apr-util: out-of-bounds writes in the apr_base64 (CVE-2022-25147)\n\nFor more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.","solution":null,"affectedProducts":["Rocky Linux 8"],"fixes":[{"ticket":"2169652","sourceBy":"Red Hat","sourceLink":"https:\/\/bugzilla.redhat.com\/show_bug.cgi?id=2169652","description":""}],"cves":[{"name":"CVE-2022-25147","sourceBy":"MITRE","sourceLink":"https:\/\/cve.mitre.org\/cgi-bin\/cvename.cgi?name=CVE-2022-25147","cvss3ScoringVector":"UNKNOWN","cvss3BaseScore":"UNKNOWN","cwe":"UNKNOWN"}],"references":[],"publishedAt":"2023-05-17T01:10:15.797595Z","rpms":{"Rocky Linux 8":{"nvras":["apr-util-0:1.6.1-6.el8.1.aarch64.rpm","apr-util-0:1.6.1-6.el8.1.i686.rpm","apr-util-0:1.6.1-6.el8.1.src.rpm","apr-util-0:1.6.1-6.el8.1.x86_64.rpm","apr-util-bdb-0:1.6.1-6.el8.1.aarch64.rpm","apr-util-bdb-0:1.6.1-6.el8.1.i686.rpm","apr-util-bdb-0:1.6.1-6.el8.1.x86_64.rpm","apr-util-bdb-debuginfo-0:1.6.1-6.el8.1.aarch64.rpm","apr-util-bdb-debuginfo-0:1.6.1-6.el8.1.i686.rpm","apr-util-bdb-debuginfo-0:1.6.1-6.el8.1.x86_64.rpm","apr-util-debuginfo-0:1.6.1-6.el8.1.aarch64.rpm","apr-util-debuginfo-0:1.6.1-6.el8.1.i686.rpm","apr-util-debuginfo-0:1.6.1-6.el8.1.x86_64.rpm","apr-util-debugsource-0:1.6.1-6.el8.1.aarch64.rpm","apr-util-debugsource-0:1.6.1-6.el8.1.i686.rpm","apr-util-debugsource-0:1.6.1-6.el8.1.x86_64.rpm","apr-util-devel-0:1.6.1-6.el8.1.aarch64.rpm","apr-util-devel-0:1.6.1-6.el8.1.i686.rpm","apr-util-devel-0:1.6.1-6.el8.1.x86_64.rpm","apr-util-ldap-0:1.6.1-6.el8.1.aarch64.rpm","apr-util-ldap-0:1.6.1-6.el8.1.x86_64.rpm","apr-util-ldap-debuginfo-0:1.6.1-6.el8.1.aarch64.rpm","apr-util-ldap-debuginfo-0:1.6.1-6.el8.1.x86_64.rpm","apr-util-mysql-0:1.6.1-6.el8.1.aarch64.rpm","apr-util-mysql-0:1.6.1-6.el8.1.x86_64.rpm","apr-util-mysql-debuginfo-0:1.6.1-6.el8.1.aarch64.rpm","apr-util-mysql-debuginfo-0:1.6.1-6.el8.1.x86_64.rpm","apr-util-odbc-0:1.6.1-6.el8.1.aarch64.rpm","apr-util-odbc-0:1.6.1-6.el8.1.x86_64.rpm","apr-util-odbc-debuginfo-0:1.6.1-6.el8.1.aarch64.rpm","apr-util-odbc-debuginfo-0:1.6.1-6.el8.1.x86_64.rpm","apr-util-openssl-0:1.6.1-6.el8.1.aarch64.rpm","apr-util-openssl-0:1.6.1-6.el8.1.i686.rpm","apr-util-openssl-0:1.6.1-6.el8.1.x86_64.rpm","apr-util-openssl-debuginfo-0:1.6.1-6.el8.1.aarch64.rpm","apr-util-openssl-debuginfo-0:1.6.1-6.el8.1.i686.rpm","apr-util-openssl-debuginfo-0:1.6.1-6.el8.1.x86_64.rpm","apr-util-pgsql-0:1.6.1-6.el8.1.aarch64.rpm","apr-util-pgsql-0:1.6.1-6.el8.1.x86_64.rpm","apr-util-pgsql-debuginfo-0:1.6.1-6.el8.1.aarch64.rpm","apr-util-pgsql-debuginfo-0:1.6.1-6.el8.1.x86_64.rpm","apr-util-sqlite-0:1.6.1-6.el8.1.aarch64.rpm","apr-util-sqlite-0:1.6.1-6.el8.1.x86_64.rpm","apr-util-sqlite-debuginfo-0:1.6.1-6.el8.1.aarch64.rpm","apr-util-sqlite-debuginfo-0:1.6.1-6.el8.1.x86_64.rpm"]}},"rebootSuggested":false,"buildReferences":[]}

Rocky Linux: RLSA-2023:3109 apr-util security update

May 17, 2023
An update is available for apr-util. This update affects Rocky Linux 8. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE list

Summary

An update is available for apr-util. This update affects Rocky Linux 8. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE list


The Apache Portable Runtime (APR) is a portability library used by the Apache HTTP Server and other projects. apr-util is a library which provides additional utility interfaces for APR; including support for XML parsing, LDAP, database interfaces, URI parsing, and more. Security Fix(es): * apr-util: out-of-bounds writes in the apr_base64 (CVE-2022-25147) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

RPMs

apr-util-0:1.6.1-6.el8.1.aarch64.rpm

apr-util-0:1.6.1-6.el8.1.i686.rpm

apr-util-0:1.6.1-6.el8.1.src.rpm

apr-util-0:1.6.1-6.el8.1.x86_64.rpm

apr-util-bdb-0:1.6.1-6.el8.1.aarch64.rpm

apr-util-bdb-0:1.6.1-6.el8.1.i686.rpm

apr-util-bdb-0:1.6.1-6.el8.1.x86_64.rpm

apr-util-bdb-debuginfo-0:1.6.1-6.el8.1.aarch64.rpm

apr-util-bdb-debuginfo-0:1.6.1-6.el8.1.i686.rpm

apr-util-bdb-debuginfo-0:1.6.1-6.el8.1.x86_64.rpm

apr-util-debuginfo-0:1.6.1-6.el8.1.aarch64.rpm

apr-util-debuginfo-0:1.6.1-6.el8.1.i686.rpm

apr-util-debuginfo-0:1.6.1-6.el8.1.x86_64.rpm

apr-util-debugsource-0:1.6.1-6.el8.1.aarch64.rpm

apr-util-debugsource-0:1.6.1-6.el8.1.i686.rpm

apr-util-debugsource-0:1.6.1-6.el8.1.x86_64.rpm

apr-util-devel-0:1.6.1-6.el8.1.aarch64.rpm

apr-util-devel-0:1.6.1-6.el8.1.i686.rpm

apr-util-devel-0:1.6.1-6.el8.1.x86_64.rpm

apr-util-ldap-0:1.6.1-6.el8.1.aarch64.rpm

apr-util-ldap-0:1.6.1-6.el8.1.x86_64.rpm

apr-util-ldap-debuginfo-0:1.6.1-6.el8.1.aarch64.rpm

apr-util-ldap-debuginfo-0:1.6.1-6.el8.1.x86_64.rpm

apr-util-mysql-0:1.6.1-6.el8.1.aarch64.rpm

apr-util-mysql-0:1.6.1-6.el8.1.x86_64.rpm

apr-util-mysql-debuginfo-0:1.6.1-6.el8.1.aarch64.rpm

apr-util-mysql-debuginfo-0:1.6.1-6.el8.1.x86_64.rpm

apr-util-odbc-0:1.6.1-6.el8.1.aarch64.rpm

apr-util-odbc-0:1.6.1-6.el8.1.x86_64.rpm

apr-util-odbc-debuginfo-0:1.6.1-6.el8.1.aarch64.rpm

apr-util-odbc-debuginfo-0:1.6.1-6.el8.1.x86_64.rpm

apr-util-openssl-0:1.6.1-6.el8.1.aarch64.rpm

apr-util-openssl-0:1.6.1-6.el8.1.i686.rpm

apr-util-openssl-0:1.6.1-6.el8.1.x86_64.rpm

apr-util-openssl-debuginfo-0:1.6.1-6.el8.1.aarch64.rpm

apr-util-openssl-debuginfo-0:1.6.1-6.el8.1.i686.rpm

apr-util-openssl-debuginfo-0:1.6.1-6.el8.1.x86_64.rpm

apr-util-pgsql-0:1.6.1-6.el8.1.aarch64.rpm

apr-util-pgsql-0:1.6.1-6.el8.1.x86_64.rpm

apr-util-pgsql-debuginfo-0:1.6.1-6.el8.1.aarch64.rpm

apr-util-pgsql-debuginfo-0:1.6.1-6.el8.1.x86_64.rpm

apr-util-sqlite-0:1.6.1-6.el8.1.aarch64.rpm

apr-util-sqlite-0:1.6.1-6.el8.1.x86_64.rpm

apr-util-sqlite-debuginfo-0:1.6.1-6.el8.1.aarch64.rpm

apr-util-sqlite-debuginfo-0:1.6.1-6.el8.1.x86_64.rpm

References

No References

CVEs

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-25147

Severity
Name: RLSA-2023:3109
Affected Products: Rocky Linux 8

Fixes

https://bugzilla.redhat.com/show_bug.cgi?id=2169652


We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.