{"type":"TYPE_SECURITY","shortCode":"RL","name":"RLSA-2024:3671","synopsis":"Moderate: ruby:3.3 security, bug fix, and enhancement update","severity":"SEVERITY_MODERATE","topic":"An update is available for rubygem-mysql2, module.rubygem-pg, ruby, module.rubygem-mysql2, rubygem-pg, module.ruby.\nThis update affects Rocky Linux 9.\nA Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE list","description":"Ruby is an extensible, interpreted, object-oriented, scripting language. It has features to process text files and to perform system management tasks.\n\nThe following packages have been upgraded to a later upstream version: ruby (3.3). (Rocky Linux-37697)\n\nSecurity Fix(es):\n\n* ruby: Buffer overread vulnerability in StringIO (CVE-2024-27280)\n\n* ruby: RCE vulnerability with .rdoc_options in RDoc (CVE-2024-27281)\n\n* ruby: Arbitrary memory address read vulnerability with Regex search (CVE-2024-27282)\n\nFor more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.","solution":null,"affectedProducts":["Rocky Linux 9"],"fixes":[{"ticket":"2270749","sourceBy":"Red Hat","sourceLink":"https:\/\/bugzilla.redhat.com\/show_bug.cgi?id=2270749","description":""},{"ticket":"2270750","sourceBy":"Red Hat","sourceLink":"https:\/\/bugzilla.redhat.com\/show_bug.cgi?id=2270750","description":""},{"ticket":"2276810","sourceBy":"Red Hat","sourceLink":"https:\/\/bugzilla.redhat.com\/show_bug.cgi?id=2276810","description":""}],"cves":[{"name":"CVE-2024-27280","sourceBy":"MITRE","sourceLink":"https:\/\/cve.mitre.org\/cgi-bin\/cvename.cgi?name=CVE-2024-27280","cvss3ScoringVector":"UNKNOWN","cvss3BaseScore":"UNKNOWN","cwe":"UNKNOWN"},{"name":"CVE-2024-27281","sourceBy":"MITRE","sourceLink":"https:\/\/cve.mitre.org\/cgi-bin\/cvename.cgi?name=CVE-2024-27281","cvss3ScoringVector":"UNKNOWN","cvss3BaseScore":"UNKNOWN","cwe":"UNKNOWN"},{"name":"CVE-2024-27282","sourceBy":"MITRE","sourceLink":"https:\/\/cve.mitre.org\/cgi-bin\/cvename.cgi?name=CVE-2024-27282","cvss3ScoringVector":"UNKNOWN","cvss3BaseScore":"UNKNOWN","cwe":"UNKNOWN"}],"references":[],"publishedAt":"2024-06-14T14:00:40.182624Z","rpms":{"Rocky Linux 9":{"nvras":["ruby-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm","ruby-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm","ruby-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.s390x.rpm","ruby-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.src.rpm","ruby-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm","ruby-bundled-gems-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm","ruby-bundled-gems-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm","ruby-bundled-gems-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.s390x.rpm","ruby-bundled-gems-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm","ruby-bundled-gems-debuginfo-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm","ruby-bundled-gems-debuginfo-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm","ruby-bundled-gems-debuginfo-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.s390x.rpm","ruby-bundled-gems-debuginfo-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm","ruby-debuginfo-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm","ruby-debuginfo-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm","ruby-debuginfo-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.s390x.rpm","ruby-debuginfo-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm","ruby-debugsource-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm","ruby-debugsource-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm","ruby-debugsource-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.s390x.rpm","ruby-debugsource-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm","ruby-default-gems-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.noarch.rpm","ruby-devel-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm","ruby-devel-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm","ruby-devel-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.s390x.rpm","ruby-devel-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm","ruby-doc-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.noarch.rpm","rubygem-bigdecimal-0:3.1.5-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm","rubygem-bigdecimal-0:3.1.5-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm","rubygem-bigdecimal-0:3.1.5-2.module+el9.4.0+20787+4c237fd3.s390x.rpm","rubygem-bigdecimal-0:3.1.5-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm","rubygem-bigdecimal-debuginfo-0:3.1.5-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm","rubygem-bigdecimal-debuginfo-0:3.1.5-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm","rubygem-bigdecimal-debuginfo-0:3.1.5-2.module+el9.4.0+20787+4c237fd3.s390x.rpm","rubygem-bigdecimal-debuginfo-0:3.1.5-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm","rubygem-bundler-0:2.5.9-2.module+el9.4.0+20787+4c237fd3.noarch.rpm","rubygem-io-console-0:0.7.1-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm","rubygem-io-console-0:0.7.1-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm","rubygem-io-console-0:0.7.1-2.module+el9.4.0+20787+4c237fd3.s390x.rpm","rubygem-io-console-0:0.7.1-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm","rubygem-io-console-debuginfo-0:0.7.1-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm","rubygem-io-console-debuginfo-0:0.7.1-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm","rubygem-io-console-debuginfo-0:0.7.1-2.module+el9.4.0+20787+4c237fd3.s390x.rpm","rubygem-io-console-debuginfo-0:0.7.1-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm","rubygem-irb-0:1.11.0-2.module+el9.4.0+20787+4c237fd3.noarch.rpm","rubygem-json-0:2.7.1-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm","rubygem-json-0:2.7.1-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm","rubygem-json-0:2.7.1-2.module+el9.4.0+20787+4c237fd3.s390x.rpm","rubygem-json-0:2.7.1-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm","rubygem-json-debuginfo-0:2.7.1-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm","rubygem-json-debuginfo-0:2.7.1-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm","rubygem-json-debuginfo-0:2.7.1-2.module+el9.4.0+20787+4c237fd3.s390x.rpm","rubygem-json-debuginfo-0:2.7.1-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm","rubygem-minitest-0:5.20.0-2.module+el9.4.0+20787+4c237fd3.noarch.rpm","rubygem-mysql2-0:0.5.5-1.module+el9.4.0+20787+4c237fd3.aarch64.rpm","rubygem-mysql2-0:0.5.5-1.module+el9.4.0+20787+4c237fd3.ppc64le.rpm","rubygem-mysql2-0:0.5.5-1.module+el9.4.0+20787+4c237fd3.s390x.rpm","rubygem-mysql2-0:0.5.5-1.module+el9.4.0+20787+4c237fd3.src.rpm","rubygem-mysql2-0:0.5.5-1.module+el9.4.0+20787+4c237fd3.x86_64.rpm","rubygem-mysql2-debuginfo-0:0.5.5-1.module+el9.4.0+20787+4c237fd3.aarch64.rpm","rubygem-mysql2-debuginfo-0:0.5.5-1.module+el9.4.0+20787+4c237fd3.ppc64le.rpm","rubygem-mysql2-debuginfo-0:0.5.5-1.module+el9.4.0+20787+4c237fd3.s390x.rpm","rubygem-mysql2-debuginfo-0:0.5.5-1.module+el9.4.0+20787+4c237fd3.x86_64.rpm","rubygem-mysql2-debugsource-0:0.5.5-1.module+el9.4.0+20787+4c237fd3.aarch64.rpm","rubygem-mysql2-debugsource-0:0.5.5-1.module+el9.4.0+20787+4c237fd3.ppc64le.rpm","rubygem-mysql2-debugsource-0:0.5.5-1.module+el9.4.0+20787+4c237fd3.s390x.rpm","rubygem-mysql2-debugsource-0:0.5.5-1.module+el9.4.0+20787+4c237fd3.x86_64.rpm","rubygem-mysql2-doc-0:0.5.5-1.module+el9.4.0+20787+4c237fd3.noarch.rpm","rubygem-pg-0:1.5.4-1.module+el9.4.0+20787+4c237fd3.aarch64.rpm","rubygem-pg-0:1.5.4-1.module+el9.4.0+20787+4c237fd3.ppc64le.rpm","rubygem-pg-0:1.5.4-1.module+el9.4.0+20787+4c237fd3.s390x.rpm","rubygem-pg-0:1.5.4-1.module+el9.4.0+20787+4c237fd3.src.rpm","rubygem-pg-0:1.5.4-1.module+el9.4.0+20787+4c237fd3.x86_64.rpm","rubygem-pg-debuginfo-0:1.5.4-1.module+el9.4.0+20787+4c237fd3.aarch64.rpm","rubygem-pg-debuginfo-0:1.5.4-1.module+el9.4.0+20787+4c237fd3.ppc64le.rpm","rubygem-pg-debuginfo-0:1.5.4-1.module+el9.4.0+20787+4c237fd3.s390x.rpm","rubygem-pg-debuginfo-0:1.5.4-1.module+el9.4.0+20787+4c237fd3.x86_64.rpm","rubygem-pg-debugsource-0:1.5.4-1.module+el9.4.0+20787+4c237fd3.aarch64.rpm","rubygem-pg-debugsource-0:1.5.4-1.module+el9.4.0+20787+4c237fd3.ppc64le.rpm","rubygem-pg-debugsource-0:1.5.4-1.module+el9.4.0+20787+4c237fd3.s390x.rpm","rubygem-pg-debugsource-0:1.5.4-1.module+el9.4.0+20787+4c237fd3.x86_64.rpm","rubygem-pg-doc-0:1.5.4-1.module+el9.4.0+20787+4c237fd3.noarch.rpm","rubygem-power_assert-0:2.0.3-2.module+el9.4.0+20787+4c237fd3.noarch.rpm","rubygem-psych-0:5.1.2-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm","rubygem-psych-0:5.1.2-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm","rubygem-psych-0:5.1.2-2.module+el9.4.0+20787+4c237fd3.s390x.rpm","rubygem-psych-0:5.1.2-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm","rubygem-psych-debuginfo-0:5.1.2-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm","rubygem-psych-debuginfo-0:5.1.2-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm","rubygem-psych-debuginfo-0:5.1.2-2.module+el9.4.0+20787+4c237fd3.s390x.rpm","rubygem-psych-debuginfo-0:5.1.2-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm","rubygem-racc-0:1.7.3-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm","rubygem-racc-0:1.7.3-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm","rubygem-racc-0:1.7.3-2.module+el9.4.0+20787+4c237fd3.s390x.rpm","rubygem-racc-0:1.7.3-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm","rubygem-racc-debuginfo-0:1.7.3-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm","rubygem-racc-debuginfo-0:1.7.3-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm","rubygem-racc-debuginfo-0:1.7.3-2.module+el9.4.0+20787+4c237fd3.s390x.rpm","rubygem-racc-debuginfo-0:1.7.3-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm","rubygem-rake-0:13.1.0-2.module+el9.4.0+20787+4c237fd3.noarch.rpm","rubygem-rbs-0:3.4.0-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm","rubygem-rbs-0:3.4.0-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm","rubygem-rbs-0:3.4.0-2.module+el9.4.0+20787+4c237fd3.s390x.rpm","rubygem-rbs-0:3.4.0-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm","rubygem-rbs-debuginfo-0:3.4.0-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm","rubygem-rbs-debuginfo-0:3.4.0-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm","rubygem-rbs-debuginfo-0:3.4.0-2.module+el9.4.0+20787+4c237fd3.s390x.rpm","rubygem-rbs-debuginfo-0:3.4.0-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm","rubygem-rdoc-0:6.6.3.1-2.module+el9.4.0+20787+4c237fd3.noarch.rpm","rubygem-rexml-0:3.2.6-2.module+el9.4.0+20787+4c237fd3.noarch.rpm","rubygem-rss-0:0.3.0-2.module+el9.4.0+20787+4c237fd3.noarch.rpm","rubygems-0:3.5.9-2.module+el9.4.0+20787+4c237fd3.noarch.rpm","rubygems-devel-0:3.5.9-2.module+el9.4.0+20787+4c237fd3.noarch.rpm","rubygem-test-unit-0:3.6.1-2.module+el9.4.0+20787+4c237fd3.noarch.rpm","rubygem-typeprof-0:0.21.9-2.module+el9.4.0+20787+4c237fd3.noarch.rpm","ruby-libs-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm","ruby-libs-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm","ruby-libs-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.s390x.rpm","ruby-libs-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm","ruby-libs-debuginfo-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm","ruby-libs-debuginfo-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm","ruby-libs-debuginfo-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.s390x.rpm","ruby-libs-debuginfo-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm"]}},"rebootSuggested":false,"buildReferences":[]}

Rocky Linux: RLSA-2024:3671 ruby Security Advisories Updates

June 14, 2024
An update is available for rubygem-mysql2, module.rubygem-pg, ruby, module.rubygem-mysql2, rubygem-pg, module.ruby. This update affects Rocky Linux 9. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE list

Summary

An update is available for rubygem-mysql2, module.rubygem-pg, ruby, module.rubygem-mysql2, rubygem-pg, module.ruby. This update affects Rocky Linux 9. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE list


Ruby is an extensible, interpreted, object-oriented, scripting language. It has features to process text files and to perform system management tasks. The following packages have been upgraded to a later upstream version: ruby (3.3). (Rocky Linux-37697) Security Fix(es): * ruby: Buffer overread vulnerability in StringIO (CVE-2024-27280) * ruby: RCE vulnerability with .rdoc_options in RDoc (CVE-2024-27281) * ruby: Arbitrary memory address read vulnerability with Regex search (CVE-2024-27282) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

RPMs

ruby-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm

ruby-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm

ruby-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.s390x.rpm

ruby-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.src.rpm

ruby-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm

ruby-bundled-gems-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm

ruby-bundled-gems-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm

ruby-bundled-gems-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.s390x.rpm

ruby-bundled-gems-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm

ruby-bundled-gems-debuginfo-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm

ruby-bundled-gems-debuginfo-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm

ruby-bundled-gems-debuginfo-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.s390x.rpm

ruby-bundled-gems-debuginfo-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm

ruby-debuginfo-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm

ruby-debuginfo-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm

ruby-debuginfo-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.s390x.rpm

ruby-debuginfo-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm

ruby-debugsource-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm

ruby-debugsource-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm

ruby-debugsource-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.s390x.rpm

ruby-debugsource-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm

ruby-default-gems-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.noarch.rpm

ruby-devel-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm

ruby-devel-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm

ruby-devel-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.s390x.rpm

ruby-devel-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm

ruby-doc-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.noarch.rpm

rubygem-bigdecimal-0:3.1.5-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm

rubygem-bigdecimal-0:3.1.5-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm

rubygem-bigdecimal-0:3.1.5-2.module+el9.4.0+20787+4c237fd3.s390x.rpm

rubygem-bigdecimal-0:3.1.5-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm

rubygem-bigdecimal-debuginfo-0:3.1.5-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm

rubygem-bigdecimal-debuginfo-0:3.1.5-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm

rubygem-bigdecimal-debuginfo-0:3.1.5-2.module+el9.4.0+20787+4c237fd3.s390x.rpm

rubygem-bigdecimal-debuginfo-0:3.1.5-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm

rubygem-bundler-0:2.5.9-2.module+el9.4.0+20787+4c237fd3.noarch.rpm

rubygem-io-console-0:0.7.1-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm

rubygem-io-console-0:0.7.1-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm

rubygem-io-console-0:0.7.1-2.module+el9.4.0+20787+4c237fd3.s390x.rpm

rubygem-io-console-0:0.7.1-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm

rubygem-io-console-debuginfo-0:0.7.1-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm

rubygem-io-console-debuginfo-0:0.7.1-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm

rubygem-io-console-debuginfo-0:0.7.1-2.module+el9.4.0+20787+4c237fd3.s390x.rpm

rubygem-io-console-debuginfo-0:0.7.1-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm

rubygem-irb-0:1.11.0-2.module+el9.4.0+20787+4c237fd3.noarch.rpm

rubygem-json-0:2.7.1-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm

rubygem-json-0:2.7.1-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm

rubygem-json-0:2.7.1-2.module+el9.4.0+20787+4c237fd3.s390x.rpm

rubygem-json-0:2.7.1-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm

rubygem-json-debuginfo-0:2.7.1-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm

rubygem-json-debuginfo-0:2.7.1-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm

rubygem-json-debuginfo-0:2.7.1-2.module+el9.4.0+20787+4c237fd3.s390x.rpm

rubygem-json-debuginfo-0:2.7.1-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm

rubygem-minitest-0:5.20.0-2.module+el9.4.0+20787+4c237fd3.noarch.rpm

rubygem-mysql2-0:0.5.5-1.module+el9.4.0+20787+4c237fd3.aarch64.rpm

rubygem-mysql2-0:0.5.5-1.module+el9.4.0+20787+4c237fd3.ppc64le.rpm

rubygem-mysql2-0:0.5.5-1.module+el9.4.0+20787+4c237fd3.s390x.rpm

rubygem-mysql2-0:0.5.5-1.module+el9.4.0+20787+4c237fd3.src.rpm

rubygem-mysql2-0:0.5.5-1.module+el9.4.0+20787+4c237fd3.x86_64.rpm

rubygem-mysql2-debuginfo-0:0.5.5-1.module+el9.4.0+20787+4c237fd3.aarch64.rpm

rubygem-mysql2-debuginfo-0:0.5.5-1.module+el9.4.0+20787+4c237fd3.ppc64le.rpm

rubygem-mysql2-debuginfo-0:0.5.5-1.module+el9.4.0+20787+4c237fd3.s390x.rpm

rubygem-mysql2-debuginfo-0:0.5.5-1.module+el9.4.0+20787+4c237fd3.x86_64.rpm

rubygem-mysql2-debugsource-0:0.5.5-1.module+el9.4.0+20787+4c237fd3.aarch64.rpm

rubygem-mysql2-debugsource-0:0.5.5-1.module+el9.4.0+20787+4c237fd3.ppc64le.rpm

rubygem-mysql2-debugsource-0:0.5.5-1.module+el9.4.0+20787+4c237fd3.s390x.rpm

rubygem-mysql2-debugsource-0:0.5.5-1.module+el9.4.0+20787+4c237fd3.x86_64.rpm

rubygem-mysql2-doc-0:0.5.5-1.module+el9.4.0+20787+4c237fd3.noarch.rpm

rubygem-pg-0:1.5.4-1.module+el9.4.0+20787+4c237fd3.aarch64.rpm

rubygem-pg-0:1.5.4-1.module+el9.4.0+20787+4c237fd3.ppc64le.rpm

rubygem-pg-0:1.5.4-1.module+el9.4.0+20787+4c237fd3.s390x.rpm

rubygem-pg-0:1.5.4-1.module+el9.4.0+20787+4c237fd3.src.rpm

rubygem-pg-0:1.5.4-1.module+el9.4.0+20787+4c237fd3.x86_64.rpm

rubygem-pg-debuginfo-0:1.5.4-1.module+el9.4.0+20787+4c237fd3.aarch64.rpm

rubygem-pg-debuginfo-0:1.5.4-1.module+el9.4.0+20787+4c237fd3.ppc64le.rpm

rubygem-pg-debuginfo-0:1.5.4-1.module+el9.4.0+20787+4c237fd3.s390x.rpm

rubygem-pg-debuginfo-0:1.5.4-1.module+el9.4.0+20787+4c237fd3.x86_64.rpm

rubygem-pg-debugsource-0:1.5.4-1.module+el9.4.0+20787+4c237fd3.aarch64.rpm

rubygem-pg-debugsource-0:1.5.4-1.module+el9.4.0+20787+4c237fd3.ppc64le.rpm

rubygem-pg-debugsource-0:1.5.4-1.module+el9.4.0+20787+4c237fd3.s390x.rpm

rubygem-pg-debugsource-0:1.5.4-1.module+el9.4.0+20787+4c237fd3.x86_64.rpm

rubygem-pg-doc-0:1.5.4-1.module+el9.4.0+20787+4c237fd3.noarch.rpm

rubygem-power_assert-0:2.0.3-2.module+el9.4.0+20787+4c237fd3.noarch.rpm

rubygem-psych-0:5.1.2-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm

rubygem-psych-0:5.1.2-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm

rubygem-psych-0:5.1.2-2.module+el9.4.0+20787+4c237fd3.s390x.rpm

rubygem-psych-0:5.1.2-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm

rubygem-psych-debuginfo-0:5.1.2-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm

rubygem-psych-debuginfo-0:5.1.2-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm

rubygem-psych-debuginfo-0:5.1.2-2.module+el9.4.0+20787+4c237fd3.s390x.rpm

rubygem-psych-debuginfo-0:5.1.2-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm

rubygem-racc-0:1.7.3-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm

rubygem-racc-0:1.7.3-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm

rubygem-racc-0:1.7.3-2.module+el9.4.0+20787+4c237fd3.s390x.rpm

rubygem-racc-0:1.7.3-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm

rubygem-racc-debuginfo-0:1.7.3-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm

rubygem-racc-debuginfo-0:1.7.3-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm

rubygem-racc-debuginfo-0:1.7.3-2.module+el9.4.0+20787+4c237fd3.s390x.rpm

rubygem-racc-debuginfo-0:1.7.3-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm

rubygem-rake-0:13.1.0-2.module+el9.4.0+20787+4c237fd3.noarch.rpm

rubygem-rbs-0:3.4.0-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm

rubygem-rbs-0:3.4.0-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm

rubygem-rbs-0:3.4.0-2.module+el9.4.0+20787+4c237fd3.s390x.rpm

rubygem-rbs-0:3.4.0-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm

rubygem-rbs-debuginfo-0:3.4.0-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm

rubygem-rbs-debuginfo-0:3.4.0-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm

rubygem-rbs-debuginfo-0:3.4.0-2.module+el9.4.0+20787+4c237fd3.s390x.rpm

rubygem-rbs-debuginfo-0:3.4.0-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm

rubygem-rdoc-0:6.6.3.1-2.module+el9.4.0+20787+4c237fd3.noarch.rpm

rubygem-rexml-0:3.2.6-2.module+el9.4.0+20787+4c237fd3.noarch.rpm

rubygem-rss-0:0.3.0-2.module+el9.4.0+20787+4c237fd3.noarch.rpm

rubygems-0:3.5.9-2.module+el9.4.0+20787+4c237fd3.noarch.rpm

rubygems-devel-0:3.5.9-2.module+el9.4.0+20787+4c237fd3.noarch.rpm

rubygem-test-unit-0:3.6.1-2.module+el9.4.0+20787+4c237fd3.noarch.rpm

rubygem-typeprof-0:0.21.9-2.module+el9.4.0+20787+4c237fd3.noarch.rpm

ruby-libs-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm

ruby-libs-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm

ruby-libs-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.s390x.rpm

ruby-libs-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm

ruby-libs-debuginfo-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.aarch64.rpm

ruby-libs-debuginfo-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.ppc64le.rpm

ruby-libs-debuginfo-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.s390x.rpm

ruby-libs-debuginfo-0:3.3.1-2.module+el9.4.0+20787+4c237fd3.x86_64.rpm

References

No References

CVEs

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2024-27280

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2024-27281

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2024-27282

Severity
Name: RLSA-2024:3671
Affected Products: Rocky Linux 9

Fixes

https://bugzilla.redhat.com/show_bug.cgi?id=2270749

https://bugzilla.redhat.com/show_bug.cgi?id=2270750

https://bugzilla.redhat.com/show_bug.cgi?id=2276810


Related News