SciLinux: SLSA-2020-3217-1 Moderate: grub2 on SL7.x x86_64

    Date 31 Jul 2020
    99
    Posted By LinuxSecurity Advisories
    grub2: Crafted grub.cfg file can lead to arbitrary code execution during boot process (CVE-2020-10713) * grub2: grub_malloc does not validate allocation size allowing for arithmetic overflow and subsequent heap-based buffer overflow (CVE-2020-14308) * grub2: Integer overflow in grub_squash_read_symlink may lead to heap-based buffer overflow (CVE-2020-14309) * grub2: Integer overflow read_se [More...]
    Synopsis:          Moderate: grub2 security and bug fix update
    Advisory ID:       SLSA-2020:3217-1
    Issue Date:        2020-07-29
    CVE Numbers:       None
    --
    
    Security Fix(es):
    
    * grub2: Crafted grub.cfg file can lead to arbitrary code execution during
    boot process (CVE-2020-10713)
    
    * grub2: grub_malloc does not validate allocation size allowing for
    arithmetic overflow and subsequent heap-based buffer overflow
    (CVE-2020-14308)
    
    * grub2: Integer overflow in grub_squash_read_symlink may lead to
    heap-based buffer overflow (CVE-2020-14309)
    
    * grub2: Integer overflow read_section_as_string may lead to heap-based
    buffer overflow (CVE-2020-14310)
    
    * grub2: Integer overflow in grub_ext2_read_link leads to heap-based buffer
    overflow (CVE-2020-14311)
    
    * grub2: Fail kernel validation without shim protocol (CVE-2020-15705)
    
    * grub2: Use-after-free redefining a function whilst the same function is
    already executing (CVE-2020-15706)
    
    * grub2: Integer overflow in initrd size handling (CVE-2020-15707)
    --
    
    SL7
      x86_64
        fwupdate-12-6.el7_8.x86_64.rpm
        fwupdate-debuginfo-12-6.el7_8.x86_64.rpm
        fwupdate-efi-12-6.el7_8.x86_64.rpm
        fwupdate-libs-12-6.el7_8.x86_64.rpm
        grub2-2.02-0.86.el7_8.x86_64.rpm
        grub2-debuginfo-2.02-0.86.el7_8.x86_64.rpm
        grub2-efi-ia32-2.02-0.86.el7_8.x86_64.rpm
        grub2-efi-x64-2.02-0.86.el7_8.x86_64.rpm
        grub2-pc-2.02-0.86.el7_8.x86_64.rpm
        grub2-tools-2.02-0.86.el7_8.x86_64.rpm
        grub2-tools-extra-2.02-0.86.el7_8.x86_64.rpm
        grub2-tools-minimal-2.02-0.86.el7_8.x86_64.rpm
        mokutil-15-7.el7_8.x86_64.rpm
        mokutil-debuginfo-15-7.el7_8.x86_64.rpm
        shim-ia32-15-7.el7_8.x86_64.rpm
        shim-unsigned-ia32-15-7.el7_9.x86_64.rpm
        shim-unsigned-x64-15-7.el7_9.x86_64.rpm
        shim-x64-15-7.el7_8.x86_64.rpm
        fwupdate-devel-12-6.el7_8.x86_64.rpm
        grub2-efi-ia32-cdboot-2.02-0.86.el7_8.x86_64.rpm
        grub2-efi-x64-cdboot-2.02-0.86.el7_8.x86_64.rpm
      noarch
        grub2-common-2.02-0.86.el7_8.noarch.rpm
        grub2-efi-ia32-modules-2.02-0.86.el7_8.noarch.rpm
        grub2-efi-x64-modules-2.02-0.86.el7_8.noarch.rpm
        grub2-pc-modules-2.02-0.86.el7_8.noarch.rpm
        shim-unsigned-aa64-debuginfo-15-7.el7_9.noarch.rpm
        shim-unsigned-ia32-debuginfo-15-7.el7_9.noarch.rpm
        shim-unsigned-x64-debuginfo-15-7.el7_9.noarch.rpm
        grub2-efi-aa64-modules-2.02-0.86.el7_8.noarch.rpm
        grub2-ppc-modules-2.02-0.86.el7_8.noarch.rpm
        grub2-ppc64-modules-2.02-0.86.el7_8.noarch.rpm
        grub2-ppc64le-modules-2.02-0.86.el7_8.noarch.rpm
    
    - Scientific Linux Development Team
    

    LinuxSecurity Poll

    Are you planning to use the 1Password password manager now that it is available to Linux users?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/35-are-you-planning-to-use-the-1password-password-manager-now-that-it-is-available-to-linux-users?task=poll.vote&format=json
    35
    radio
    [{"id":"122","title":"Yes","votes":"1","type":"x","order":"1","pct":20,"resources":[]},{"id":"123","title":"No ","votes":"3","type":"x","order":"2","pct":60,"resources":[]},{"id":"124","title":"Not sure at the moment","votes":"1","type":"x","order":"3","pct":20,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350
    bottom 200

    Advisories

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.