Synopsis:          Important: tigervnc and xorg-x11-server security update
Advisory ID:       SLSA-2023:0675-1
Issue Date:        2023-02-09
CVE Numbers:       CVE-2023-0494
--

X.Org is an open-source implementation of the X Window System. It provides
the basic low-level functionality that full-fledged graphical user
interfaces are designed upon.

Security Fix(es):

* xorg-x11-server: DeepCopyPointerClasses use-after-free leads to
privilege  elevation (CVE-2023-0494)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
--

SL7
  x86_64
    tigervnc-1.8.0-24.el7_9.x86_64.rpm
    tigervnc-debuginfo-1.8.0-24.el7_9.x86_64.rpm
    tigervnc-server-1.8.0-24.el7_9.x86_64.rpm
    tigervnc-server-minimal-1.8.0-24.el7_9.x86_64.rpm
    xorg-x11-server-Xephyr-1.20.4-22.el7_9.x86_64.rpm
    xorg-x11-server-Xorg-1.20.4-22.el7_9.x86_64.rpm
    xorg-x11-server-common-1.20.4-22.el7_9.x86_64.rpm
    xorg-x11-server-debuginfo-1.20.4-22.el7_9.x86_64.rpm
    tigervnc-server-module-1.8.0-24.el7_9.x86_64.rpm
    xorg-x11-server-Xdmx-1.20.4-22.el7_9.x86_64.rpm
    xorg-x11-server-Xnest-1.20.4-22.el7_9.x86_64.rpm
    xorg-x11-server-Xvfb-1.20.4-22.el7_9.x86_64.rpm
    xorg-x11-server-Xwayland-1.20.4-22.el7_9.x86_64.rpm
    xorg-x11-server-debuginfo-1.20.4-22.el7_9.i686.rpm
    xorg-x11-server-devel-1.20.4-22.el7_9.i686.rpm
    xorg-x11-server-devel-1.20.4-22.el7_9.x86_64.rpm
  noarch
    tigervnc-icons-1.8.0-24.el7_9.noarch.rpm
    tigervnc-license-1.8.0-24.el7_9.noarch.rpm
    tigervnc-server-applet-1.8.0-24.el7_9.noarch.rpm
    xorg-x11-server-source-1.20.4-22.el7_9.noarch.rpm

- Scientific Linux Development Team

SciLinux: SLSA-2023-0675-1 Important: tigervnc and xorg-x11-server on SL7.x x86_64

xorg-x11-server: DeepCopyPointerClasses use-after-free leads to privilege elevation (CVE-2023-0494) For more details about the security issue(s), including the impact, a CVSS score...

Summary

Important: tigervnc and xorg-x11-server security update



Security Fixes

* xorg-x11-server: DeepCopyPointerClasses use-after-free leads to privilege elevation (CVE-2023-0494)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE
SL7 x86_64 tigervnc-1.8.0-24.el7_9.x86_64.rpm tigervnc-debuginfo-1.8.0-24.el7_9.x86_64.rpm tigervnc-server-1.8.0-24.el7_9.x86_64.rpm tigervnc-server-minimal-1.8.0-24.el7_9.x86_64.rpm xorg-x11-server-Xephyr-1.20.4-22.el7_9.x86_64.rpm xorg-x11-server-Xorg-1.20.4-22.el7_9.x86_64.rpm xorg-x11-server-common-1.20.4-22.el7_9.x86_64.rpm xorg-x11-server-debuginfo-1.20.4-22.el7_9.x86_64.rpm tigervnc-server-module-1.8.0-24.el7_9.x86_64.rpm xorg-x11-server-Xdmx-1.20.4-22.el7_9.x86_64.rpm xorg-x11-server-Xnest-1.20.4-22.el7_9.x86_64.rpm xorg-x11-server-Xvfb-1.20.4-22.el7_9.x86_64.rpm xorg-x11-server-Xwayland-1.20.4-22.el7_9.x86_64.rpm xorg-x11-server-debuginfo-1.20.4-22.el7_9.i686.rpm xorg-x11-server-devel-1.20.4-22.el7_9.i686.rpm xorg-x11-server-devel-1.20.4-22.el7_9.x86_64.rpm noarch tigervnc-icons-1.8.0-24.el7_9.noarch.rpm tigervnc-license-1.8.0-24.el7_9.noarch.rpm tigervnc-server-applet-1.8.0-24.el7_9.noarch.rpm xorg-x11-server-source-1.20.4-22.el7_9.noarch.rpm
- Scientific Linux Development Team

Severity
Advisory ID: SLSA-2023:0675-1
Issued Date: : 2023-02-09
CVE Numbers: CVE-2023-0494
X.Org is an open-source implementation of the X Window System. It provides

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo