-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

[slackware-security]  vim (SSA:2023-328-01)

New vim packages are available for Slackware 15.0 and -current to
fix security issues.


Here are the details from the Slackware 15.0 ChangeLog:
+--------------------------+
patches/packages/vim-9.0.2127-i586-1_slack15.0.txz:  Upgraded.
  Fixed security issues.
  Thanks to marav for the heads-up.
  For more information, see:
    https://www.cve.org/CVERecord?id=CVE-2023-48231
    https://www.cve.org/CVERecord?id=CVE-2023-48232
    https://www.cve.org/CVERecord?id=CVE-2023-48233
    https://www.cve.org/CVERecord?id=CVE-2023-48234
    https://www.cve.org/CVERecord?id=CVE-2023-48235
    https://www.cve.org/CVERecord?id=CVE-2023-48236
    https://www.cve.org/CVERecord?id=CVE-2023-48237
  (* Security fix *)
patches/packages/vim-gvim-9.0.2127-i586-1_slack15.0.txz:  Upgraded.
+--------------------------+


Where to find the new packages:
+-----------------------------+

Thanks to the friendly folks at the OSU Open Source Lab
(https://osuosl.org/) for donating FTP and rsync hosting
to the Slackware project!  :-)

Also see the "Get Slack" section on http://www.slackware.com/ for
additional mirror sites near you.

Updated packages for Slackware 15.0:
ftp://ftp.slackware.com/pub/slackware/slackware-15.0/patches/packages/vim-9.0.2127-i586-1_slack15.0.txz
ftp://ftp.slackware.com/pub/slackware/slackware-15.0/patches/packages/vim-gvim-9.0.2127-i586-1_slack15.0.txz

Updated packages for Slackware x86_64 15.0:
ftp://ftp.slackware.com/pub/slackware/slackware64-15.0/patches/packages/vim-9.0.2127-x86_64-1_slack15.0.txz
ftp://ftp.slackware.com/pub/slackware/slackware64-15.0/patches/packages/vim-gvim-9.0.2127-x86_64-1_slack15.0.txz

Updated packages for Slackware -current:

Updated packages for Slackware x86_64 -current:


MD5 signatures:
+-------------+

Slackware 15.0 packages:
c0072756362f34fa5fc1121d49481d48  vim-9.0.2127-i586-1_slack15.0.txz
c8fc94e220e7d1f88962b52a0a378d83  vim-gvim-9.0.2127-i586-1_slack15.0.txz

Slackware x86_64 15.0 packages:
3b8a942d068343c6d8c0df5057bf6aee  vim-9.0.2127-x86_64-1_slack15.0.txz
e8463e28282a9d3dd47888071db2f027  vim-gvim-9.0.2127-x86_64-1_slack15.0.txz

Slackware -current packages:
a7f26ee78d9ef0d72b543eb695f22aea  ap/vim-9.0.2127-i586-1.txz
01b7e7b14e4c81d6f20865d9fce48670  xap/vim-gvim-9.0.2127-i586-1.txz

Slackware x86_64 -current packages:
3fd98cb7c623b08451d9d582560994c8  ap/vim-9.0.2127-x86_64-1.txz
d5512b67b25af76d003359e69e39b6c3  xap/vim-gvim-9.0.2127-x86_64-1.txz


Installation instructions:
+------------------------+

Upgrade the packages as root:
# upgradepkg vim-9.0.2127-i586-1_slack15.0.txz vim-gvim-9.0.2127-i586-1_slack15.0.txz


+-----+

Slackware: 2023-328-01: vim Security Update

November 24, 2023
New vim packages are available for Slackware 15.0 and -current to fix security issues

Summary

Here are the details from the Slackware 15.0 ChangeLog: patches/packages/vim-9.0.2127-i586-1_slack15.0.txz: Upgraded. Fixed security issues. Thanks to marav for the heads-up. For more information, see: https://www.cve.org/CVERecord?id=CVE-2023-48231 https://www.cve.org/CVERecord?id=CVE-2023-48232 https://www.cve.org/CVERecord?id=CVE-2023-48233 https://www.cve.org/CVERecord?id=CVE-2023-48234 https://www.cve.org/CVERecord?id=CVE-2023-48235 https://www.cve.org/CVERecord?id=CVE-2023-48236 https://www.cve.org/CVERecord?id=CVE-2023-48237 (* Security fix *) patches/packages/vim-gvim-9.0.2127-i586-1_slack15.0.txz: Upgraded.

Where Find New Packages

Thanks to the friendly folks at the OSU Open Source Lab (https://osuosl.org/) for donating FTP and rsync hosting to the Slackware project! :-)
Also see the "Get Slack" section on http://www.slackware.com/ for additional mirror sites near you.
Updated packages for Slackware 15.0: ftp://ftp.slackware.com/pub/slackware/slackware-15.0/patches/packages/vim-9.0.2127-i586-1_slack15.0.txz ftp://ftp.slackware.com/pub/slackware/slackware-15.0/patches/packages/vim-gvim-9.0.2127-i586-1_slack15.0.txz
Updated packages for Slackware x86_64 15.0: ftp://ftp.slackware.com/pub/slackware/slackware64-15.0/patches/packages/vim-9.0.2127-x86_64-1_slack15.0.txz ftp://ftp.slackware.com/pub/slackware/slackware64-15.0/patches/packages/vim-gvim-9.0.2127-x86_64-1_slack15.0.txz
Updated packages for Slackware -current:
Updated packages for Slackware x86_64 -current:

MD5 Signatures

Slackware 15.0 packages: c0072756362f34fa5fc1121d49481d48 vim-9.0.2127-i586-1_slack15.0.txz c8fc94e220e7d1f88962b52a0a378d83 vim-gvim-9.0.2127-i586-1_slack15.0.txz
Slackware x86_64 15.0 packages: 3b8a942d068343c6d8c0df5057bf6aee vim-9.0.2127-x86_64-1_slack15.0.txz e8463e28282a9d3dd47888071db2f027 vim-gvim-9.0.2127-x86_64-1_slack15.0.txz
Slackware -current packages: a7f26ee78d9ef0d72b543eb695f22aea ap/vim-9.0.2127-i586-1.txz 01b7e7b14e4c81d6f20865d9fce48670 xap/vim-gvim-9.0.2127-i586-1.txz
Slackware x86_64 -current packages: 3fd98cb7c623b08451d9d582560994c8 ap/vim-9.0.2127-x86_64-1.txz d5512b67b25af76d003359e69e39b6c3 xap/vim-gvim-9.0.2127-x86_64-1.txz

Severity
[slackware-security] vim (SSA:2023-328-01)
New vim packages are available for Slackware 15.0 and -current to fix security issues.

Installation Instructions

Installation instructions: Upgrade the packages as root: # upgradepkg vim-9.0.2127-i586-1_slack15.0.txz vim-gvim-9.0.2127-i586-1_slack15.0.txz

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo