SUSE Security Update: Security update for git
______________________________________________________________________________

Announcement ID:    SUSE-SU-2020:0991-1
Rating:             important
References:         #1168930 
Cross-References:   CVE-2020-5260
Affected Products:
                    SUSE Linux Enterprise Server for SAP 15
                    SUSE Linux Enterprise Server 15-LTSS
                    SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1
                    SUSE Linux Enterprise Module for Development Tools 15-SP1
                    SUSE Linux Enterprise Module for Basesystem 15-SP1
                    SUSE Linux Enterprise High Performance Computing 15-LTSS
                    SUSE Linux Enterprise High Performance Computing 15-ESPOS
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for git fixes the following issues:

   - CVE-2020-5260: With a crafted URL that contains a newline in it, the
     credential helper machinery can be fooled to give credential information
     for a wrong host (bsc#1168930).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Server for SAP 15:

      zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2020-991=1

   - SUSE Linux Enterprise Server 15-LTSS:

      zypper in -t patch SUSE-SLE-Product-SLES-15-2020-991=1

   - SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1:

      zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-991=1

   - SUSE Linux Enterprise Module for Development Tools 15-SP1:

      zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP1-2020-991=1

   - SUSE Linux Enterprise Module for Basesystem 15-SP1:

      zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP1-2020-991=1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-2020-991=1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-2020-991=1



Package List:

   - SUSE Linux Enterprise Server for SAP 15 (ppc64le x86_64):

      git-2.16.4-3.20.1
      git-arch-2.16.4-3.20.1
      git-core-2.16.4-3.20.1
      git-core-debuginfo-2.16.4-3.20.1
      git-cvs-2.16.4-3.20.1
      git-daemon-2.16.4-3.20.1
      git-daemon-debuginfo-2.16.4-3.20.1
      git-debuginfo-2.16.4-3.20.1
      git-debugsource-2.16.4-3.20.1
      git-email-2.16.4-3.20.1
      git-gui-2.16.4-3.20.1
      git-svn-2.16.4-3.20.1
      git-svn-debuginfo-2.16.4-3.20.1
      git-web-2.16.4-3.20.1
      gitk-2.16.4-3.20.1

   - SUSE Linux Enterprise Server for SAP 15 (noarch):

      git-doc-2.16.4-3.20.1

   - SUSE Linux Enterprise Server 15-LTSS (aarch64 s390x):

      git-2.16.4-3.20.1
      git-arch-2.16.4-3.20.1
      git-core-2.16.4-3.20.1
      git-core-debuginfo-2.16.4-3.20.1
      git-cvs-2.16.4-3.20.1
      git-daemon-2.16.4-3.20.1
      git-daemon-debuginfo-2.16.4-3.20.1
      git-debuginfo-2.16.4-3.20.1
      git-debugsource-2.16.4-3.20.1
      git-email-2.16.4-3.20.1
      git-gui-2.16.4-3.20.1
      git-svn-2.16.4-3.20.1
      git-svn-debuginfo-2.16.4-3.20.1
      git-web-2.16.4-3.20.1
      gitk-2.16.4-3.20.1

   - SUSE Linux Enterprise Server 15-LTSS (noarch):

      git-doc-2.16.4-3.20.1

   - SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (aarch64 ppc64le s390x x86_64):

      git-credential-gnome-keyring-2.16.4-3.20.1
      git-credential-gnome-keyring-debuginfo-2.16.4-3.20.1
      git-credential-libsecret-2.16.4-3.20.1
      git-credential-libsecret-debuginfo-2.16.4-3.20.1
      git-debuginfo-2.16.4-3.20.1
      git-debugsource-2.16.4-3.20.1
      git-p4-2.16.4-3.20.1

   - SUSE Linux Enterprise Module for Development Tools 15-SP1 (aarch64 ppc64le s390x x86_64):

      git-2.16.4-3.20.1
      git-arch-2.16.4-3.20.1
      git-cvs-2.16.4-3.20.1
      git-daemon-2.16.4-3.20.1
      git-daemon-debuginfo-2.16.4-3.20.1
      git-debuginfo-2.16.4-3.20.1
      git-debugsource-2.16.4-3.20.1
      git-email-2.16.4-3.20.1
      git-gui-2.16.4-3.20.1
      git-svn-2.16.4-3.20.1
      git-svn-debuginfo-2.16.4-3.20.1
      git-web-2.16.4-3.20.1
      gitk-2.16.4-3.20.1

   - SUSE Linux Enterprise Module for Development Tools 15-SP1 (noarch):

      git-doc-2.16.4-3.20.1

   - SUSE Linux Enterprise Module for Basesystem 15-SP1 (aarch64 ppc64le s390x x86_64):

      git-core-2.16.4-3.20.1
      git-core-debuginfo-2.16.4-3.20.1
      git-debuginfo-2.16.4-3.20.1
      git-debugsource-2.16.4-3.20.1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS (aarch64 x86_64):

      git-2.16.4-3.20.1
      git-arch-2.16.4-3.20.1
      git-core-2.16.4-3.20.1
      git-core-debuginfo-2.16.4-3.20.1
      git-cvs-2.16.4-3.20.1
      git-daemon-2.16.4-3.20.1
      git-daemon-debuginfo-2.16.4-3.20.1
      git-debuginfo-2.16.4-3.20.1
      git-debugsource-2.16.4-3.20.1
      git-email-2.16.4-3.20.1
      git-gui-2.16.4-3.20.1
      git-svn-2.16.4-3.20.1
      git-svn-debuginfo-2.16.4-3.20.1
      git-web-2.16.4-3.20.1
      gitk-2.16.4-3.20.1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS (noarch):

      git-doc-2.16.4-3.20.1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS (aarch64 x86_64):

      git-2.16.4-3.20.1
      git-arch-2.16.4-3.20.1
      git-core-2.16.4-3.20.1
      git-core-debuginfo-2.16.4-3.20.1
      git-cvs-2.16.4-3.20.1
      git-daemon-2.16.4-3.20.1
      git-daemon-debuginfo-2.16.4-3.20.1
      git-debuginfo-2.16.4-3.20.1
      git-debugsource-2.16.4-3.20.1
      git-email-2.16.4-3.20.1
      git-gui-2.16.4-3.20.1
      git-svn-2.16.4-3.20.1
      git-svn-debuginfo-2.16.4-3.20.1
      git-web-2.16.4-3.20.1
      gitk-2.16.4-3.20.1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS (noarch):

      git-doc-2.16.4-3.20.1


References:

   https://www.suse.com/security/cve/CVE-2020-5260.html
   https://bugzilla.suse.com/1168930

_______________________________________________
sle-security-updates mailing list
[email protected]
https://lists.suse.com/mailman/listinfo/sle-security-updates