Linux Security
    Linux Security
    Linux Security

    SUSE: 2020:2748-1 important: libqt5-qtbase

    Date
    135
    Posted By
    An update that solves one vulnerability and has one errata is now available.
    
       SUSE Security Update: Security update for libqt5-qtbase
    ______________________________________________________________________________
    
    Announcement ID:    SUSE-SU-2020:2748-1
    Rating:             important
    References:         #1172515 #1176315 
    Cross-References:   CVE-2020-17507
    Affected Products:
                        SUSE Linux Enterprise Server for SAP 15
                        SUSE Linux Enterprise Server 15-LTSS
                        SUSE Linux Enterprise High Performance Computing 15-LTSS
                        SUSE Linux Enterprise High Performance Computing 15-ESPOS
    ______________________________________________________________________________
    
       An update that solves one vulnerability and has one errata
       is now available.
    
    Description:
    
       This update for libqt5-qtbase fixes the following issues:
    
       - CVE-2020-17507: Fixed a buffer overflow in XBM parser (bsc#1176315)
       - Made handling of XDG_RUNTIME_DIR more secure (bsc#1172515)
    
    
    Patch Instructions:
    
       To install this SUSE Security Update use the SUSE recommended installation methods
       like YaST online_update or "zypper patch".
    
       Alternatively you can run the command listed for your product:
    
       - SUSE Linux Enterprise Server for SAP 15:
    
          zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2020-2748=1
    
       - SUSE Linux Enterprise Server 15-LTSS:
    
          zypper in -t patch SUSE-SLE-Product-SLES-15-2020-2748=1
    
       - SUSE Linux Enterprise High Performance Computing 15-LTSS:
    
          zypper in -t patch SUSE-SLE-Product-HPC-15-2020-2748=1
    
       - SUSE Linux Enterprise High Performance Computing 15-ESPOS:
    
          zypper in -t patch SUSE-SLE-Product-HPC-15-2020-2748=1
    
    
    
    Package List:
    
       - SUSE Linux Enterprise Server for SAP 15 (ppc64le x86_64):
    
          libQt5Concurrent-devel-5.9.4-8.24.1
          libQt5Concurrent5-5.9.4-8.24.1
          libQt5Concurrent5-debuginfo-5.9.4-8.24.1
          libQt5Core-devel-5.9.4-8.24.1
          libQt5Core5-5.9.4-8.24.1
          libQt5Core5-debuginfo-5.9.4-8.24.1
          libQt5DBus-devel-5.9.4-8.24.1
          libQt5DBus-devel-debuginfo-5.9.4-8.24.1
          libQt5DBus5-5.9.4-8.24.1
          libQt5DBus5-debuginfo-5.9.4-8.24.1
          libQt5Gui-devel-5.9.4-8.24.1
          libQt5Gui5-5.9.4-8.24.1
          libQt5Gui5-debuginfo-5.9.4-8.24.1
          libQt5KmsSupport-devel-static-5.9.4-8.24.1
          libQt5Network-devel-5.9.4-8.24.1
          libQt5Network5-5.9.4-8.24.1
          libQt5Network5-debuginfo-5.9.4-8.24.1
          libQt5OpenGL-devel-5.9.4-8.24.1
          libQt5OpenGL5-5.9.4-8.24.1
          libQt5OpenGL5-debuginfo-5.9.4-8.24.1
          libQt5PlatformHeaders-devel-5.9.4-8.24.1
          libQt5PlatformSupport-devel-static-5.9.4-8.24.1
          libQt5PrintSupport-devel-5.9.4-8.24.1
          libQt5PrintSupport5-5.9.4-8.24.1
          libQt5PrintSupport5-debuginfo-5.9.4-8.24.1
          libQt5Sql-devel-5.9.4-8.24.1
          libQt5Sql5-5.9.4-8.24.1
          libQt5Sql5-debuginfo-5.9.4-8.24.1
          libQt5Sql5-sqlite-5.9.4-8.24.1
          libQt5Sql5-sqlite-debuginfo-5.9.4-8.24.1
          libQt5Test-devel-5.9.4-8.24.1
          libQt5Test5-5.9.4-8.24.1
          libQt5Test5-debuginfo-5.9.4-8.24.1
          libQt5Widgets-devel-5.9.4-8.24.1
          libQt5Widgets5-5.9.4-8.24.1
          libQt5Widgets5-debuginfo-5.9.4-8.24.1
          libQt5Xml-devel-5.9.4-8.24.1
          libQt5Xml5-5.9.4-8.24.1
          libQt5Xml5-debuginfo-5.9.4-8.24.1
          libqt5-qtbase-common-devel-5.9.4-8.24.1
          libqt5-qtbase-common-devel-debuginfo-5.9.4-8.24.1
          libqt5-qtbase-debugsource-5.9.4-8.24.1
          libqt5-qtbase-devel-5.9.4-8.24.1
    
       - SUSE Linux Enterprise Server for SAP 15 (noarch):
    
          libQt5Core-private-headers-devel-5.9.4-8.24.1
          libQt5DBus-private-headers-devel-5.9.4-8.24.1
          libQt5Gui-private-headers-devel-5.9.4-8.24.1
          libQt5KmsSupport-private-headers-devel-5.9.4-8.24.1
          libQt5Network-private-headers-devel-5.9.4-8.24.1
          libQt5OpenGL-private-headers-devel-5.9.4-8.24.1
          libQt5PlatformSupport-private-headers-devel-5.9.4-8.24.1
          libQt5PrintSupport-private-headers-devel-5.9.4-8.24.1
          libQt5Sql-private-headers-devel-5.9.4-8.24.1
          libQt5Test-private-headers-devel-5.9.4-8.24.1
          libQt5Widgets-private-headers-devel-5.9.4-8.24.1
          libqt5-qtbase-private-headers-devel-5.9.4-8.24.1
    
       - SUSE Linux Enterprise Server 15-LTSS (aarch64 s390x):
    
          libQt5Concurrent-devel-5.9.4-8.24.1
          libQt5Concurrent5-5.9.4-8.24.1
          libQt5Concurrent5-debuginfo-5.9.4-8.24.1
          libQt5Core-devel-5.9.4-8.24.1
          libQt5Core5-5.9.4-8.24.1
          libQt5Core5-debuginfo-5.9.4-8.24.1
          libQt5DBus-devel-5.9.4-8.24.1
          libQt5DBus-devel-debuginfo-5.9.4-8.24.1
          libQt5DBus5-5.9.4-8.24.1
          libQt5DBus5-debuginfo-5.9.4-8.24.1
          libQt5Gui-devel-5.9.4-8.24.1
          libQt5Gui5-5.9.4-8.24.1
          libQt5Gui5-debuginfo-5.9.4-8.24.1
          libQt5KmsSupport-devel-static-5.9.4-8.24.1
          libQt5Network-devel-5.9.4-8.24.1
          libQt5Network5-5.9.4-8.24.1
          libQt5Network5-debuginfo-5.9.4-8.24.1
          libQt5OpenGL-devel-5.9.4-8.24.1
          libQt5OpenGL5-5.9.4-8.24.1
          libQt5OpenGL5-debuginfo-5.9.4-8.24.1
          libQt5PlatformHeaders-devel-5.9.4-8.24.1
          libQt5PlatformSupport-devel-static-5.9.4-8.24.1
          libQt5PrintSupport-devel-5.9.4-8.24.1
          libQt5PrintSupport5-5.9.4-8.24.1
          libQt5PrintSupport5-debuginfo-5.9.4-8.24.1
          libQt5Sql-devel-5.9.4-8.24.1
          libQt5Sql5-5.9.4-8.24.1
          libQt5Sql5-debuginfo-5.9.4-8.24.1
          libQt5Sql5-sqlite-5.9.4-8.24.1
          libQt5Sql5-sqlite-debuginfo-5.9.4-8.24.1
          libQt5Test-devel-5.9.4-8.24.1
          libQt5Test5-5.9.4-8.24.1
          libQt5Test5-debuginfo-5.9.4-8.24.1
          libQt5Widgets-devel-5.9.4-8.24.1
          libQt5Widgets5-5.9.4-8.24.1
          libQt5Widgets5-debuginfo-5.9.4-8.24.1
          libQt5Xml-devel-5.9.4-8.24.1
          libQt5Xml5-5.9.4-8.24.1
          libQt5Xml5-debuginfo-5.9.4-8.24.1
          libqt5-qtbase-common-devel-5.9.4-8.24.1
          libqt5-qtbase-common-devel-debuginfo-5.9.4-8.24.1
          libqt5-qtbase-debugsource-5.9.4-8.24.1
          libqt5-qtbase-devel-5.9.4-8.24.1
    
       - SUSE Linux Enterprise Server 15-LTSS (noarch):
    
          libQt5Core-private-headers-devel-5.9.4-8.24.1
          libQt5DBus-private-headers-devel-5.9.4-8.24.1
          libQt5Gui-private-headers-devel-5.9.4-8.24.1
          libQt5KmsSupport-private-headers-devel-5.9.4-8.24.1
          libQt5Network-private-headers-devel-5.9.4-8.24.1
          libQt5OpenGL-private-headers-devel-5.9.4-8.24.1
          libQt5PlatformSupport-private-headers-devel-5.9.4-8.24.1
          libQt5PrintSupport-private-headers-devel-5.9.4-8.24.1
          libQt5Sql-private-headers-devel-5.9.4-8.24.1
          libQt5Test-private-headers-devel-5.9.4-8.24.1
          libQt5Widgets-private-headers-devel-5.9.4-8.24.1
          libqt5-qtbase-private-headers-devel-5.9.4-8.24.1
    
       - SUSE Linux Enterprise High Performance Computing 15-LTSS (aarch64 x86_64):
    
          libQt5Concurrent-devel-5.9.4-8.24.1
          libQt5Concurrent5-5.9.4-8.24.1
          libQt5Concurrent5-debuginfo-5.9.4-8.24.1
          libQt5Core-devel-5.9.4-8.24.1
          libQt5Core5-5.9.4-8.24.1
          libQt5Core5-debuginfo-5.9.4-8.24.1
          libQt5DBus-devel-5.9.4-8.24.1
          libQt5DBus-devel-debuginfo-5.9.4-8.24.1
          libQt5DBus5-5.9.4-8.24.1
          libQt5DBus5-debuginfo-5.9.4-8.24.1
          libQt5Gui-devel-5.9.4-8.24.1
          libQt5Gui5-5.9.4-8.24.1
          libQt5Gui5-debuginfo-5.9.4-8.24.1
          libQt5KmsSupport-devel-static-5.9.4-8.24.1
          libQt5Network-devel-5.9.4-8.24.1
          libQt5Network5-5.9.4-8.24.1
          libQt5Network5-debuginfo-5.9.4-8.24.1
          libQt5OpenGL-devel-5.9.4-8.24.1
          libQt5OpenGL5-5.9.4-8.24.1
          libQt5OpenGL5-debuginfo-5.9.4-8.24.1
          libQt5PlatformHeaders-devel-5.9.4-8.24.1
          libQt5PlatformSupport-devel-static-5.9.4-8.24.1
          libQt5PrintSupport-devel-5.9.4-8.24.1
          libQt5PrintSupport5-5.9.4-8.24.1
          libQt5PrintSupport5-debuginfo-5.9.4-8.24.1
          libQt5Sql-devel-5.9.4-8.24.1
          libQt5Sql5-5.9.4-8.24.1
          libQt5Sql5-debuginfo-5.9.4-8.24.1
          libQt5Sql5-sqlite-5.9.4-8.24.1
          libQt5Sql5-sqlite-debuginfo-5.9.4-8.24.1
          libQt5Test-devel-5.9.4-8.24.1
          libQt5Test5-5.9.4-8.24.1
          libQt5Test5-debuginfo-5.9.4-8.24.1
          libQt5Widgets-devel-5.9.4-8.24.1
          libQt5Widgets5-5.9.4-8.24.1
          libQt5Widgets5-debuginfo-5.9.4-8.24.1
          libQt5Xml-devel-5.9.4-8.24.1
          libQt5Xml5-5.9.4-8.24.1
          libQt5Xml5-debuginfo-5.9.4-8.24.1
          libqt5-qtbase-common-devel-5.9.4-8.24.1
          libqt5-qtbase-common-devel-debuginfo-5.9.4-8.24.1
          libqt5-qtbase-debugsource-5.9.4-8.24.1
          libqt5-qtbase-devel-5.9.4-8.24.1
    
       - SUSE Linux Enterprise High Performance Computing 15-LTSS (noarch):
    
          libQt5Core-private-headers-devel-5.9.4-8.24.1
          libQt5DBus-private-headers-devel-5.9.4-8.24.1
          libQt5Gui-private-headers-devel-5.9.4-8.24.1
          libQt5KmsSupport-private-headers-devel-5.9.4-8.24.1
          libQt5Network-private-headers-devel-5.9.4-8.24.1
          libQt5OpenGL-private-headers-devel-5.9.4-8.24.1
          libQt5PlatformSupport-private-headers-devel-5.9.4-8.24.1
          libQt5PrintSupport-private-headers-devel-5.9.4-8.24.1
          libQt5Sql-private-headers-devel-5.9.4-8.24.1
          libQt5Test-private-headers-devel-5.9.4-8.24.1
          libQt5Widgets-private-headers-devel-5.9.4-8.24.1
          libqt5-qtbase-private-headers-devel-5.9.4-8.24.1
    
       - SUSE Linux Enterprise High Performance Computing 15-ESPOS (aarch64 x86_64):
    
          libQt5Concurrent-devel-5.9.4-8.24.1
          libQt5Concurrent5-5.9.4-8.24.1
          libQt5Concurrent5-debuginfo-5.9.4-8.24.1
          libQt5Core-devel-5.9.4-8.24.1
          libQt5Core5-5.9.4-8.24.1
          libQt5Core5-debuginfo-5.9.4-8.24.1
          libQt5DBus-devel-5.9.4-8.24.1
          libQt5DBus-devel-debuginfo-5.9.4-8.24.1
          libQt5DBus5-5.9.4-8.24.1
          libQt5DBus5-debuginfo-5.9.4-8.24.1
          libQt5Gui-devel-5.9.4-8.24.1
          libQt5Gui5-5.9.4-8.24.1
          libQt5Gui5-debuginfo-5.9.4-8.24.1
          libQt5KmsSupport-devel-static-5.9.4-8.24.1
          libQt5Network-devel-5.9.4-8.24.1
          libQt5Network5-5.9.4-8.24.1
          libQt5Network5-debuginfo-5.9.4-8.24.1
          libQt5OpenGL-devel-5.9.4-8.24.1
          libQt5OpenGL5-5.9.4-8.24.1
          libQt5OpenGL5-debuginfo-5.9.4-8.24.1
          libQt5PlatformHeaders-devel-5.9.4-8.24.1
          libQt5PlatformSupport-devel-static-5.9.4-8.24.1
          libQt5PrintSupport-devel-5.9.4-8.24.1
          libQt5PrintSupport5-5.9.4-8.24.1
          libQt5PrintSupport5-debuginfo-5.9.4-8.24.1
          libQt5Sql-devel-5.9.4-8.24.1
          libQt5Sql5-5.9.4-8.24.1
          libQt5Sql5-debuginfo-5.9.4-8.24.1
          libQt5Sql5-sqlite-5.9.4-8.24.1
          libQt5Sql5-sqlite-debuginfo-5.9.4-8.24.1
          libQt5Test-devel-5.9.4-8.24.1
          libQt5Test5-5.9.4-8.24.1
          libQt5Test5-debuginfo-5.9.4-8.24.1
          libQt5Widgets-devel-5.9.4-8.24.1
          libQt5Widgets5-5.9.4-8.24.1
          libQt5Widgets5-debuginfo-5.9.4-8.24.1
          libQt5Xml-devel-5.9.4-8.24.1
          libQt5Xml5-5.9.4-8.24.1
          libQt5Xml5-debuginfo-5.9.4-8.24.1
          libqt5-qtbase-common-devel-5.9.4-8.24.1
          libqt5-qtbase-common-devel-debuginfo-5.9.4-8.24.1
          libqt5-qtbase-debugsource-5.9.4-8.24.1
          libqt5-qtbase-devel-5.9.4-8.24.1
    
       - SUSE Linux Enterprise High Performance Computing 15-ESPOS (noarch):
    
          libQt5Core-private-headers-devel-5.9.4-8.24.1
          libQt5DBus-private-headers-devel-5.9.4-8.24.1
          libQt5Gui-private-headers-devel-5.9.4-8.24.1
          libQt5KmsSupport-private-headers-devel-5.9.4-8.24.1
          libQt5Network-private-headers-devel-5.9.4-8.24.1
          libQt5OpenGL-private-headers-devel-5.9.4-8.24.1
          libQt5PlatformSupport-private-headers-devel-5.9.4-8.24.1
          libQt5PrintSupport-private-headers-devel-5.9.4-8.24.1
          libQt5Sql-private-headers-devel-5.9.4-8.24.1
          libQt5Test-private-headers-devel-5.9.4-8.24.1
          libQt5Widgets-private-headers-devel-5.9.4-8.24.1
          libqt5-qtbase-private-headers-devel-5.9.4-8.24.1
    
    
    References:
    
       https://www.suse.com/security/cve/CVE-2020-17507.html
       https://bugzilla.suse.com/1172515
       https://bugzilla.suse.com/1176315
    
    _______________________________________________
    sle-security-updates mailing list
    This email address is being protected from spambots. You need JavaScript enabled to view it.
    https://lists.suse.com/mailman/listinfo/sle-security-updates
    

    LinuxSecurity Poll

    I agree with Linus Torvalds - Apple's new M1-powered laptops should run on Linux.

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 2 answer(s).
    /main-polls/45-i-agree-with-linus-torvalds-apple-s-new-m1-powered-laptops-should-run-on-linux?task=poll.vote&format=json
    45
    radio
    [{"id":"158","title":"True","votes":"8","type":"x","order":"1","pct":100,"resources":[]},{"id":"159","title":"False","votes":"0","type":"x","order":"2","pct":0,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350

    Please vote first in order to view vote results.


    VIEW MORE POLLS

    bottom 200

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.