SUSE Security Update: Security update for webkit2gtk3
______________________________________________________________________________

Announcement ID:    SUSE-SU-2021:3769-1
Rating:             important
References:         #1191937 #1192063 
Cross-References:   CVE-2021-30846 CVE-2021-30851 CVE-2021-42762
                   
CVSS scores:
                    CVE-2021-30846 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2021-30846 (SUSE): 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2021-30851 (NVD) : 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2021-30851 (SUSE): 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2021-42762 (NVD) : 5.3 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
                    CVE-2021-42762 (SUSE): 8.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Affected Products:
                    SUSE Linux Enterprise Server for SAP 15-SP1
                    SUSE Linux Enterprise Server for SAP 15
                    SUSE Linux Enterprise Server 15-SP1-LTSS
                    SUSE Linux Enterprise Server 15-SP1-BCL
                    SUSE Linux Enterprise Server 15-LTSS
                    SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS
                    SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS
                    SUSE Linux Enterprise High Performance Computing 15-LTSS
                    SUSE Linux Enterprise High Performance Computing 15-ESPOS
                    SUSE Enterprise Storage 6
                    SUSE CaaS Platform 4.0
______________________________________________________________________________

   An update that fixes three vulnerabilities is now available.

Description:

   This update for webkit2gtk3 fixes the following issues:

   - CVE-2021-30846: Fixed memory corruption issue that could lead to
     arbitrary code execution when processing maliciously crafted web content
     (bsc#1192063).
   - CVE-2021-30851: Fixed memory corruption vulnerability that could lead to
     arbitrary code execution when processing maliciously crafted web content
     (bsc#1192063).
   - CVE-2021-42762: Updated seccomp rules with latest changes from flatpak
     (bsc#1191937).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Server for SAP 15-SP1:

      zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP1-2021-3769=1

   - SUSE Linux Enterprise Server for SAP 15:

      zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2021-3769=1

   - SUSE Linux Enterprise Server 15-SP1-LTSS:

      zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-LTSS-2021-3769=1

   - SUSE Linux Enterprise Server 15-SP1-BCL:

      zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-BCL-2021-3769=1

   - SUSE Linux Enterprise Server 15-LTSS:

      zypper in -t patch SUSE-SLE-Product-SLES-15-2021-3769=1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-LTSS-2021-3769=1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-ESPOS-2021-3769=1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-2021-3769=1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-2021-3769=1

   - SUSE Enterprise Storage 6:

      zypper in -t patch SUSE-Storage-6-2021-3769=1

   - SUSE CaaS Platform 4.0:

      To install this update, use the SUSE CaaS Platform 'skuba' tool. It
      will inform you if it detects new updates and let you then trigger
      updating of the complete cluster in a controlled way.



Package List:

   - SUSE Linux Enterprise Server for SAP 15-SP1 (ppc64le x86_64):

      libjavascriptcoregtk-4_0-18-2.34.1-3.87.1
      libjavascriptcoregtk-4_0-18-debuginfo-2.34.1-3.87.1
      libwebkit2gtk-4_0-37-2.34.1-3.87.1
      libwebkit2gtk-4_0-37-debuginfo-2.34.1-3.87.1
      typelib-1_0-JavaScriptCore-4_0-2.34.1-3.87.1
      typelib-1_0-WebKit2-4_0-2.34.1-3.87.1
      typelib-1_0-WebKit2WebExtension-4_0-2.34.1-3.87.1
      webkit2gtk-4_0-injected-bundles-2.34.1-3.87.1
      webkit2gtk-4_0-injected-bundles-debuginfo-2.34.1-3.87.1
      webkit2gtk3-debugsource-2.34.1-3.87.1
      webkit2gtk3-devel-2.34.1-3.87.1

   - SUSE Linux Enterprise Server for SAP 15-SP1 (noarch):

      libwebkit2gtk3-lang-2.34.1-3.87.1

   - SUSE Linux Enterprise Server for SAP 15 (ppc64le x86_64):

      libjavascriptcoregtk-4_0-18-2.34.1-3.87.1
      libjavascriptcoregtk-4_0-18-debuginfo-2.34.1-3.87.1
      libwebkit2gtk-4_0-37-2.34.1-3.87.1
      libwebkit2gtk-4_0-37-debuginfo-2.34.1-3.87.1
      typelib-1_0-JavaScriptCore-4_0-2.34.1-3.87.1
      typelib-1_0-WebKit2-4_0-2.34.1-3.87.1
      typelib-1_0-WebKit2WebExtension-4_0-2.34.1-3.87.1
      webkit2gtk-4_0-injected-bundles-2.34.1-3.87.1
      webkit2gtk-4_0-injected-bundles-debuginfo-2.34.1-3.87.1
      webkit2gtk3-debugsource-2.34.1-3.87.1
      webkit2gtk3-devel-2.34.1-3.87.1

   - SUSE Linux Enterprise Server for SAP 15 (noarch):

      libwebkit2gtk3-lang-2.34.1-3.87.1

   - SUSE Linux Enterprise Server 15-SP1-LTSS (aarch64 ppc64le s390x x86_64):

      libjavascriptcoregtk-4_0-18-2.34.1-3.87.1
      libjavascriptcoregtk-4_0-18-debuginfo-2.34.1-3.87.1
      libwebkit2gtk-4_0-37-2.34.1-3.87.1
      libwebkit2gtk-4_0-37-debuginfo-2.34.1-3.87.1
      typelib-1_0-JavaScriptCore-4_0-2.34.1-3.87.1
      typelib-1_0-WebKit2-4_0-2.34.1-3.87.1
      typelib-1_0-WebKit2WebExtension-4_0-2.34.1-3.87.1
      webkit2gtk-4_0-injected-bundles-2.34.1-3.87.1
      webkit2gtk-4_0-injected-bundles-debuginfo-2.34.1-3.87.1
      webkit2gtk3-debugsource-2.34.1-3.87.1
      webkit2gtk3-devel-2.34.1-3.87.1

   - SUSE Linux Enterprise Server 15-SP1-LTSS (noarch):

      libwebkit2gtk3-lang-2.34.1-3.87.1

   - SUSE Linux Enterprise Server 15-SP1-BCL (noarch):

      libwebkit2gtk3-lang-2.34.1-3.87.1

   - SUSE Linux Enterprise Server 15-SP1-BCL (x86_64):

      libjavascriptcoregtk-4_0-18-2.34.1-3.87.1
      libjavascriptcoregtk-4_0-18-debuginfo-2.34.1-3.87.1
      libwebkit2gtk-4_0-37-2.34.1-3.87.1
      libwebkit2gtk-4_0-37-debuginfo-2.34.1-3.87.1
      typelib-1_0-JavaScriptCore-4_0-2.34.1-3.87.1
      typelib-1_0-WebKit2-4_0-2.34.1-3.87.1
      typelib-1_0-WebKit2WebExtension-4_0-2.34.1-3.87.1
      webkit2gtk-4_0-injected-bundles-2.34.1-3.87.1
      webkit2gtk-4_0-injected-bundles-debuginfo-2.34.1-3.87.1
      webkit2gtk3-debugsource-2.34.1-3.87.1
      webkit2gtk3-devel-2.34.1-3.87.1

   - SUSE Linux Enterprise Server 15-LTSS (aarch64 s390x):

      libjavascriptcoregtk-4_0-18-2.34.1-3.87.1
      libjavascriptcoregtk-4_0-18-debuginfo-2.34.1-3.87.1
      libwebkit2gtk-4_0-37-2.34.1-3.87.1
      libwebkit2gtk-4_0-37-debuginfo-2.34.1-3.87.1
      typelib-1_0-JavaScriptCore-4_0-2.34.1-3.87.1
      typelib-1_0-WebKit2-4_0-2.34.1-3.87.1
      typelib-1_0-WebKit2WebExtension-4_0-2.34.1-3.87.1
      webkit2gtk-4_0-injected-bundles-2.34.1-3.87.1
      webkit2gtk-4_0-injected-bundles-debuginfo-2.34.1-3.87.1
      webkit2gtk3-debugsource-2.34.1-3.87.1
      webkit2gtk3-devel-2.34.1-3.87.1

   - SUSE Linux Enterprise Server 15-LTSS (noarch):

      libwebkit2gtk3-lang-2.34.1-3.87.1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (aarch64 x86_64):

      libjavascriptcoregtk-4_0-18-2.34.1-3.87.1
      libjavascriptcoregtk-4_0-18-debuginfo-2.34.1-3.87.1
      libwebkit2gtk-4_0-37-2.34.1-3.87.1
      libwebkit2gtk-4_0-37-debuginfo-2.34.1-3.87.1
      typelib-1_0-JavaScriptCore-4_0-2.34.1-3.87.1
      typelib-1_0-WebKit2-4_0-2.34.1-3.87.1
      typelib-1_0-WebKit2WebExtension-4_0-2.34.1-3.87.1
      webkit2gtk-4_0-injected-bundles-2.34.1-3.87.1
      webkit2gtk-4_0-injected-bundles-debuginfo-2.34.1-3.87.1
      webkit2gtk3-debugsource-2.34.1-3.87.1
      webkit2gtk3-devel-2.34.1-3.87.1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (noarch):

      libwebkit2gtk3-lang-2.34.1-3.87.1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (aarch64 x86_64):

      libjavascriptcoregtk-4_0-18-2.34.1-3.87.1
      libjavascriptcoregtk-4_0-18-debuginfo-2.34.1-3.87.1
      libwebkit2gtk-4_0-37-2.34.1-3.87.1
      libwebkit2gtk-4_0-37-debuginfo-2.34.1-3.87.1
      typelib-1_0-JavaScriptCore-4_0-2.34.1-3.87.1
      typelib-1_0-WebKit2-4_0-2.34.1-3.87.1
      typelib-1_0-WebKit2WebExtension-4_0-2.34.1-3.87.1
      webkit2gtk-4_0-injected-bundles-2.34.1-3.87.1
      webkit2gtk-4_0-injected-bundles-debuginfo-2.34.1-3.87.1
      webkit2gtk3-debugsource-2.34.1-3.87.1
      webkit2gtk3-devel-2.34.1-3.87.1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (noarch):

      libwebkit2gtk3-lang-2.34.1-3.87.1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS (aarch64 x86_64):

      libjavascriptcoregtk-4_0-18-2.34.1-3.87.1
      libjavascriptcoregtk-4_0-18-debuginfo-2.34.1-3.87.1
      libwebkit2gtk-4_0-37-2.34.1-3.87.1
      libwebkit2gtk-4_0-37-debuginfo-2.34.1-3.87.1
      typelib-1_0-JavaScriptCore-4_0-2.34.1-3.87.1
      typelib-1_0-WebKit2-4_0-2.34.1-3.87.1
      typelib-1_0-WebKit2WebExtension-4_0-2.34.1-3.87.1
      webkit2gtk-4_0-injected-bundles-2.34.1-3.87.1
      webkit2gtk-4_0-injected-bundles-debuginfo-2.34.1-3.87.1
      webkit2gtk3-debugsource-2.34.1-3.87.1
      webkit2gtk3-devel-2.34.1-3.87.1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS (noarch):

      libwebkit2gtk3-lang-2.34.1-3.87.1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS (aarch64 x86_64):

      libjavascriptcoregtk-4_0-18-2.34.1-3.87.1
      libjavascriptcoregtk-4_0-18-debuginfo-2.34.1-3.87.1
      libwebkit2gtk-4_0-37-2.34.1-3.87.1
      libwebkit2gtk-4_0-37-debuginfo-2.34.1-3.87.1
      typelib-1_0-JavaScriptCore-4_0-2.34.1-3.87.1
      typelib-1_0-WebKit2-4_0-2.34.1-3.87.1
      typelib-1_0-WebKit2WebExtension-4_0-2.34.1-3.87.1
      webkit2gtk-4_0-injected-bundles-2.34.1-3.87.1
      webkit2gtk-4_0-injected-bundles-debuginfo-2.34.1-3.87.1
      webkit2gtk3-debugsource-2.34.1-3.87.1
      webkit2gtk3-devel-2.34.1-3.87.1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS (noarch):

      libwebkit2gtk3-lang-2.34.1-3.87.1

   - SUSE Enterprise Storage 6 (aarch64 x86_64):

      libjavascriptcoregtk-4_0-18-2.34.1-3.87.1
      libjavascriptcoregtk-4_0-18-debuginfo-2.34.1-3.87.1
      libwebkit2gtk-4_0-37-2.34.1-3.87.1
      libwebkit2gtk-4_0-37-debuginfo-2.34.1-3.87.1
      typelib-1_0-JavaScriptCore-4_0-2.34.1-3.87.1
      typelib-1_0-WebKit2-4_0-2.34.1-3.87.1
      typelib-1_0-WebKit2WebExtension-4_0-2.34.1-3.87.1
      webkit2gtk-4_0-injected-bundles-2.34.1-3.87.1
      webkit2gtk-4_0-injected-bundles-debuginfo-2.34.1-3.87.1
      webkit2gtk3-debugsource-2.34.1-3.87.1
      webkit2gtk3-devel-2.34.1-3.87.1

   - SUSE Enterprise Storage 6 (noarch):

      libwebkit2gtk3-lang-2.34.1-3.87.1

   - SUSE CaaS Platform 4.0 (noarch):

      libwebkit2gtk3-lang-2.34.1-3.87.1

   - SUSE CaaS Platform 4.0 (x86_64):

      libjavascriptcoregtk-4_0-18-2.34.1-3.87.1
      libjavascriptcoregtk-4_0-18-debuginfo-2.34.1-3.87.1
      libwebkit2gtk-4_0-37-2.34.1-3.87.1
      libwebkit2gtk-4_0-37-debuginfo-2.34.1-3.87.1
      typelib-1_0-JavaScriptCore-4_0-2.34.1-3.87.1
      typelib-1_0-WebKit2-4_0-2.34.1-3.87.1
      typelib-1_0-WebKit2WebExtension-4_0-2.34.1-3.87.1
      webkit2gtk-4_0-injected-bundles-2.34.1-3.87.1
      webkit2gtk-4_0-injected-bundles-debuginfo-2.34.1-3.87.1
      webkit2gtk3-debugsource-2.34.1-3.87.1
      webkit2gtk3-devel-2.34.1-3.87.1


References:

   https://www.suse.com/security/cve/CVE-2021-30846.html
   https://www.suse.com/security/cve/CVE-2021-30851.html
   https://www.suse.com/security/cve/CVE-2021-42762.html
   https://bugzilla.suse.com/1191937
   https://bugzilla.suse.com/1192063