SUSE Security Update: Security update for aaa_base
______________________________________________________________________________

Announcement ID:    SUSE-SU-2021:3899-1
Rating:             moderate
References:         #1162581 #1174504 #1191563 #1192248 
Affected Products:
                    SUSE MicroOS 5.1
                    SUSE MicroOS 5.0
                    SUSE Linux Enterprise Server for SAP 15-SP1
                    SUSE Linux Enterprise Server for SAP 15
                    SUSE Linux Enterprise Server 15-SP1-LTSS
                    SUSE Linux Enterprise Server 15-SP1-BCL
                    SUSE Linux Enterprise Server 15-LTSS
                    SUSE Linux Enterprise Module for Development Tools 15-SP3
                    SUSE Linux Enterprise Module for Development Tools 15-SP2
                    SUSE Linux Enterprise Module for Basesystem 15-SP3
                    SUSE Linux Enterprise Module for Basesystem 15-SP2
                    SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS
                    SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS
                    SUSE Linux Enterprise High Performance Computing 15-LTSS
                    SUSE Linux Enterprise High Performance Computing 15-ESPOS
                    SUSE Enterprise Storage 6
                    SUSE CaaS Platform 4.0
______________________________________________________________________________

   An update that contains security fixes can now be installed.

Description:

   This update for aaa_base fixes the following issues:

   - Allowed ping and ICMP commands without CAP_NET_RAW (bsc#1174504).
   - Add $HOME/.local/bin to PATH, if it exists (bsc#1192248).
   - Fixed get_kernel_version.c to work also for recent kernels on the s390/X
     platform (bsc#1191563).
   - Support xz compressed kernel (bsc#1162581)


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE MicroOS 5.1:

      zypper in -t patch SUSE-SUSE-MicroOS-5.1-2021-3899=1

   - SUSE MicroOS 5.0:

      zypper in -t patch SUSE-SUSE-MicroOS-5.0-2021-3899=1

   - SUSE Linux Enterprise Server for SAP 15-SP1:

      zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP1-2021-3899=1

   - SUSE Linux Enterprise Server for SAP 15:

      zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2021-3899=1

   - SUSE Linux Enterprise Server 15-SP1-LTSS:

      zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-LTSS-2021-3899=1

   - SUSE Linux Enterprise Server 15-SP1-BCL:

      zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-BCL-2021-3899=1

   - SUSE Linux Enterprise Server 15-LTSS:

      zypper in -t patch SUSE-SLE-Product-SLES-15-2021-3899=1

   - SUSE Linux Enterprise Module for Development Tools 15-SP3:

      zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP3-2021-3899=1

   - SUSE Linux Enterprise Module for Development Tools 15-SP2:

      zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP2-2021-3899=1

   - SUSE Linux Enterprise Module for Basesystem 15-SP3:

      zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP3-2021-3899=1

   - SUSE Linux Enterprise Module for Basesystem 15-SP2:

      zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP2-2021-3899=1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-LTSS-2021-3899=1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-ESPOS-2021-3899=1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-2021-3899=1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-2021-3899=1

   - SUSE Enterprise Storage 6:

      zypper in -t patch SUSE-Storage-6-2021-3899=1

   - SUSE CaaS Platform 4.0:

      To install this update, use the SUSE CaaS Platform 'skuba' tool. It
      will inform you if it detects new updates and let you then trigger
      updating of the complete cluster in a controlled way.



Package List:

   - SUSE MicroOS 5.1 (aarch64 s390x x86_64):

      aaa_base-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debuginfo-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debugsource-84.87+git20180409.04c9dae-3.52.1

   - SUSE MicroOS 5.0 (aarch64 x86_64):

      aaa_base-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debuginfo-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debugsource-84.87+git20180409.04c9dae-3.52.1

   - SUSE Linux Enterprise Server for SAP 15-SP1 (ppc64le x86_64):

      aaa_base-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debuginfo-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debugsource-84.87+git20180409.04c9dae-3.52.1
      aaa_base-extras-84.87+git20180409.04c9dae-3.52.1
      aaa_base-malloccheck-84.87+git20180409.04c9dae-3.52.1

   - SUSE Linux Enterprise Server for SAP 15 (ppc64le x86_64):

      aaa_base-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debuginfo-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debugsource-84.87+git20180409.04c9dae-3.52.1
      aaa_base-extras-84.87+git20180409.04c9dae-3.52.1
      aaa_base-malloccheck-84.87+git20180409.04c9dae-3.52.1

   - SUSE Linux Enterprise Server 15-SP1-LTSS (aarch64 ppc64le s390x x86_64):

      aaa_base-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debuginfo-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debugsource-84.87+git20180409.04c9dae-3.52.1
      aaa_base-extras-84.87+git20180409.04c9dae-3.52.1
      aaa_base-malloccheck-84.87+git20180409.04c9dae-3.52.1

   - SUSE Linux Enterprise Server 15-SP1-BCL (x86_64):

      aaa_base-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debuginfo-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debugsource-84.87+git20180409.04c9dae-3.52.1
      aaa_base-extras-84.87+git20180409.04c9dae-3.52.1
      aaa_base-malloccheck-84.87+git20180409.04c9dae-3.52.1

   - SUSE Linux Enterprise Server 15-LTSS (aarch64 s390x):

      aaa_base-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debuginfo-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debugsource-84.87+git20180409.04c9dae-3.52.1
      aaa_base-extras-84.87+git20180409.04c9dae-3.52.1
      aaa_base-malloccheck-84.87+git20180409.04c9dae-3.52.1

   - SUSE Linux Enterprise Module for Development Tools 15-SP3 (aarch64 ppc64le s390x x86_64):

      aaa_base-debuginfo-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debugsource-84.87+git20180409.04c9dae-3.52.1
      aaa_base-malloccheck-84.87+git20180409.04c9dae-3.52.1

   - SUSE Linux Enterprise Module for Development Tools 15-SP2 (aarch64 ppc64le s390x x86_64):

      aaa_base-debuginfo-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debugsource-84.87+git20180409.04c9dae-3.52.1
      aaa_base-malloccheck-84.87+git20180409.04c9dae-3.52.1

   - SUSE Linux Enterprise Module for Basesystem 15-SP3 (aarch64 ppc64le s390x x86_64):

      aaa_base-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debuginfo-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debugsource-84.87+git20180409.04c9dae-3.52.1
      aaa_base-extras-84.87+git20180409.04c9dae-3.52.1

   - SUSE Linux Enterprise Module for Basesystem 15-SP2 (aarch64 ppc64le s390x x86_64):

      aaa_base-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debuginfo-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debugsource-84.87+git20180409.04c9dae-3.52.1
      aaa_base-extras-84.87+git20180409.04c9dae-3.52.1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (aarch64 x86_64):

      aaa_base-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debuginfo-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debugsource-84.87+git20180409.04c9dae-3.52.1
      aaa_base-extras-84.87+git20180409.04c9dae-3.52.1
      aaa_base-malloccheck-84.87+git20180409.04c9dae-3.52.1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (aarch64 x86_64):

      aaa_base-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debuginfo-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debugsource-84.87+git20180409.04c9dae-3.52.1
      aaa_base-extras-84.87+git20180409.04c9dae-3.52.1
      aaa_base-malloccheck-84.87+git20180409.04c9dae-3.52.1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS (aarch64 x86_64):

      aaa_base-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debuginfo-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debugsource-84.87+git20180409.04c9dae-3.52.1
      aaa_base-extras-84.87+git20180409.04c9dae-3.52.1
      aaa_base-malloccheck-84.87+git20180409.04c9dae-3.52.1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS (aarch64 x86_64):

      aaa_base-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debuginfo-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debugsource-84.87+git20180409.04c9dae-3.52.1
      aaa_base-extras-84.87+git20180409.04c9dae-3.52.1
      aaa_base-malloccheck-84.87+git20180409.04c9dae-3.52.1

   - SUSE Enterprise Storage 6 (aarch64 x86_64):

      aaa_base-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debuginfo-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debugsource-84.87+git20180409.04c9dae-3.52.1
      aaa_base-extras-84.87+git20180409.04c9dae-3.52.1
      aaa_base-malloccheck-84.87+git20180409.04c9dae-3.52.1

   - SUSE CaaS Platform 4.0 (x86_64):

      aaa_base-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debuginfo-84.87+git20180409.04c9dae-3.52.1
      aaa_base-debugsource-84.87+git20180409.04c9dae-3.52.1
      aaa_base-extras-84.87+git20180409.04c9dae-3.52.1
      aaa_base-malloccheck-84.87+git20180409.04c9dae-3.52.1


References:

   https://bugzilla.suse.com/1162581
   https://bugzilla.suse.com/1174504
   https://bugzilla.suse.com/1191563
   https://bugzilla.suse.com/1192248