SUSE Security Update: Security update for openssh
______________________________________________________________________________

Announcement ID:    SUSE-SU-2021:3947-1
Rating:             important
References:         #1190975 
Cross-References:   CVE-2021-41617
CVSS scores:
                    CVE-2021-41617 (NVD) : 7 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
                    CVE-2021-41617 (SUSE): 7 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Affected Products:
                    SUSE Linux Enterprise Server for SAP 15-SP1
                    SUSE Linux Enterprise Server 15-SP1-LTSS
                    SUSE Linux Enterprise Server 15-SP1-BCL
                    SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS
                    SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS
                    SUSE Enterprise Storage 6
                    SUSE CaaS Platform 4.0
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for openssh fixes the following issues:

   - CVE-2021-41617: Fixed privilege escalation when
     AuthorizedKeysCommand/AuthorizedPrincipalsCommand are configured
     (bsc#1190975).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Server for SAP 15-SP1:

      zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP1-2021-3947=1

   - SUSE Linux Enterprise Server 15-SP1-LTSS:

      zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-LTSS-2021-3947=1

   - SUSE Linux Enterprise Server 15-SP1-BCL:

      zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-BCL-2021-3947=1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-LTSS-2021-3947=1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-ESPOS-2021-3947=1

   - SUSE Enterprise Storage 6:

      zypper in -t patch SUSE-Storage-6-2021-3947=1

   - SUSE CaaS Platform 4.0:

      To install this update, use the SUSE CaaS Platform 'skuba' tool. It
      will inform you if it detects new updates and let you then trigger
      updating of the complete cluster in a controlled way.



Package List:

   - SUSE Linux Enterprise Server for SAP 15-SP1 (ppc64le x86_64):

      openssh-7.9p1-6.28.1
      openssh-askpass-gnome-7.9p1-6.28.1
      openssh-askpass-gnome-debuginfo-7.9p1-6.28.1
      openssh-askpass-gnome-debugsource-7.9p1-6.28.1
      openssh-debuginfo-7.9p1-6.28.1
      openssh-debugsource-7.9p1-6.28.1
      openssh-fips-7.9p1-6.28.1
      openssh-helpers-7.9p1-6.28.1
      openssh-helpers-debuginfo-7.9p1-6.28.1

   - SUSE Linux Enterprise Server 15-SP1-LTSS (aarch64 ppc64le s390x x86_64):

      openssh-7.9p1-6.28.1
      openssh-askpass-gnome-7.9p1-6.28.1
      openssh-askpass-gnome-debuginfo-7.9p1-6.28.1
      openssh-askpass-gnome-debugsource-7.9p1-6.28.1
      openssh-debuginfo-7.9p1-6.28.1
      openssh-debugsource-7.9p1-6.28.1
      openssh-fips-7.9p1-6.28.1
      openssh-helpers-7.9p1-6.28.1
      openssh-helpers-debuginfo-7.9p1-6.28.1

   - SUSE Linux Enterprise Server 15-SP1-BCL (x86_64):

      openssh-7.9p1-6.28.1
      openssh-askpass-gnome-7.9p1-6.28.1
      openssh-askpass-gnome-debuginfo-7.9p1-6.28.1
      openssh-askpass-gnome-debugsource-7.9p1-6.28.1
      openssh-debuginfo-7.9p1-6.28.1
      openssh-debugsource-7.9p1-6.28.1
      openssh-fips-7.9p1-6.28.1
      openssh-helpers-7.9p1-6.28.1
      openssh-helpers-debuginfo-7.9p1-6.28.1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (aarch64 x86_64):

      openssh-7.9p1-6.28.1
      openssh-askpass-gnome-7.9p1-6.28.1
      openssh-askpass-gnome-debuginfo-7.9p1-6.28.1
      openssh-askpass-gnome-debugsource-7.9p1-6.28.1
      openssh-debuginfo-7.9p1-6.28.1
      openssh-debugsource-7.9p1-6.28.1
      openssh-fips-7.9p1-6.28.1
      openssh-helpers-7.9p1-6.28.1
      openssh-helpers-debuginfo-7.9p1-6.28.1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (aarch64 x86_64):

      openssh-7.9p1-6.28.1
      openssh-askpass-gnome-7.9p1-6.28.1
      openssh-askpass-gnome-debuginfo-7.9p1-6.28.1
      openssh-askpass-gnome-debugsource-7.9p1-6.28.1
      openssh-debuginfo-7.9p1-6.28.1
      openssh-debugsource-7.9p1-6.28.1
      openssh-fips-7.9p1-6.28.1
      openssh-helpers-7.9p1-6.28.1
      openssh-helpers-debuginfo-7.9p1-6.28.1

   - SUSE Enterprise Storage 6 (aarch64 x86_64):

      openssh-7.9p1-6.28.1
      openssh-askpass-gnome-7.9p1-6.28.1
      openssh-askpass-gnome-debuginfo-7.9p1-6.28.1
      openssh-askpass-gnome-debugsource-7.9p1-6.28.1
      openssh-debuginfo-7.9p1-6.28.1
      openssh-debugsource-7.9p1-6.28.1
      openssh-fips-7.9p1-6.28.1
      openssh-helpers-7.9p1-6.28.1
      openssh-helpers-debuginfo-7.9p1-6.28.1

   - SUSE CaaS Platform 4.0 (x86_64):

      openssh-7.9p1-6.28.1
      openssh-askpass-gnome-7.9p1-6.28.1
      openssh-askpass-gnome-debuginfo-7.9p1-6.28.1
      openssh-askpass-gnome-debugsource-7.9p1-6.28.1
      openssh-debuginfo-7.9p1-6.28.1
      openssh-debugsource-7.9p1-6.28.1
      openssh-fips-7.9p1-6.28.1
      openssh-helpers-7.9p1-6.28.1
      openssh-helpers-debuginfo-7.9p1-6.28.1


References:

   https://www.suse.com/security/cve/CVE-2021-41617.html
   https://bugzilla.suse.com/1190975