SUSE Security Update: Security update for openssh
______________________________________________________________________________

Announcement ID:    SUSE-SU-2021:4153-1
Rating:             important
References:         #1183137 
Cross-References:   CVE-2021-28041
CVSS scores:
                    CVE-2021-28041 (NVD) : 7.1 CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
                    CVE-2021-28041 (SUSE): 7.1 CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H

Affected Products:
                    SUSE MicroOS 5.1
                    SUSE Linux Enterprise Module for Server Applications 15-SP3
                    SUSE Linux Enterprise Module for Desktop Applications 15-SP3
                    SUSE Linux Enterprise Module for Basesystem 15-SP3
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for openssh fixes the following issues:

   - CVE-2021-28041: Fixed double free in ssh-agent (bsc#1183137).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE MicroOS 5.1:

      zypper in -t patch SUSE-SUSE-MicroOS-5.1-2021-4153=1

   - SUSE Linux Enterprise Module for Server Applications 15-SP3:

      zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP3-2021-4153=1

   - SUSE Linux Enterprise Module for Desktop Applications 15-SP3:

      zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP3-2021-4153=1

   - SUSE Linux Enterprise Module for Basesystem 15-SP3:

      zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP3-2021-4153=1



Package List:

   - SUSE MicroOS 5.1 (aarch64 s390x x86_64):

      openssh-8.4p1-3.9.1
      openssh-clients-8.4p1-3.9.1
      openssh-clients-debuginfo-8.4p1-3.9.1
      openssh-common-8.4p1-3.9.1
      openssh-common-debuginfo-8.4p1-3.9.1
      openssh-debuginfo-8.4p1-3.9.1
      openssh-debugsource-8.4p1-3.9.1
      openssh-fips-8.4p1-3.9.1
      openssh-server-8.4p1-3.9.1
      openssh-server-debuginfo-8.4p1-3.9.1

   - SUSE Linux Enterprise Module for Server Applications 15-SP3 (aarch64 ppc64le s390x x86_64):

      openssh-debuginfo-8.4p1-3.9.1
      openssh-debugsource-8.4p1-3.9.1
      openssh-fips-8.4p1-3.9.1

   - SUSE Linux Enterprise Module for Desktop Applications 15-SP3 (aarch64 ppc64le s390x x86_64):

      openssh-askpass-gnome-8.4p1-3.9.1
      openssh-askpass-gnome-debuginfo-8.4p1-3.9.1
      openssh-askpass-gnome-debugsource-8.4p1-3.9.1

   - SUSE Linux Enterprise Module for Basesystem 15-SP3 (aarch64 ppc64le s390x x86_64):

      openssh-8.4p1-3.9.1
      openssh-clients-8.4p1-3.9.1
      openssh-clients-debuginfo-8.4p1-3.9.1
      openssh-common-8.4p1-3.9.1
      openssh-common-debuginfo-8.4p1-3.9.1
      openssh-debuginfo-8.4p1-3.9.1
      openssh-debugsource-8.4p1-3.9.1
      openssh-fips-8.4p1-3.9.1
      openssh-helpers-8.4p1-3.9.1
      openssh-helpers-debuginfo-8.4p1-3.9.1
      openssh-server-8.4p1-3.9.1
      openssh-server-debuginfo-8.4p1-3.9.1


References:

   https://www.suse.com/security/cve/CVE-2021-28041.html
   https://bugzilla.suse.com/1183137