SUSE Security Update: Security update for logstash, elasticsearch, kafka, zookeeper, openstack-monasca-agent, openstack-monasca-persister-java, openstack-monasca-thresh
______________________________________________________________________________

Announcement ID:    SUSE-SU-2021:4160-1
Rating:             important
References:         #1193662 
Cross-References:   CVE-2021-4104
CVSS scores:
                    CVE-2021-4104 (SUSE): 6.4 CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H

Affected Products:
                    SUSE OpenStack Cloud Crowbar 9
                    SUSE OpenStack Cloud 9
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for logstash, elasticsearch, kafka, zookeeper,
   openstack-monasca-agent, openstack-monasca-persister-java,
   openstack-monasca-thresh fixes the following issues:

   Fixed vulnerability related to log4j version 1.2.x:

   - CVE-2021-4104: Fixed remote code execution through the JMS API via the
     ldap JNDI parser (bsc#1193662)


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE OpenStack Cloud Crowbar 9:

      zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2021-4160=1

   - SUSE OpenStack Cloud 9:

      zypper in -t patch SUSE-OpenStack-Cloud-9-2021-4160=1



Package List:

   - SUSE OpenStack Cloud Crowbar 9 (noarch):

      elasticsearch-2.4.2-6.3.1
      openstack-monasca-agent-2.8.2~dev5-3.12.1
      openstack-monasca-persister-java-1.12.1~dev9-12.2
      openstack-monasca-thresh-2.1.1-5.3.1
      python-monasca-agent-2.8.2~dev5-3.12.1
      zookeeper-server-3.4.13-3.6.1

   - SUSE OpenStack Cloud Crowbar 9 (x86_64):

      kafka-0.10.2.2-3.2.1
      logstash-2.4.1-7.3.1

   - SUSE OpenStack Cloud 9 (x86_64):

      kafka-0.10.2.2-3.2.1
      logstash-2.4.1-7.3.1

   - SUSE OpenStack Cloud 9 (noarch):

      elasticsearch-2.4.2-6.3.1
      openstack-monasca-agent-2.8.2~dev5-3.12.1
      openstack-monasca-persister-java-1.12.1~dev9-12.2
      openstack-monasca-thresh-2.1.1-5.3.1
      python-monasca-agent-2.8.2~dev5-3.12.1
      venv-openstack-barbican-x86_64-7.0.1~dev24-3.27.1
      venv-openstack-cinder-x86_64-13.0.10~dev23-3.30.1
      venv-openstack-designate-x86_64-7.0.2~dev2-3.27.1
      venv-openstack-glance-x86_64-17.0.1~dev30-3.25.1
      venv-openstack-heat-x86_64-11.0.4~dev4-3.27.1
      venv-openstack-horizon-x86_64-14.1.1~dev11-4.31.1
      venv-openstack-ironic-x86_64-11.1.5~dev17-4.25.1
      venv-openstack-keystone-x86_64-14.2.1~dev7-3.28.1
      venv-openstack-magnum-x86_64-7.2.1~dev1-4.27.1
      venv-openstack-manila-x86_64-7.4.2~dev60-3.33.1
      venv-openstack-monasca-ceilometer-x86_64-1.8.2~dev3-3.27.1
      venv-openstack-monasca-x86_64-2.7.1~dev10-3.27.1
      venv-openstack-neutron-x86_64-13.0.8~dev164-6.31.1
      venv-openstack-nova-x86_64-18.3.1~dev91-3.31.1
      venv-openstack-octavia-x86_64-3.2.3~dev7-4.27.1
      venv-openstack-sahara-x86_64-9.0.2~dev15-3.27.1
      venv-openstack-swift-x86_64-2.19.2~dev48-2.22.1
      zookeeper-server-3.4.13-3.6.1


References:

   https://www.suse.com/security/cve/CVE-2021-4104.html
   https://bugzilla.suse.com/1193662