SUSE Security Update: Security update for libsndfile
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:0052-1
Rating:             important
References:         #1194006 
Cross-References:   CVE-2021-4156
CVSS scores:
                    CVE-2021-4156 (SUSE): 6.1 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:H

Affected Products:
                    SUSE Manager Server 4.1
                    SUSE Manager Retail Branch Server 4.1
                    SUSE Manager Proxy 4.1
                    SUSE Linux Enterprise Server for SAP 15-SP2
                    SUSE Linux Enterprise Server for SAP 15-SP1
                    SUSE Linux Enterprise Server for SAP 15
                    SUSE Linux Enterprise Server 15-SP2-LTSS
                    SUSE Linux Enterprise Server 15-SP2-BCL
                    SUSE Linux Enterprise Server 15-SP1-LTSS
                    SUSE Linux Enterprise Server 15-SP1-BCL
                    SUSE Linux Enterprise Server 15-LTSS
                    SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3
                    SUSE Linux Enterprise Module for Basesystem 15-SP3
                    SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS
                    SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS
                    SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS
                    SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS
                    SUSE Linux Enterprise High Performance Computing 15-LTSS
                    SUSE Linux Enterprise High Performance Computing 15-ESPOS
                    SUSE Enterprise Storage 7
                    SUSE Enterprise Storage 6
                    SUSE CaaS Platform 4.5
                    SUSE CaaS Platform 4.0
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for libsndfile fixes the following issues:

   - CVE-2021-4156: Fixed heap buffer overflow in flac_buffer_copy that could
     potentially lead to heap exploitation (bsc#1194006).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Manager Server 4.1:

      zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Server-4.1-2022-52=1

   - SUSE Manager Retail Branch Server 4.1:

      zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.1-2022-52=1

   - SUSE Manager Proxy 4.1:

      zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Proxy-4.1-2022-52=1

   - SUSE Linux Enterprise Server for SAP 15-SP2:

      zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP2-2022-52=1

   - SUSE Linux Enterprise Server for SAP 15-SP1:

      zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP1-2022-52=1

   - SUSE Linux Enterprise Server for SAP 15:

      zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2022-52=1

   - SUSE Linux Enterprise Server 15-SP2-LTSS:

      zypper in -t patch SUSE-SLE-Product-SLES-15-SP2-LTSS-2022-52=1

   - SUSE Linux Enterprise Server 15-SP2-BCL:

      zypper in -t patch SUSE-SLE-Product-SLES-15-SP2-BCL-2022-52=1

   - SUSE Linux Enterprise Server 15-SP1-LTSS:

      zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-LTSS-2022-52=1

   - SUSE Linux Enterprise Server 15-SP1-BCL:

      zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-BCL-2022-52=1

   - SUSE Linux Enterprise Server 15-LTSS:

      zypper in -t patch SUSE-SLE-Product-SLES-15-2022-52=1

   - SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3:

      zypper in -t patch SUSE-SLE-Module-Packagehub-Subpackages-15-SP3-2022-52=1

   - SUSE Linux Enterprise Module for Basesystem 15-SP3:

      zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP3-2022-52=1

   - SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-SP2-LTSS-2022-52=1

   - SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-SP2-ESPOS-2022-52=1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-LTSS-2022-52=1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-ESPOS-2022-52=1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-2022-52=1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-2022-52=1

   - SUSE Enterprise Storage 7:

      zypper in -t patch SUSE-Storage-7-2022-52=1

   - SUSE Enterprise Storage 6:

      zypper in -t patch SUSE-Storage-6-2022-52=1

   - SUSE CaaS Platform 4.5:

      To install this update, use the SUSE CaaS Platform 'skuba' tool. It
      will inform you if it detects new updates and let you then trigger
      updating of the complete cluster in a controlled way.

   - SUSE CaaS Platform 4.0:

      To install this update, use the SUSE CaaS Platform 'skuba' tool. It
      will inform you if it detects new updates and let you then trigger
      updating of the complete cluster in a controlled way.



Package List:

   - SUSE Manager Server 4.1 (ppc64le s390x x86_64):

      libsndfile-debugsource-1.0.28-5.15.1
      libsndfile-devel-1.0.28-5.15.1
      libsndfile1-1.0.28-5.15.1
      libsndfile1-debuginfo-1.0.28-5.15.1

   - SUSE Manager Retail Branch Server 4.1 (x86_64):

      libsndfile-debugsource-1.0.28-5.15.1
      libsndfile-devel-1.0.28-5.15.1
      libsndfile1-1.0.28-5.15.1
      libsndfile1-debuginfo-1.0.28-5.15.1

   - SUSE Manager Proxy 4.1 (x86_64):

      libsndfile-debugsource-1.0.28-5.15.1
      libsndfile-devel-1.0.28-5.15.1
      libsndfile1-1.0.28-5.15.1
      libsndfile1-debuginfo-1.0.28-5.15.1

   - SUSE Linux Enterprise Server for SAP 15-SP2 (ppc64le x86_64):

      libsndfile-debugsource-1.0.28-5.15.1
      libsndfile-devel-1.0.28-5.15.1
      libsndfile1-1.0.28-5.15.1
      libsndfile1-debuginfo-1.0.28-5.15.1

   - SUSE Linux Enterprise Server for SAP 15-SP1 (ppc64le x86_64):

      libsndfile-debugsource-1.0.28-5.15.1
      libsndfile-devel-1.0.28-5.15.1
      libsndfile1-1.0.28-5.15.1
      libsndfile1-debuginfo-1.0.28-5.15.1

   - SUSE Linux Enterprise Server for SAP 15 (ppc64le x86_64):

      libsndfile-debugsource-1.0.28-5.15.1
      libsndfile-devel-1.0.28-5.15.1
      libsndfile1-1.0.28-5.15.1
      libsndfile1-debuginfo-1.0.28-5.15.1

   - SUSE Linux Enterprise Server 15-SP2-LTSS (aarch64 ppc64le s390x x86_64):

      libsndfile-debugsource-1.0.28-5.15.1
      libsndfile-devel-1.0.28-5.15.1
      libsndfile1-1.0.28-5.15.1
      libsndfile1-debuginfo-1.0.28-5.15.1

   - SUSE Linux Enterprise Server 15-SP2-BCL (x86_64):

      libsndfile-debugsource-1.0.28-5.15.1
      libsndfile-devel-1.0.28-5.15.1
      libsndfile1-1.0.28-5.15.1
      libsndfile1-debuginfo-1.0.28-5.15.1

   - SUSE Linux Enterprise Server 15-SP1-LTSS (aarch64 ppc64le s390x x86_64):

      libsndfile-debugsource-1.0.28-5.15.1
      libsndfile-devel-1.0.28-5.15.1
      libsndfile1-1.0.28-5.15.1
      libsndfile1-debuginfo-1.0.28-5.15.1

   - SUSE Linux Enterprise Server 15-SP1-BCL (x86_64):

      libsndfile-debugsource-1.0.28-5.15.1
      libsndfile-devel-1.0.28-5.15.1
      libsndfile1-1.0.28-5.15.1
      libsndfile1-debuginfo-1.0.28-5.15.1

   - SUSE Linux Enterprise Server 15-LTSS (aarch64 s390x):

      libsndfile-debugsource-1.0.28-5.15.1
      libsndfile-devel-1.0.28-5.15.1
      libsndfile1-1.0.28-5.15.1
      libsndfile1-debuginfo-1.0.28-5.15.1

   - SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3 (x86_64):

      libsndfile-debugsource-1.0.28-5.15.1
      libsndfile1-32bit-1.0.28-5.15.1
      libsndfile1-32bit-debuginfo-1.0.28-5.15.1

   - SUSE Linux Enterprise Module for Basesystem 15-SP3 (aarch64 ppc64le s390x x86_64):

      libsndfile-debugsource-1.0.28-5.15.1
      libsndfile-devel-1.0.28-5.15.1
      libsndfile1-1.0.28-5.15.1
      libsndfile1-debuginfo-1.0.28-5.15.1

   - SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS (aarch64 x86_64):

      libsndfile-debugsource-1.0.28-5.15.1
      libsndfile-devel-1.0.28-5.15.1
      libsndfile1-1.0.28-5.15.1
      libsndfile1-debuginfo-1.0.28-5.15.1

   - SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS (aarch64 x86_64):

      libsndfile-debugsource-1.0.28-5.15.1
      libsndfile-devel-1.0.28-5.15.1
      libsndfile1-1.0.28-5.15.1
      libsndfile1-debuginfo-1.0.28-5.15.1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (aarch64 x86_64):

      libsndfile-debugsource-1.0.28-5.15.1
      libsndfile-devel-1.0.28-5.15.1
      libsndfile1-1.0.28-5.15.1
      libsndfile1-debuginfo-1.0.28-5.15.1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (aarch64 x86_64):

      libsndfile-debugsource-1.0.28-5.15.1
      libsndfile-devel-1.0.28-5.15.1
      libsndfile1-1.0.28-5.15.1
      libsndfile1-debuginfo-1.0.28-5.15.1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS (aarch64 x86_64):

      libsndfile-debugsource-1.0.28-5.15.1
      libsndfile-devel-1.0.28-5.15.1
      libsndfile1-1.0.28-5.15.1
      libsndfile1-debuginfo-1.0.28-5.15.1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS (aarch64 x86_64):

      libsndfile-debugsource-1.0.28-5.15.1
      libsndfile-devel-1.0.28-5.15.1
      libsndfile1-1.0.28-5.15.1
      libsndfile1-debuginfo-1.0.28-5.15.1

   - SUSE Enterprise Storage 7 (aarch64 x86_64):

      libsndfile-debugsource-1.0.28-5.15.1
      libsndfile-devel-1.0.28-5.15.1
      libsndfile1-1.0.28-5.15.1
      libsndfile1-debuginfo-1.0.28-5.15.1

   - SUSE Enterprise Storage 6 (aarch64 x86_64):

      libsndfile-debugsource-1.0.28-5.15.1
      libsndfile-devel-1.0.28-5.15.1
      libsndfile1-1.0.28-5.15.1
      libsndfile1-debuginfo-1.0.28-5.15.1

   - SUSE CaaS Platform 4.5 (aarch64 x86_64):

      libsndfile-debugsource-1.0.28-5.15.1
      libsndfile-devel-1.0.28-5.15.1
      libsndfile1-1.0.28-5.15.1
      libsndfile1-debuginfo-1.0.28-5.15.1

   - SUSE CaaS Platform 4.0 (x86_64):

      libsndfile-debugsource-1.0.28-5.15.1
      libsndfile-devel-1.0.28-5.15.1
      libsndfile1-1.0.28-5.15.1
      libsndfile1-debuginfo-1.0.28-5.15.1


References:

   https://www.suse.com/security/cve/CVE-2021-4156.html
   https://bugzilla.suse.com/1194006