SUSE Security Update: Security update for polkit
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:0191-1
Rating:             important
References:         #1194568 
Cross-References:   CVE-2021-4034
Affected Products:
                    SUSE Linux Enterprise Server for SAP 15-SP1
                    SUSE Linux Enterprise Server for SAP 15
                    SUSE Linux Enterprise Server 15-SP1-LTSS
                    SUSE Linux Enterprise Server 15-SP1-BCL
                    SUSE Linux Enterprise Server 15-LTSS
                    SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS
                    SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS
                    SUSE Linux Enterprise High Performance Computing 15-LTSS
                    SUSE Linux Enterprise High Performance Computing 15-ESPOS
                    SUSE Enterprise Storage 6
                    SUSE CaaS Platform 4.0
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for polkit fixes the following issues:

   - CVE-2021-4034: Fixed a local privilege escalation in pkexec
     (bsc#1194568).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Server for SAP 15-SP1:

      zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP1-2022-191=1

   - SUSE Linux Enterprise Server for SAP 15:

      zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2022-191=1

   - SUSE Linux Enterprise Server 15-SP1-LTSS:

      zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-LTSS-2022-191=1

   - SUSE Linux Enterprise Server 15-SP1-BCL:

      zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-BCL-2022-191=1

   - SUSE Linux Enterprise Server 15-LTSS:

      zypper in -t patch SUSE-SLE-Product-SLES-15-2022-191=1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-LTSS-2022-191=1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-ESPOS-2022-191=1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-2022-191=1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-2022-191=1

   - SUSE Enterprise Storage 6:

      zypper in -t patch SUSE-Storage-6-2022-191=1

   - SUSE CaaS Platform 4.0:

      To install this update, use the SUSE CaaS Platform 'skuba' tool. It
      will inform you if it detects new updates and let you then trigger
      updating of the complete cluster in a controlled way.



Package List:

   - SUSE Linux Enterprise Server for SAP 15-SP1 (ppc64le x86_64):

      libpolkit0-0.114-3.15.1
      libpolkit0-debuginfo-0.114-3.15.1
      polkit-0.114-3.15.1
      polkit-debuginfo-0.114-3.15.1
      polkit-debugsource-0.114-3.15.1
      polkit-devel-0.114-3.15.1
      polkit-devel-debuginfo-0.114-3.15.1
      typelib-1_0-Polkit-1_0-0.114-3.15.1

   - SUSE Linux Enterprise Server for SAP 15 (ppc64le x86_64):

      libpolkit0-0.114-3.15.1
      libpolkit0-debuginfo-0.114-3.15.1
      polkit-0.114-3.15.1
      polkit-debuginfo-0.114-3.15.1
      polkit-debugsource-0.114-3.15.1
      polkit-devel-0.114-3.15.1
      polkit-devel-debuginfo-0.114-3.15.1
      typelib-1_0-Polkit-1_0-0.114-3.15.1

   - SUSE Linux Enterprise Server 15-SP1-LTSS (aarch64 ppc64le s390x x86_64):

      libpolkit0-0.114-3.15.1
      libpolkit0-debuginfo-0.114-3.15.1
      polkit-0.114-3.15.1
      polkit-debuginfo-0.114-3.15.1
      polkit-debugsource-0.114-3.15.1
      polkit-devel-0.114-3.15.1
      polkit-devel-debuginfo-0.114-3.15.1
      typelib-1_0-Polkit-1_0-0.114-3.15.1

   - SUSE Linux Enterprise Server 15-SP1-BCL (x86_64):

      libpolkit0-0.114-3.15.1
      libpolkit0-debuginfo-0.114-3.15.1
      polkit-0.114-3.15.1
      polkit-debuginfo-0.114-3.15.1
      polkit-debugsource-0.114-3.15.1
      polkit-devel-0.114-3.15.1
      polkit-devel-debuginfo-0.114-3.15.1
      typelib-1_0-Polkit-1_0-0.114-3.15.1

   - SUSE Linux Enterprise Server 15-LTSS (aarch64 s390x):

      libpolkit0-0.114-3.15.1
      libpolkit0-debuginfo-0.114-3.15.1
      polkit-0.114-3.15.1
      polkit-debuginfo-0.114-3.15.1
      polkit-debugsource-0.114-3.15.1
      polkit-devel-0.114-3.15.1
      polkit-devel-debuginfo-0.114-3.15.1
      typelib-1_0-Polkit-1_0-0.114-3.15.1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (aarch64 x86_64):

      libpolkit0-0.114-3.15.1
      libpolkit0-debuginfo-0.114-3.15.1
      polkit-0.114-3.15.1
      polkit-debuginfo-0.114-3.15.1
      polkit-debugsource-0.114-3.15.1
      polkit-devel-0.114-3.15.1
      polkit-devel-debuginfo-0.114-3.15.1
      typelib-1_0-Polkit-1_0-0.114-3.15.1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (aarch64 x86_64):

      libpolkit0-0.114-3.15.1
      libpolkit0-debuginfo-0.114-3.15.1
      polkit-0.114-3.15.1
      polkit-debuginfo-0.114-3.15.1
      polkit-debugsource-0.114-3.15.1
      polkit-devel-0.114-3.15.1
      polkit-devel-debuginfo-0.114-3.15.1
      typelib-1_0-Polkit-1_0-0.114-3.15.1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS (aarch64 x86_64):

      libpolkit0-0.114-3.15.1
      libpolkit0-debuginfo-0.114-3.15.1
      polkit-0.114-3.15.1
      polkit-debuginfo-0.114-3.15.1
      polkit-debugsource-0.114-3.15.1
      polkit-devel-0.114-3.15.1
      polkit-devel-debuginfo-0.114-3.15.1
      typelib-1_0-Polkit-1_0-0.114-3.15.1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS (aarch64 x86_64):

      libpolkit0-0.114-3.15.1
      libpolkit0-debuginfo-0.114-3.15.1
      polkit-0.114-3.15.1
      polkit-debuginfo-0.114-3.15.1
      polkit-debugsource-0.114-3.15.1
      polkit-devel-0.114-3.15.1
      polkit-devel-debuginfo-0.114-3.15.1
      typelib-1_0-Polkit-1_0-0.114-3.15.1

   - SUSE Enterprise Storage 6 (aarch64 x86_64):

      libpolkit0-0.114-3.15.1
      libpolkit0-debuginfo-0.114-3.15.1
      polkit-0.114-3.15.1
      polkit-debuginfo-0.114-3.15.1
      polkit-debugsource-0.114-3.15.1
      polkit-devel-0.114-3.15.1
      polkit-devel-debuginfo-0.114-3.15.1
      typelib-1_0-Polkit-1_0-0.114-3.15.1

   - SUSE CaaS Platform 4.0 (x86_64):

      libpolkit0-0.114-3.15.1
      libpolkit0-debuginfo-0.114-3.15.1
      polkit-0.114-3.15.1
      polkit-debuginfo-0.114-3.15.1
      polkit-debugsource-0.114-3.15.1
      polkit-devel-0.114-3.15.1
      polkit-devel-debuginfo-0.114-3.15.1
      typelib-1_0-Polkit-1_0-0.114-3.15.1


References:

   https://www.suse.com/security/cve/CVE-2021-4034.html
   https://bugzilla.suse.com/1194568