SUSE Security Update: Security update for polkit
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:0524-1
Rating:             moderate
References:         #1195542 
Cross-References:   CVE-2021-4115
CVSS scores:
                    CVE-2021-4115 (SUSE): 3.3 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L

Affected Products:
                    SUSE Linux Enterprise Desktop 12-SP5
                    SUSE Linux Enterprise Server 12-SP5
                    SUSE Linux Enterprise Server for SAP Applications 12-SP5
                    SUSE Linux Enterprise Software Development Kit 12-SP5
                    SUSE Linux Enterprise Workstation Extension 12-SP5
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for polkit fixes the following issues:

   - CVE-2021-4115: Fixed a denial of service via file descriptor leak
     (bsc#1195542).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Workstation Extension 12-SP5:

      zypper in -t patch SUSE-SLE-WE-12-SP5-2022-524=1

   - SUSE Linux Enterprise Software Development Kit 12-SP5:

      zypper in -t patch SUSE-SLE-SDK-12-SP5-2022-524=1

   - SUSE Linux Enterprise Server 12-SP5:

      zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-524=1



Package List:

   - SUSE Linux Enterprise Workstation Extension 12-SP5 (x86_64):

      libpolkit0-32bit-0.113-5.27.1
      libpolkit0-debuginfo-32bit-0.113-5.27.1
      polkit-debugsource-0.113-5.27.1

   - SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le s390x x86_64):

      polkit-debuginfo-0.113-5.27.1
      polkit-debugsource-0.113-5.27.1
      polkit-devel-0.113-5.27.1
      polkit-devel-debuginfo-0.113-5.27.1

   - SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64):

      libpolkit0-0.113-5.27.1
      libpolkit0-debuginfo-0.113-5.27.1
      polkit-0.113-5.27.1
      polkit-debuginfo-0.113-5.27.1
      polkit-debugsource-0.113-5.27.1
      typelib-1_0-Polkit-1_0-0.113-5.27.1


References:

   https://www.suse.com/security/cve/CVE-2021-4115.html
   https://bugzilla.suse.com/1195542