SUSE Security Update: Security update for tomcat
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:0694-1
Rating:             important
References:         #1195255 
Cross-References:   CVE-2022-23181
CVSS scores:
                    CVE-2022-23181 (NVD) : 7 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-23181 (SUSE): 7 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Affected Products:
                    SUSE Linux Enterprise High Performance Computing 15-ESPOS
                    SUSE Linux Enterprise High Performance Computing 15-LTSS
                    SUSE Linux Enterprise Server 15-LTSS
                    SUSE Linux Enterprise Server for SAP 15
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for tomcat fixes the following issues:

   - CVE-2022-23181: Fixed time of check, time of use vulnerability that
     allowed local privilege escalation. (bsc#1195255)


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Server for SAP 15:

      zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2022-694=1

   - SUSE Linux Enterprise Server 15-LTSS:

      zypper in -t patch SUSE-SLE-Product-SLES-15-2022-694=1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-2022-694=1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-2022-694=1



Package List:

   - SUSE Linux Enterprise Server for SAP 15 (noarch):

      tomcat-9.0.36-3.90.1
      tomcat-admin-webapps-9.0.36-3.90.1
      tomcat-el-3_0-api-9.0.36-3.90.1
      tomcat-jsp-2_3-api-9.0.36-3.90.1
      tomcat-lib-9.0.36-3.90.1
      tomcat-servlet-4_0-api-9.0.36-3.90.1
      tomcat-webapps-9.0.36-3.90.1

   - SUSE Linux Enterprise Server 15-LTSS (noarch):

      tomcat-9.0.36-3.90.1
      tomcat-admin-webapps-9.0.36-3.90.1
      tomcat-el-3_0-api-9.0.36-3.90.1
      tomcat-jsp-2_3-api-9.0.36-3.90.1
      tomcat-lib-9.0.36-3.90.1
      tomcat-servlet-4_0-api-9.0.36-3.90.1
      tomcat-webapps-9.0.36-3.90.1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS (noarch):

      tomcat-9.0.36-3.90.1
      tomcat-admin-webapps-9.0.36-3.90.1
      tomcat-el-3_0-api-9.0.36-3.90.1
      tomcat-jsp-2_3-api-9.0.36-3.90.1
      tomcat-lib-9.0.36-3.90.1
      tomcat-servlet-4_0-api-9.0.36-3.90.1
      tomcat-webapps-9.0.36-3.90.1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS (noarch):

      tomcat-9.0.36-3.90.1
      tomcat-admin-webapps-9.0.36-3.90.1
      tomcat-el-3_0-api-9.0.36-3.90.1
      tomcat-jsp-2_3-api-9.0.36-3.90.1
      tomcat-lib-9.0.36-3.90.1
      tomcat-servlet-4_0-api-9.0.36-3.90.1
      tomcat-webapps-9.0.36-3.90.1


References:

   https://www.suse.com/security/cve/CVE-2022-23181.html
   https://bugzilla.suse.com/1195255