SUSE Security Update: Security update for zsh
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:0732-1
Rating:             important
References:         #1163882 #1196435 
Cross-References:   CVE-2019-20044 CVE-2021-45444
CVSS scores:
                    CVE-2019-20044 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
                    CVE-2019-20044 (SUSE): 7 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
                    CVE-2021-45444 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2021-45444 (SUSE): 7 CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Affected Products:
                    SUSE Linux Enterprise High Performance Computing 15-ESPOS
                    SUSE Linux Enterprise High Performance Computing 15-LTSS
                    SUSE Linux Enterprise Server 15-LTSS
                    SUSE Linux Enterprise Server for SAP 15
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for zsh fixes the following issues:

   - CVE-2021-45444: Fixed a vulnerability where arbitrary shell commands
     could be executed related to prompt expansion (bsc#1196435).
   - CVE-2019-20044: Fixed a vulnerability where shell privileges would not
     be properly dropped when unsetting the PRIVILEGED option (bsc#1163882).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Server for SAP 15:

      zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2022-732=1

   - SUSE Linux Enterprise Server 15-LTSS:

      zypper in -t patch SUSE-SLE-Product-SLES-15-2022-732=1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-2022-732=1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-2022-732=1



Package List:

   - SUSE Linux Enterprise Server for SAP 15 (ppc64le x86_64):

      zsh-5.6-3.11.1
      zsh-debuginfo-5.6-3.11.1
      zsh-debugsource-5.6-3.11.1

   - SUSE Linux Enterprise Server 15-LTSS (aarch64 s390x):

      zsh-5.6-3.11.1
      zsh-debuginfo-5.6-3.11.1
      zsh-debugsource-5.6-3.11.1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS (aarch64 x86_64):

      zsh-5.6-3.11.1
      zsh-debuginfo-5.6-3.11.1
      zsh-debugsource-5.6-3.11.1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS (aarch64 x86_64):

      zsh-5.6-3.11.1
      zsh-debuginfo-5.6-3.11.1
      zsh-debugsource-5.6-3.11.1


References:

   https://www.suse.com/security/cve/CVE-2019-20044.html
   https://www.suse.com/security/cve/CVE-2021-45444.html
   https://bugzilla.suse.com/1163882
   https://bugzilla.suse.com/1196435