SUSE Security Update: Security update for go1.18
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:1410-1
Rating:             moderate
References:         #1183043 #1193742 #1198423 #1198424 #1198427 
                    
Cross-References:   CVE-2022-24675 CVE-2022-27536 CVE-2022-28327
                   
CVSS scores:
                    CVE-2022-24675 (SUSE): 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2022-27536 (SUSE): 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2022-28327 (SUSE): 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Affected Products:
                    SUSE Linux Enterprise Desktop 15-SP3
                    SUSE Linux Enterprise Desktop 15-SP4
                    SUSE Linux Enterprise High Performance Computing 15-SP3
                    SUSE Linux Enterprise High Performance Computing 15-SP4
                    SUSE Linux Enterprise Module for Development Tools 15-SP3
                    SUSE Linux Enterprise Module for Development Tools 15-SP4
                    SUSE Linux Enterprise Server 15-SP3
                    SUSE Linux Enterprise Server 15-SP4
                    SUSE Linux Enterprise Server for SAP Applications 15-SP3
                    SUSE Linux Enterprise Server for SAP Applications 15-SP4
                    SUSE Manager Proxy 4.2
                    SUSE Manager Server 4.2
                    openSUSE Leap 15.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that solves three vulnerabilities and has two
   fixes is now available.

Description:

   This update for go1.18 fixes the following issues:

   - CVE-2022-24675: Fixed a stack overlow in Decode() in encoding/pem
     (bsc#1198423).
   - CVE-2022-28327: Fixed a crash due to refused oversized scalars in
     generic P-256 (bsc#1198424).
   - CVE-2022-27536: Fixed a crash in Certificate.Verify in crypto/x509
     (bsc#1198427).

   Bump go1.18 (bsc#1193742)


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-1410=1

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2022-1410=1

   - SUSE Linux Enterprise Module for Development Tools 15-SP4:

      zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP4-2022-1410=1

   - SUSE Linux Enterprise Module for Development Tools 15-SP3:

      zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP3-2022-1410=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      go1.18-1.18.1-150000.1.11.1
      go1.18-doc-1.18.1-150000.1.11.1

   - openSUSE Leap 15.4 (aarch64 x86_64):

      go1.18-race-1.18.1-150000.1.11.1

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      go1.18-1.18.1-150000.1.11.1
      go1.18-doc-1.18.1-150000.1.11.1

   - openSUSE Leap 15.3 (aarch64 x86_64):

      go1.18-race-1.18.1-150000.1.11.1

   - SUSE Linux Enterprise Module for Development Tools 15-SP4 (aarch64 ppc64le s390x x86_64):

      go1.18-1.18.1-150000.1.11.1
      go1.18-doc-1.18.1-150000.1.11.1

   - SUSE Linux Enterprise Module for Development Tools 15-SP4 (aarch64 x86_64):

      go1.18-race-1.18.1-150000.1.11.1

   - SUSE Linux Enterprise Module for Development Tools 15-SP3 (aarch64 ppc64le s390x x86_64):

      go1.18-1.18.1-150000.1.11.1
      go1.18-doc-1.18.1-150000.1.11.1

   - SUSE Linux Enterprise Module for Development Tools 15-SP3 (aarch64 x86_64):

      go1.18-race-1.18.1-150000.1.11.1


References:

   https://www.suse.com/security/cve/CVE-2022-24675.html
   https://www.suse.com/security/cve/CVE-2022-27536.html
   https://www.suse.com/security/cve/CVE-2022-28327.html
   https://bugzilla.suse.com/1183043
   https://bugzilla.suse.com/1193742
   https://bugzilla.suse.com/1198423
   https://bugzilla.suse.com/1198424
   https://bugzilla.suse.com/1198427