SUSE Security Update: Security update for ant
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:1418-1
Rating:             moderate
References:         #1188468 #1188469 
Cross-References:   CVE-2021-36373 CVE-2021-36374
CVSS scores:
                    CVE-2021-36373 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
                    CVE-2021-36373 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
                    CVE-2021-36374 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
                    CVE-2021-36374 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Affected Products:
                    SUSE Linux Enterprise Desktop 15-SP3
                    SUSE Linux Enterprise Desktop 15-SP4
                    SUSE Linux Enterprise High Performance Computing 15-SP3
                    SUSE Linux Enterprise High Performance Computing 15-SP4
                    SUSE Linux Enterprise Module for Development Tools 15-SP3
                    SUSE Linux Enterprise Module for Development Tools 15-SP4
                    SUSE Linux Enterprise Realtime Extension 15-SP2
                    SUSE Linux Enterprise Server 15-SP3
                    SUSE Linux Enterprise Server 15-SP4
                    SUSE Linux Enterprise Server for SAP Applications 15-SP3
                    SUSE Linux Enterprise Server for SAP Applications 15-SP4
                    SUSE Manager Proxy 4.2
                    SUSE Manager Server 4.2
                    openSUSE Leap 15.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for ant fixes the following issues:

   - CVE-2021-36373: Fixed an excessive memory allocation when reading a
     specially crafted TAR archive (bsc#1188468).
   - CVE-2021-36374: Fixed an excessive memory allocation when reading a
     specially crafted ZIP archive (bsc#1188469).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-1418=1

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2022-1418=1

   - SUSE Linux Enterprise Realtime Extension 15-SP2:

      zypper in -t patch SUSE-SLE-Product-RT-15-SP2-2022-1418=1

   - SUSE Linux Enterprise Module for Development Tools 15-SP4:

      zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP4-2022-1418=1

   - SUSE Linux Enterprise Module for Development Tools 15-SP3:

      zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP3-2022-1418=1



Package List:

   - openSUSE Leap 15.4 (noarch):

      ant-1.10.7-150200.4.6.1
      ant-antlr-1.10.7-150200.4.6.1
      ant-apache-bcel-1.10.7-150200.4.6.1
      ant-apache-bsf-1.10.7-150200.4.6.1
      ant-apache-log4j-1.10.7-150200.4.6.1
      ant-apache-oro-1.10.7-150200.4.6.1
      ant-apache-regexp-1.10.7-150200.4.6.1
      ant-apache-resolver-1.10.7-150200.4.6.1
      ant-apache-xalan2-1.10.7-150200.4.6.1
      ant-commons-logging-1.10.7-150200.4.6.1
      ant-commons-net-1.10.7-150200.4.6.1
      ant-imageio-1.10.7-150200.4.6.1
      ant-javamail-1.10.7-150200.4.6.1
      ant-jdepend-1.10.7-150200.4.6.1
      ant-jmf-1.10.7-150200.4.6.1
      ant-jsch-1.10.7-150200.4.6.1
      ant-junit-1.10.7-150200.4.6.1
      ant-junit5-1.10.7-150200.4.6.1
      ant-manual-1.10.7-150200.4.6.1
      ant-scripts-1.10.7-150200.4.6.1
      ant-swing-1.10.7-150200.4.6.1
      ant-testutil-1.10.7-150200.4.6.1
      ant-xz-1.10.7-150200.4.6.1

   - openSUSE Leap 15.3 (noarch):

      ant-1.10.7-150200.4.6.1
      ant-antlr-1.10.7-150200.4.6.1
      ant-apache-bcel-1.10.7-150200.4.6.1
      ant-apache-bsf-1.10.7-150200.4.6.1
      ant-apache-log4j-1.10.7-150200.4.6.1
      ant-apache-oro-1.10.7-150200.4.6.1
      ant-apache-regexp-1.10.7-150200.4.6.1
      ant-apache-resolver-1.10.7-150200.4.6.1
      ant-apache-xalan2-1.10.7-150200.4.6.1
      ant-commons-logging-1.10.7-150200.4.6.1
      ant-commons-net-1.10.7-150200.4.6.1
      ant-imageio-1.10.7-150200.4.6.1
      ant-javamail-1.10.7-150200.4.6.1
      ant-jdepend-1.10.7-150200.4.6.1
      ant-jmf-1.10.7-150200.4.6.1
      ant-jsch-1.10.7-150200.4.6.1
      ant-junit-1.10.7-150200.4.6.1
      ant-junit5-1.10.7-150200.4.6.1
      ant-manual-1.10.7-150200.4.6.1
      ant-scripts-1.10.7-150200.4.6.1
      ant-swing-1.10.7-150200.4.6.1
      ant-testutil-1.10.7-150200.4.6.1
      ant-xz-1.10.7-150200.4.6.1

   - SUSE Linux Enterprise Realtime Extension 15-SP2 (noarch):

      ant-1.10.7-150200.4.6.1
      ant-antlr-1.10.7-150200.4.6.1
      ant-apache-bcel-1.10.7-150200.4.6.1
      ant-apache-bsf-1.10.7-150200.4.6.1
      ant-apache-log4j-1.10.7-150200.4.6.1
      ant-apache-oro-1.10.7-150200.4.6.1
      ant-apache-regexp-1.10.7-150200.4.6.1
      ant-apache-resolver-1.10.7-150200.4.6.1
      ant-commons-logging-1.10.7-150200.4.6.1
      ant-javamail-1.10.7-150200.4.6.1
      ant-jdepend-1.10.7-150200.4.6.1
      ant-jmf-1.10.7-150200.4.6.1
      ant-junit-1.10.7-150200.4.6.1
      ant-manual-1.10.7-150200.4.6.1
      ant-scripts-1.10.7-150200.4.6.1
      ant-swing-1.10.7-150200.4.6.1

   - SUSE Linux Enterprise Module for Development Tools 15-SP4 (noarch):

      ant-1.10.7-150200.4.6.1
      ant-antlr-1.10.7-150200.4.6.1
      ant-apache-bcel-1.10.7-150200.4.6.1
      ant-apache-bsf-1.10.7-150200.4.6.1
      ant-apache-log4j-1.10.7-150200.4.6.1
      ant-apache-oro-1.10.7-150200.4.6.1
      ant-apache-regexp-1.10.7-150200.4.6.1
      ant-apache-resolver-1.10.7-150200.4.6.1
      ant-commons-logging-1.10.7-150200.4.6.1
      ant-javamail-1.10.7-150200.4.6.1
      ant-jdepend-1.10.7-150200.4.6.1
      ant-jmf-1.10.7-150200.4.6.1
      ant-junit-1.10.7-150200.4.6.1
      ant-manual-1.10.7-150200.4.6.1
      ant-scripts-1.10.7-150200.4.6.1
      ant-swing-1.10.7-150200.4.6.1

   - SUSE Linux Enterprise Module for Development Tools 15-SP3 (noarch):

      ant-1.10.7-150200.4.6.1
      ant-antlr-1.10.7-150200.4.6.1
      ant-apache-bcel-1.10.7-150200.4.6.1
      ant-apache-bsf-1.10.7-150200.4.6.1
      ant-apache-log4j-1.10.7-150200.4.6.1
      ant-apache-oro-1.10.7-150200.4.6.1
      ant-apache-regexp-1.10.7-150200.4.6.1
      ant-apache-resolver-1.10.7-150200.4.6.1
      ant-commons-logging-1.10.7-150200.4.6.1
      ant-javamail-1.10.7-150200.4.6.1
      ant-jdepend-1.10.7-150200.4.6.1
      ant-jmf-1.10.7-150200.4.6.1
      ant-junit-1.10.7-150200.4.6.1
      ant-manual-1.10.7-150200.4.6.1
      ant-scripts-1.10.7-150200.4.6.1
      ant-swing-1.10.7-150200.4.6.1


References:

   https://www.suse.com/security/cve/CVE-2021-36373.html
   https://www.suse.com/security/cve/CVE-2021-36374.html
   https://bugzilla.suse.com/1188468
   https://bugzilla.suse.com/1188469