SUSE Security Update: Security update for firewalld, golang-github-prometheus-prometheus
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:1435-1
Rating:             important
References:         #1196338 #1197042 SLE-24373 SLE-24374 SLE-24375 
                    
Cross-References:   CVE-2022-21698
CVSS scores:
                    CVE-2022-21698 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2022-21698 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Affected Products:
                    SUSE Enterprise Storage 6
                    SUSE Linux Enterprise Desktop 15-SP3
                    SUSE Linux Enterprise High Performance Computing 15-SP3
                    SUSE Linux Enterprise Micro 5.1
                    SUSE Linux Enterprise Micro 5.2
                    SUSE Linux Enterprise Module for Basesystem 15-SP3
                    SUSE Linux Enterprise Module for Desktop Applications 15-SP3
                    SUSE Linux Enterprise Module for SUSE Manager Proxy 4.1
                    SUSE Linux Enterprise Module for SUSE Manager Proxy 4.2
                    SUSE Linux Enterprise Module for SUSE Manager Proxy 4.3
                    SUSE Linux Enterprise Server 15-SP3
                    SUSE Linux Enterprise Server for SAP Applications 15-SP3
                    SUSE Manager Proxy 4.1
                    SUSE Manager Proxy 4.2
                    SUSE Manager Proxy 4.3
                    SUSE Manager Server 4.2
                    openSUSE Leap 15.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that solves one vulnerability, contains three
   features and has one errata is now available.

Description:

   This update for firewalld, golang-github-prometheus-prometheus fixes the
   following issues:

   Security fixes for golang-github-prometheus-prometheus:

   - CVE-2022-21698: Denial of Service through unbounded cardinality, and
     potential memory exhaustion, when handling requests with non-standard
     HTTP methods (bsc#1196338).

   Other non security changes for golang-github-prometheus-prometheus:

   - Build `firewalld-prometheus-config` only for SUSE Linux Enterprise 15,
     15-SP1 and 15-SP2, and require `firewalld`.
   - Only recommends `firewalld-prometheus-config` as prometheus does not
     require it to run.
   - Create `firewalld-prometheus-config` subpackage (bsc#1197042,
     jsc#SLE-24373, jsc#SLE-24374, jsc#SLE-24375)

   Other non security changes for firewalld:
   - Provide dummy `firewalld-prometheus-config` package (bsc#1197042)


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-1435=1

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2022-1435=1

   - SUSE Linux Enterprise Module for SUSE Manager Proxy 4.3:

      zypper in -t patch SUSE-SLE-Module-SUSE-Manager-Proxy-4.3-2022-1435=1

   - SUSE Linux Enterprise Module for SUSE Manager Proxy 4.2:

      zypper in -t patch SUSE-SLE-Module-SUSE-Manager-Proxy-4.2-2022-1435=1

   - SUSE Linux Enterprise Module for SUSE Manager Proxy 4.1:

      zypper in -t patch SUSE-SLE-Module-SUSE-Manager-Proxy-4.1-2022-1435=1

   - SUSE Linux Enterprise Module for Desktop Applications 15-SP3:

      zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP3-2022-1435=1

   - SUSE Linux Enterprise Module for Basesystem 15-SP3:

      zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP3-2022-1435=1

   - SUSE Linux Enterprise Micro 5.2:

      zypper in -t patch SUSE-SUSE-MicroOS-5.2-2022-1435=1

   - SUSE Linux Enterprise Micro 5.1:

      zypper in -t patch SUSE-SUSE-MicroOS-5.1-2022-1435=1

   - SUSE Enterprise Storage 6:

      zypper in -t patch SUSE-Storage-6-2022-1435=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      golang-github-prometheus-prometheus-2.32.1-150100.4.9.2

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      golang-github-prometheus-prometheus-2.32.1-150100.4.9.2

   - openSUSE Leap 15.3 (noarch):

      firewall-applet-0.9.3-150300.3.6.1
      firewall-config-0.9.3-150300.3.6.1
      firewall-macros-0.9.3-150300.3.6.1
      firewalld-0.9.3-150300.3.6.1
      firewalld-lang-0.9.3-150300.3.6.1
      python3-firewall-0.9.3-150300.3.6.1

   - SUSE Linux Enterprise Module for SUSE Manager Proxy 4.3 (aarch64 ppc64le s390x x86_64):

      golang-github-prometheus-prometheus-2.32.1-150100.4.9.2

   - SUSE Linux Enterprise Module for SUSE Manager Proxy 4.2 (aarch64 ppc64le s390x x86_64):

      golang-github-prometheus-prometheus-2.32.1-150100.4.9.2

   - SUSE Linux Enterprise Module for SUSE Manager Proxy 4.1 (aarch64 ppc64le s390x x86_64):

      firewalld-prometheus-config-0.1-150100.4.9.2
      golang-github-prometheus-prometheus-2.32.1-150100.4.9.2

   - SUSE Linux Enterprise Module for Desktop Applications 15-SP3 (noarch):

      firewall-applet-0.9.3-150300.3.6.1
      firewall-config-0.9.3-150300.3.6.1

   - SUSE Linux Enterprise Module for Basesystem 15-SP3 (noarch):

      firewall-macros-0.9.3-150300.3.6.1
      firewalld-0.9.3-150300.3.6.1
      firewalld-lang-0.9.3-150300.3.6.1
      python3-firewall-0.9.3-150300.3.6.1

   - SUSE Linux Enterprise Micro 5.2 (noarch):

      firewalld-0.9.3-150300.3.6.1
      python3-firewall-0.9.3-150300.3.6.1

   - SUSE Linux Enterprise Micro 5.1 (noarch):

      firewalld-0.9.3-150300.3.6.1
      python3-firewall-0.9.3-150300.3.6.1

   - SUSE Enterprise Storage 6 (aarch64 x86_64):

      firewalld-prometheus-config-0.1-150100.4.9.2
      golang-github-prometheus-prometheus-2.32.1-150100.4.9.2


References:

   https://www.suse.com/security/cve/CVE-2022-21698.html
   https://bugzilla.suse.com/1196338
   https://bugzilla.suse.com/1197042