SUSE Security Update: Security update for python-Twisted
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:1477-1
Rating:             moderate
References:         #1198086 
Cross-References:   CVE-2022-24801
CVSS scores:
                    CVE-2022-24801 (NVD) : 8.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-24801 (SUSE): 6.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L

Affected Products:
                    SUSE Linux Enterprise High Performance Computing 15-SP3
                    SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3
                    SUSE Linux Enterprise Module for Server Applications 15-SP3
                    SUSE Linux Enterprise Realtime Extension 15-SP2
                    SUSE Linux Enterprise Server 15-SP3
                    SUSE Linux Enterprise Server for SAP Applications 15-SP3
                    SUSE Manager Proxy 4.2
                    SUSE Manager Server 4.2
                    openSUSE Leap 15.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for python-Twisted fixes the following issues:

   - CVE-2022-24801: Fixed to not be as lenient as earlier HTTP/1.1 RFCs to
     prevent HTTP request smuggling. (bsc#1198086)


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-1477=1

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2022-1477=1

   - SUSE Linux Enterprise Realtime Extension 15-SP2:

      zypper in -t patch SUSE-SLE-Product-RT-15-SP2-2022-1477=1

   - SUSE Linux Enterprise Module for Server Applications 15-SP3:

      zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP3-2022-1477=1

   - SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3:

      zypper in -t patch SUSE-SLE-Module-Packagehub-Subpackages-15-SP3-2022-1477=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      python-Twisted-debuginfo-19.10.0-150200.3.9.1
      python-Twisted-debugsource-19.10.0-150200.3.9.1
      python2-Twisted-19.10.0-150200.3.9.1
      python2-Twisted-debuginfo-19.10.0-150200.3.9.1
      python3-Twisted-debuginfo-19.10.0-150200.3.9.1

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      python-Twisted-debuginfo-19.10.0-150200.3.9.1
      python-Twisted-debugsource-19.10.0-150200.3.9.1
      python-Twisted-doc-19.10.0-150200.3.9.1
      python2-Twisted-19.10.0-150200.3.9.1
      python2-Twisted-debuginfo-19.10.0-150200.3.9.1
      python3-Twisted-19.10.0-150200.3.9.1
      python3-Twisted-debuginfo-19.10.0-150200.3.9.1

   - SUSE Linux Enterprise Realtime Extension 15-SP2 (x86_64):

      python3-Twisted-19.10.0-150200.3.9.1
      python3-Twisted-debuginfo-19.10.0-150200.3.9.1

   - SUSE Linux Enterprise Module for Server Applications 15-SP3 (aarch64 ppc64le s390x x86_64):

      python-Twisted-debuginfo-19.10.0-150200.3.9.1
      python-Twisted-debugsource-19.10.0-150200.3.9.1
      python3-Twisted-19.10.0-150200.3.9.1
      python3-Twisted-debuginfo-19.10.0-150200.3.9.1

   - SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3 (aarch64 ppc64le s390x x86_64):

      python-Twisted-debugsource-19.10.0-150200.3.9.1
      python3-Twisted-19.10.0-150200.3.9.1
      python3-Twisted-debuginfo-19.10.0-150200.3.9.1


References:

   https://www.suse.com/security/cve/CVE-2022-24801.html
   https://bugzilla.suse.com/1198086