SUSE: 2022:1484-1 important: git | LinuxSecurity.com

   SUSE Security Update: Security update for git
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:1484-1
Rating:             important
References:         #1181400 #1198234 
Cross-References:   CVE-2022-24765
CVSS scores:
                    CVE-2022-24765 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-24765 (SUSE): 7.3 CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

Affected Products:
                    SUSE Linux Enterprise Desktop 15-SP3
                    SUSE Linux Enterprise Desktop 15-SP4
                    SUSE Linux Enterprise High Performance Computing 15-SP3
                    SUSE Linux Enterprise High Performance Computing 15-SP4
                    SUSE Linux Enterprise Module for Basesystem 15-SP3
                    SUSE Linux Enterprise Module for Basesystem 15-SP4
                    SUSE Linux Enterprise Module for Development Tools 15-SP3
                    SUSE Linux Enterprise Module for Development Tools 15-SP4
                    SUSE Linux Enterprise Server 15-SP3
                    SUSE Linux Enterprise Server 15-SP4
                    SUSE Linux Enterprise Server for SAP Applications 15-SP3
                    SUSE Linux Enterprise Server for SAP Applications 15-SP4
                    SUSE Manager Proxy 4.2
                    SUSE Manager Server 4.2
                    openSUSE Leap 15.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that solves one vulnerability and has one errata
   is now available.

Description:

   This update for git fixes the following issues:

   - Updated to version 2.35.3:
     - CVE-2022-24765: Fixed a potential command injection via git worktree
       (bsc#1198234).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-1484=1

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2022-1484=1

   - SUSE Linux Enterprise Module for Development Tools 15-SP4:

      zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP4-2022-1484=1

   - SUSE Linux Enterprise Module for Development Tools 15-SP3:

      zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP3-2022-1484=1

   - SUSE Linux Enterprise Module for Basesystem 15-SP4:

      zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP4-2022-1484=1

   - SUSE Linux Enterprise Module for Basesystem 15-SP3:

      zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP3-2022-1484=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      git-2.35.3-150300.10.12.1
      git-arch-2.35.3-150300.10.12.1
      git-core-2.35.3-150300.10.12.1
      git-core-debuginfo-2.35.3-150300.10.12.1
      git-credential-gnome-keyring-2.35.3-150300.10.12.1
      git-credential-gnome-keyring-debuginfo-2.35.3-150300.10.12.1
      git-credential-libsecret-2.35.3-150300.10.12.1
      git-credential-libsecret-debuginfo-2.35.3-150300.10.12.1
      git-cvs-2.35.3-150300.10.12.1
      git-daemon-2.35.3-150300.10.12.1
      git-daemon-debuginfo-2.35.3-150300.10.12.1
      git-debuginfo-2.35.3-150300.10.12.1
      git-debugsource-2.35.3-150300.10.12.1
      git-email-2.35.3-150300.10.12.1
      git-gui-2.35.3-150300.10.12.1
      git-p4-2.35.3-150300.10.12.1
      git-svn-2.35.3-150300.10.12.1
      git-web-2.35.3-150300.10.12.1
      gitk-2.35.3-150300.10.12.1
      perl-Git-2.35.3-150300.10.12.1

   - openSUSE Leap 15.4 (noarch):

      git-doc-2.35.3-150300.10.12.1

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      git-2.35.3-150300.10.12.1
      git-arch-2.35.3-150300.10.12.1
      git-core-2.35.3-150300.10.12.1
      git-core-debuginfo-2.35.3-150300.10.12.1
      git-credential-gnome-keyring-2.35.3-150300.10.12.1
      git-credential-gnome-keyring-debuginfo-2.35.3-150300.10.12.1
      git-credential-libsecret-2.35.3-150300.10.12.1
      git-credential-libsecret-debuginfo-2.35.3-150300.10.12.1
      git-cvs-2.35.3-150300.10.12.1
      git-daemon-2.35.3-150300.10.12.1
      git-daemon-debuginfo-2.35.3-150300.10.12.1
      git-debuginfo-2.35.3-150300.10.12.1
      git-debugsource-2.35.3-150300.10.12.1
      git-email-2.35.3-150300.10.12.1
      git-gui-2.35.3-150300.10.12.1
      git-p4-2.35.3-150300.10.12.1
      git-svn-2.35.3-150300.10.12.1
      git-web-2.35.3-150300.10.12.1
      gitk-2.35.3-150300.10.12.1
      perl-Git-2.35.3-150300.10.12.1

   - openSUSE Leap 15.3 (noarch):

      git-doc-2.35.3-150300.10.12.1

   - SUSE Linux Enterprise Module for Development Tools 15-SP4 (aarch64 ppc64le s390x x86_64):

      git-2.35.3-150300.10.12.1
      git-arch-2.35.3-150300.10.12.1
      git-cvs-2.35.3-150300.10.12.1
      git-daemon-2.35.3-150300.10.12.1
      git-daemon-debuginfo-2.35.3-150300.10.12.1
      git-debuginfo-2.35.3-150300.10.12.1
      git-debugsource-2.35.3-150300.10.12.1
      git-email-2.35.3-150300.10.12.1
      git-gui-2.35.3-150300.10.12.1
      git-svn-2.35.3-150300.10.12.1
      git-web-2.35.3-150300.10.12.1
      gitk-2.35.3-150300.10.12.1
      perl-Git-2.35.3-150300.10.12.1

   - SUSE Linux Enterprise Module for Development Tools 15-SP4 (noarch):

      git-doc-2.35.3-150300.10.12.1

   - SUSE Linux Enterprise Module for Development Tools 15-SP3 (aarch64 ppc64le s390x x86_64):

      git-2.35.3-150300.10.12.1
      git-arch-2.35.3-150300.10.12.1
      git-cvs-2.35.3-150300.10.12.1
      git-daemon-2.35.3-150300.10.12.1
      git-daemon-debuginfo-2.35.3-150300.10.12.1
      git-debuginfo-2.35.3-150300.10.12.1
      git-debugsource-2.35.3-150300.10.12.1
      git-email-2.35.3-150300.10.12.1
      git-gui-2.35.3-150300.10.12.1
      git-svn-2.35.3-150300.10.12.1
      git-web-2.35.3-150300.10.12.1
      gitk-2.35.3-150300.10.12.1

   - SUSE Linux Enterprise Module for Development Tools 15-SP3 (noarch):

      git-doc-2.35.3-150300.10.12.1

   - SUSE Linux Enterprise Module for Basesystem 15-SP4 (aarch64 ppc64le s390x x86_64):

      git-core-2.35.3-150300.10.12.1
      git-core-debuginfo-2.35.3-150300.10.12.1
      git-debuginfo-2.35.3-150300.10.12.1
      git-debugsource-2.35.3-150300.10.12.1

   - SUSE Linux Enterprise Module for Basesystem 15-SP3 (aarch64 ppc64le s390x x86_64):

      git-core-2.35.3-150300.10.12.1
      git-core-debuginfo-2.35.3-150300.10.12.1
      git-debuginfo-2.35.3-150300.10.12.1
      git-debugsource-2.35.3-150300.10.12.1
      perl-Git-2.35.3-150300.10.12.1


References:

   https://www.suse.com/security/cve/CVE-2022-24765.html
   https://bugzilla.suse.com/1181400
   https://bugzilla.suse.com/1198234

SUSE: 2022:1484-1 important: git

May 2, 2022
An update that solves one vulnerability and has one errata is now available

Summary

This update for git fixes the following issues: - Updated to version 2.35.3: - CVE-2022-24765: Fixed a potential command injection via git worktree (bsc#1198234). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2022-1484=1 - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2022-1484=1 - SUSE Linux Enterprise Module for Development Tools 15-SP4: zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP4-2022-1484=1 - SUSE Linux Enterprise Module for Development Tools 15-SP3: zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP3-2022-1484=1 - SUSE Linux Enterprise Module for Basesystem 15-SP4: zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP4-2022-1484=1 - SUSE Linux Enterprise Module for Basesystem 15-SP3: zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP3-2022-1484=1 Package List: - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64): git-2.35.3-150300.10.12.1 git-arch-2.35.3-150300.10.12.1 git-core-2.35.3-150300.10.12.1 git-core-debuginfo-2.35.3-150300.10.12.1 git-credential-gnome-keyring-2.35.3-150300.10.12.1 git-credential-gnome-keyring-debuginfo-2.35.3-150300.10.12.1 git-credential-libsecret-2.35.3-150300.10.12.1 git-credential-libsecret-debuginfo-2.35.3-150300.10.12.1 git-cvs-2.35.3-150300.10.12.1 git-daemon-2.35.3-150300.10.12.1 git-daemon-debuginfo-2.35.3-150300.10.12.1 git-debuginfo-2.35.3-150300.10.12.1 git-debugsource-2.35.3-150300.10.12.1 git-email-2.35.3-150300.10.12.1 git-gui-2.35.3-150300.10.12.1 git-p4-2.35.3-150300.10.12.1 git-svn-2.35.3-150300.10.12.1 git-web-2.35.3-150300.10.12.1 gitk-2.35.3-150300.10.12.1 perl-Git-2.35.3-150300.10.12.1 - openSUSE Leap 15.4 (noarch): git-doc-2.35.3-150300.10.12.1 - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64): git-2.35.3-150300.10.12.1 git-arch-2.35.3-150300.10.12.1 git-core-2.35.3-150300.10.12.1 git-core-debuginfo-2.35.3-150300.10.12.1 git-credential-gnome-keyring-2.35.3-150300.10.12.1 git-credential-gnome-keyring-debuginfo-2.35.3-150300.10.12.1 git-credential-libsecret-2.35.3-150300.10.12.1 git-credential-libsecret-debuginfo-2.35.3-150300.10.12.1 git-cvs-2.35.3-150300.10.12.1 git-daemon-2.35.3-150300.10.12.1 git-daemon-debuginfo-2.35.3-150300.10.12.1 git-debuginfo-2.35.3-150300.10.12.1 git-debugsource-2.35.3-150300.10.12.1 git-email-2.35.3-150300.10.12.1 git-gui-2.35.3-150300.10.12.1 git-p4-2.35.3-150300.10.12.1 git-svn-2.35.3-150300.10.12.1 git-web-2.35.3-150300.10.12.1 gitk-2.35.3-150300.10.12.1 perl-Git-2.35.3-150300.10.12.1 - openSUSE Leap 15.3 (noarch): git-doc-2.35.3-150300.10.12.1 - SUSE Linux Enterprise Module for Development Tools 15-SP4 (aarch64 ppc64le s390x x86_64): git-2.35.3-150300.10.12.1 git-arch-2.35.3-150300.10.12.1 git-cvs-2.35.3-150300.10.12.1 git-daemon-2.35.3-150300.10.12.1 git-daemon-debuginfo-2.35.3-150300.10.12.1 git-debuginfo-2.35.3-150300.10.12.1 git-debugsource-2.35.3-150300.10.12.1 git-email-2.35.3-150300.10.12.1 git-gui-2.35.3-150300.10.12.1 git-svn-2.35.3-150300.10.12.1 git-web-2.35.3-150300.10.12.1 gitk-2.35.3-150300.10.12.1 perl-Git-2.35.3-150300.10.12.1 - SUSE Linux Enterprise Module for Development Tools 15-SP4 (noarch): git-doc-2.35.3-150300.10.12.1 - SUSE Linux Enterprise Module for Development Tools 15-SP3 (aarch64 ppc64le s390x x86_64): git-2.35.3-150300.10.12.1 git-arch-2.35.3-150300.10.12.1 git-cvs-2.35.3-150300.10.12.1 git-daemon-2.35.3-150300.10.12.1 git-daemon-debuginfo-2.35.3-150300.10.12.1 git-debuginfo-2.35.3-150300.10.12.1 git-debugsource-2.35.3-150300.10.12.1 git-email-2.35.3-150300.10.12.1 git-gui-2.35.3-150300.10.12.1 git-svn-2.35.3-150300.10.12.1 git-web-2.35.3-150300.10.12.1 gitk-2.35.3-150300.10.12.1 - SUSE Linux Enterprise Module for Development Tools 15-SP3 (noarch): git-doc-2.35.3-150300.10.12.1 - SUSE Linux Enterprise Module for Basesystem 15-SP4 (aarch64 ppc64le s390x x86_64): git-core-2.35.3-150300.10.12.1 git-core-debuginfo-2.35.3-150300.10.12.1 git-debuginfo-2.35.3-150300.10.12.1 git-debugsource-2.35.3-150300.10.12.1 - SUSE Linux Enterprise Module for Basesystem 15-SP3 (aarch64 ppc64le s390x x86_64): git-core-2.35.3-150300.10.12.1 git-core-debuginfo-2.35.3-150300.10.12.1 git-debuginfo-2.35.3-150300.10.12.1 git-debugsource-2.35.3-150300.10.12.1 perl-Git-2.35.3-150300.10.12.1

References

#1181400 #1198234

Cross- CVE-2022-24765

CVSS scores:

CVE-2022-24765 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

CVE-2022-24765 (SUSE): 7.3 CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

Affected Products:

SUSE Linux Enterprise Desktop 15-SP3

SUSE Linux Enterprise Desktop 15-SP4

SUSE Linux Enterprise High Performance Computing 15-SP3

SUSE Linux Enterprise High Performance Computing 15-SP4

SUSE Linux Enterprise Module for Basesystem 15-SP3

SUSE Linux Enterprise Module for Basesystem 15-SP4

SUSE Linux Enterprise Module for Development Tools 15-SP3

SUSE Linux Enterprise Module for Development Tools 15-SP4

SUSE Linux Enterprise Server 15-SP3

SUSE Linux Enterprise Server 15-SP4

SUSE Linux Enterprise Server for SAP Applications 15-SP3

SUSE Linux Enterprise Server for SAP Applications 15-SP4

SUSE Manager Proxy 4.2

SUSE Manager Server 4.2

openSUSE Leap 15.3

openSUSE Leap 15.4

https://www.suse.com/security/cve/CVE-2022-24765.html

https://bugzilla.suse.com/1181400

https://bugzilla.suse.com/1198234

Severity
Announcement ID: SUSE-SU-2022:1484-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.